SOLVED Unable to register host for the following reasons <blank>

  • I just got a new Dell Latitude E5570 to image for a staff member. I setup the BIOS as per our normal standards, and tried to boot it by the NIC. It gets an address, and loads the boot menu. I choose the option for a full host registration, but gives me the “Unable to register host for the following reasons: <blank>” message, scrolls through hardware details, then “Attempting to send inventory…”, followed by blank lines that keep scrolling.

    Trying advice from other threads, I upgraded the installation to 1.2.0 (and updated the database schema). I restarted the server, but no change. I have also tried downloading a newer kernel:

    /var/www/fog/service/ipxe# file bzImage
    bzImage: Linux kernel x86 boot executable bzImage, version 4.5.3 (root@debian64) #1 SMP Mon May 9 05:44:34 EDT 2016, RO-rootFS, swap_dev 0x6, Normal VGA
    /var/www/fog/service/ipxe# file bzImage32
    bzImage32: Linux kernel x86 boot executable bzImage, version 4.5.3 (root@debian64) #1 SMP Mon May 9 05:45:31 EDT 2016, RO-rootFS, swap_dev 0x6, Normal VGA
    /var/www/fog/service/ipxe# ls -lah
    total 35M
    drwxr-xr-x 3 fog      www-data 4.0K May 31 11:09 .
    drwxr-xr-x 3 www-data www-data 4.0K May 31 11:01 ..
    -rw-r--r-- 1 fog      www-data 1.1K May 31 11:01 advanced.php
    drwxr-xr-x 2 fog      fog      4.0K May 31 11:09 backup
    -rw-r--r-- 1 fog      www-data  44K May 31 11:01 bg.png
    -rw-r--r-- 1 fog      www-data  756 May 31 11:01 boot.php
    -rw-r--r-- 1 fog      www-data 6.8M May  9 03:27 bzImage
    -rw-r--r-- 1 fog      www-data 6.7M May  9 03:27 bzImage32
    -rw-r--r-- 1 fog      www-data 230K May 31 11:01 grub.exe
    -rw-r--r-- 1 fog      www-data 9.2M May 31 11:01 init_32.xz
    -rw-r--r-- 1 fog      www-data  11M May 31 11:01 init.xz
    -rw-r--r-- 1 fog      www-data  25K May 31 11:01 memdisk
    -rw-r--r-- 1 fog      www-data 1.8M May 31 11:01 memtest.bin

    Running Debug mode, it is not pulling an IP address after booting. It detects eth0 as a device when using the ip command, but not when using ifconfig. To query the kernel, uname -a returned: “Linux fogclient.localdomain 4.5.3 #1 SMP Mon May 9 05:44:34 EDT 2016 x86_64 GNU/Linux”, so it’s pulling the (current) latest kernel available. Both ifconfig and ip show the correct MAC address, but it looks like it’s not even attempting to contact the DHCP server again (tail -f /var/log/syslog | grep dhcpd is not showing the MAC address looking for an address after booting Debug mode).

    What more can I do or test? Is there another config file I should post?

  • @lukebarone You should use the file that works with most of your computers (most likely undionly.kkpxe) and for the rest should set DHCP reservations that just consist of the correct boot file, not IP.

  • That did it! Upgraded to the Trunk release, changed the boot option to intel.pxe in the DHCP server, and it’s letting me register now!

    Is it possible to eventually go back to the original option, ipxe.pxe? I only ask, just in case I have computers that do not use Intel’s drivers.

  • @lukebarone Those come with FOG Trunk. Try the other files I mentioned.

  • @Wayne-Workman Compatibility Checks - Network FAILS.

    I upgraded from 1.1.x to 1.2.0, trying to fix this issue. It was 0.32 when I started this job a couple years ago, though - 1.1.x has been working fine for at least a year now.

    DHCP is handing out a filename of “ipxe.pxe”. On the FOG server, in the /tftpboot folder, I have the following:

    # ls /tftpboot
    boot.txt  default.ipxe  ipxe.kkpxe  ipxe.kpxe  ipxe.krn  ipxe.pxe  memdisk  pxelinux.0.old  snponly.efi  undionly.kkpxe  undionly.kpxe  undionly.kpxe.INTEL  undionly.pxe  vesamenu.c32

    I will try changing my DHCP server to hand out undionly.pxe, and see if that fixes it… and no change! Same errors, and still failing the FOG check. It still loads the boot menu OK. I do not have the Intel or Realtek KPXE files - is that included somewhere with FOG?

  • Try to run the compatibility checks from the menu, see what they say.

    You could try a different boot file. Since you just updated to 1.2.0, I assume you’re coming from a much much older version of FOG, possibly 0.32?

    Check what file your DHCP service is handing out. Boot files to try would include undionly.kpxe, undionly.kkpxe.

    I was looking online for the specs of this model. Sadly, manufacturers anymore don’t seem to care about telling you exactly what NIC Chipset they used, who the NIC chipset manufacturer was, etc. Pretty poor if you ask me, I mean it’s only information on what you may buy thousands of for your organization. </rant>. If it’s an intel based NIC chipset, also try intel.kpxe, intel.kkpxe, or if it’s realtek then try realtek.kpxe or realtek.kkpxe.