FOG menu: Boot from hard disk - ignores BIOS settings

  • For public PCs
    OptiPlex 390 - BIOS (latest version, A11) is password protected, boot order is NIC, HDD

    If the F12 key is used to access the boot menu, items not in boot sequence (e.g. optical disc, USB drive) display as possibilities, but require BIOS password (earlier versions of BIOS hid these options)

    If the network cable is disconnected, PC cannot PXE boot, and will boot to HDD. But, if it is connected and the FOG menu ‘Boot from hard disk’ is invoked, it will boot to a bootable USB drive (or fail to boot if non-bootable USB drive is in slot).

    Is there any way to make changes in the FOG configuration which will cause the ‘Boot from hard disk’ to only boot from the HDD?

  • I’ve used davido38’s suggestion re: cctk. I can even remove the pxe boot from the boot order. Now, any boot other than the HDD requires the BIOS password, but I can use psexec to set the next boot to pxe and then use psshutdown to reboot so the PCs can be imaged. Great work-around.

  • @Wayne-Workman Version 1.2.0, the menu says it is up to date.

    @davido38 Since the PCs are on 24×7, I’m looking at your idea of using cctk to force a pxe boot only when I want to re-image.

  • @TRex What version of FOG are you using? If it’s an older version, it may be that the “exit to HDD” stuff is detecting bootable media in USB and choosing to exit to that.

  • why don’t you set the boot order to 1 HDD and set the wake on lan with pxe ? So the 390 will boot to pxe only if you use the wol.

    or you can install Dell cctk and use this command

    cctk --forcepxeonnextboot=enable --valsetuppwd=yourbiospassword

  • Tried downgrading BIOS: versions A10, A09, A07, A05 all showed the USB with ‘*Admin Password Required’ on right side when boot menu invoked (F12). Version A03 did not display the USB in the boot menu. But all BIOS versions, coming out of the FOG menu, booted to a USB even though ‘USB Storage Device’ was not checked.

    Obviously, I don’t know if an OptiPlex 390 which had never gone beyond version A03 would do this since I don’t have any in that condition.

  • BIOS settings: boot order is (1) NIC and (2) HDD. Other options are unchecked. If F12 is pressed, the boot menu appears. The boot menu has (1) NIC, (2) HDD, (3) CD/DVD, and then if a bootable USB is detected, the USB. Item(s) after the HDD entry have, on right side, ‘*Admin Password Required’ (there is a BIOS password). Earlier BIOS versions only displayed first two items (I’m not sure which version instituted the change; the current BIOS version is A11).

    Using the boot menu via F12, blocks trying to boot to optical disc or USB (which is what I want). But if it goes to the FOG menu, it will try to boot to the USB (but not the CD/DVD).

    Yes, if a (non-bootable) USB stick is left in, the PC will not boot. (This happened, which is what started this investigation.) If there is no USB stick, it will boot to hard drive.

  • @Sebastian-Roth said in FOG menu: Boot from hard disk - ignores BIOS settings:

    Anyone with Optiplex 390 able to confirm this??

    No need. @TRex you need to change the boot order in the system’s firmware, or (probably) press F12 during POST to select a temporary boot medium.

  • Moderator

    @TRex In our list of known working devices the OptiPlex 390 is listed as working fine. So I am wondering if this is a BIOS setting issue?!?

    it will boot to a bootable USB drive (or fail to boot if non-bootable USB drive is in slot).

    Seriously? If there is a non-bootable (or no) USB stick then it fails to boot? Is your BIOS configured to boot from USB first?

    Anyone with Optiplex 390 able to confirm this??

  • With the exit type set to ‘sanboot’ or ‘Grub style’ (tried it, even though these are Windows boxes), the BIOS settings are bypassed and the PC boots to a USB stick. When set to ‘exit’, it won’t boot. The ‘No Menu’ and ‘Hide Menu’ don’t seem to have any effect.

    (I can turn off the FOG server when we are open, but I’d only be able to create images during off hours.)

  • All my public PCs are Optiplex 390s, so it is happening on all one model. 🙂

    The mention of the ‘Host Bios Exit Type’ led me to FOG PXE Boot Menu Configuration. It was set to ‘sanboot’. I’ll experiment with some different settings.

  • Moderator

    Is this just this specific model doing this bad behavior or is it all models? My initial reaction is the exit mode for this system need to be modified from the global setting.

    i.e. in the host definition: Host Bios Exit Type maybe needs to be sanboot or just exit.