UEFI-PXE-Boot (Asus t100 Tablet)

  • Were trying to image 250 t100 tablets we have. We got three different network adapters as these tablets have no on board ethernet port. From what Ive read two of the three should work with it. When we boot to the network we get “Start pxe over ipv4” and then it just sits there. Not sure what to do at this point. Have read a lot of forum posts on this but haven’t gotten much luck. Is it even possible at this point. We have server 2008 for the dhcp, i read somewhere that we might need 2012. Other than that we have fog trunk, and have also changed option 67 to point towards ipxe.efi with no luck.

  • Moderator

    @K.Hays When booting into FOS this way we only need to ensure that the FOS kernel is updated to support new hardware.

    So as the developers release new version of the FOS engine all you need to do is download these files and move them to the previously created usb flash drive into the boot folder replacing the existing files.


    In regards to the usb network adapters. When you pxe boot uefi devices you MUST use network adapters recommended by the manufacturer to support pxe booting. When you usb boot into FOS you will have better luck with older USB 2.0 network adapters since those are most likely supported by the linux developers.

  • Also as a side not, the only Ethernet to usb adapters that worked were usb 2.0 10/100. Specifically the “Cable Matters USB 2.0 to 10/100 Fast Ethernet Network Adapter” and the “ASUS Network Adapter for Transformer Pad” (model number: 90-XB3900CA00040-). I tried three others that were usb 3.0, gig adapters and they did not work for whatever reason.

  • @george1421 This worked! Thanks a bunch, this is going to cut down maintenance time on these tablets immensely. Also thanks to everyone who took the time to look into this!

    The solution was to boot directly to the FOS engine using this guide:

    It did still take a usb hub, correct Ethernet adapters, and a flash drive but that is perfectly fine.

  • Moderator

    @K.Hays Now with FOS booting off from the usb drive, you MUST schedule a capture or deploy on the FOG server BEFORE you boot the target computer into FOS. If you don’t you will get a strange message about “type not being defined” or something similar.

  • Moderator

    @K.Hays said in UEFI-PXE-Boot (Asus t100 Tablet):

    @george1421 I did use both pxe files

    Well that is disappointing…

    OK then we move on to phase 3 usb booting the FOS engine directly. You will loose the tight integration between FOG and FOS but it will work.

    (look at the fog IM talk bubble in the forum tool tray)

  • @george1421 That sounds like no good. What’s available for me to try next?

  • Moderator

    @K.Hays The refind error is related to when the fog menu exits out after no selection is made. In efi mode it uses refind to locate the boot medium.

  • Moderator

    @K.Hays Can you try the ipxe7156.efi file in place of ipxe.efi (which you renamed on the flash drive). What you are seeing now is the hand off between iPXE and FOG blowing up just like between the PXE rom and iPXE.

  • @george1421 I did use both pxe files

  • @george1421 more in depth, what happens is: No matter what i click it gets to the point where it says “Init.xs… ok” Then it jumps back to the main fog screen, but plain black background and white text. There is also no highlight showing me what i hover over, and after a while of sitting at that screen it says

    http://x.x.x.x/fog/service/ipxe/refind.conf... ok
    http://x.x.x.x/fog/service/ipxe/refind.efi... ok
    Could not boot: Error ox7f048283 (http://ipxe.org/7f048283)
    Could not boot: Error ox7f048283 (http://ipxe.org/7f048283)
    Chainloading failed. hit 's' for the iPXE shell: reboot in 10 seconds
  • Moderator

    @K.Hays For example if you pick hardware compatibility test what error do you get? Post a clear picture taken with a mobile phone please.

    Did you also try to use the ipxe7<something>.efi one?

  • @george1421 So i was able to get to the fog menu with the assistance of the flash drive, but from there anything i try to do with it fails. Also the firmware is up to date.

  • Moderator

    @K.Hays Whelp, that means that iPXE kernel is OK and it boots into fog’s iPXE menu. So the issue is the hand-off between the onboard PXE rom and the iPXE kernel. In a nutshell this is a firmware issue with the hardware.

    So what can you do?

    1. Confirm that these tablets have the latest firmware installed and test again.
    2. Contact the vendor and report this firmware bug.
    3. Decide to move forward with usb booting and imaging that way. The iPXE kernel on the usb flash drive is taking over the responsibility to boot into the FOG kernel, we are just bypassing the faulty uefi firmware.

  • @george1421 said in UEFI-PXE-Boot (Asus t100 Tablet):


    Yep, that worked to get to the menu with the ipxe.efi file. So then what next?

    @JJ-Fullmer Also i had not tried your guide yet, i was wondering if there was an option other than that (since it had gotten further) but it seems like that is not the case 😛

  • Moderator

    Let me preface this with, this is not a FOG issue directly. It is either a uefi firmware issue or an iPXE issue not supporting the hardware.

    We have seen some pretty shoddy uefi pxe booting firmware on some vendor’s systems (I’m not implying this is the case here either). What I want to try with these ASUS T100 systems is this: We will create a iPXE usb boot drive to see if we can bypass the on-board firmware pxe boot. Hopefully we can get the ASUS T100’s into the fog menu. If the fog menu appears then we have a path forward for imaging these systems. If this doesn’t work then there is no reason to continue testing pxe boot kernels. Also, make sure you have the latest firmware install on these tablets since this issue is a year old. With any luck ASUS could have fixed the issue in the interim.

    I want you to do this for this test:

    1. Acquire a usb flash drive that is at least 4MB in size (yes I said only 4MB, larger will work but we only need 4MB of space).
    2. Format that usb flash drive - fat32. You can do this on a windows box or a linux box. The format must be fat32.
    3. On that newly formatted flash drive create the following path \EFI\BOOT (case should not be important, but use all caps as I posted).
    4. Now you will need 2 of the iPXE files from the fog server.
      Copy /tftpboot/ipxe.efi to \EFI\BOOT as BOOTX64.EFI
      Copy /tftpboot/i386-efi/ipxe.efi to \EFI\BOOT as BOOTIA32.EFI
    5. Eject the usb flash drive and then attempt to boot this ASUS device from the usb drive using the device’s boot menu.

    If the ipxe.efi files don’t work, please repeat the process above except use ipxe7156.efi from the fog server instead. For both the x64 and x86 files.

  • Testers

    @K.Hays Are you using the latest versions of the ipxe files?
    Because if you are try some older ones, like the ones labeled -7156 if you don’t have any sitting around.
    I was imaging a compute stick today and it wouldn’t boot into fox with the latest ipxe.efi file, it did work with an older one I still had that usb drive from a year ago when I wrote this post. I’ve had varying results of newer ipxe.efi files and the efi shell boot method.
    If the 7156 versions provided don’t work let me know and I’ll post the ones that are working for me right now.

  • @Tom-Elliott So far we’ve tried ipxe.efi, snponly.efi, intel.efi, realtek.efi. That’s just today so far.

  • @K.Hays What’s the boot file you’re using?

  • So its been almost a year now, but as summer maintenance is coming back up, these tablets are in question again. I was going to try what @JJ-Fullmer suggested, but i thought since it’s been a while ill try it normally once more. What i found was that it got to the point where it says “succeed to download NBP file” and then it proceeds to boot to windows. So it did connect to the fog server now.I would love to be able to do these without having to purchase several hubs/adapters/usb drives for the ability to have a good group going at once. If that’s what it comes to though, so be it. Also if it would be best to open a new topic, just let me know. Thank you!

    Since it’s been a while here are the specs on the server
    Fog Version: 1.4.0 - RC - 13
    Ubuntu 16.04