• Moderator

    I just created a new topic to not mix things up. People will be able to find things better if we keep them separated. I am sure @Jbob will be able to answer your questions!

  • @Louis-CSUSA I forked your posts to here: https://forums.fogproject.org/topic/7561/network-booting-a-mac

    Please post in there.

  • Developer

    Well this is indeed a bit odd. If running the launchctl commands start and stop the service, the service should start on its own based on your plist. Essentially this is what happens when the mac boots and hands off the thread to launchd. So hmmmmm. Permissions??? Perhaps!!

    Please run:

    ls -la /Library/LaunchDaemons/org.freeghost.daemon.plist


    ls -la /opt/fog-service

    This will verify permissions.

    Also, in security under System Preferences, try allowing apps from anywhere. This is obviously not a fix but certainly could help resolve a possible issue.

    Please post your results


  • @Jbob said in FOG client on Mac OS X:

    perhaps we could name it something like “Wait until users are logged off” and invert it, or have some (?) hover next ot it?

    I like that idea.

  • Senior Developer

    @Louis-CSUSA not a problem. I’ll have limited availability tomorrow as well. I’ll try and replicate the issue on the single Mac I have to test with (one of the difficulties of developing an OS X client ).

  • @Jbob Since this is our first time doing this, we can reimage this unit again and start from scratch tomorrow. I want to make sure that user-error (on our side) isn’t giving you bad data. We will report back more tomorrow.

    Thank you very much @Jbob!

  • Senior Developer

    The fact that you had to manually start it is a problem. Pinging @Tom-S for this conversation (I’ll be busy for the next several hours). As for the “Users are still logged in”, that is a checkbox in the web portal under a host/group


    Specifically the “Host changes every cycle”. If disabled, it will wait for users to log off first. @Tom-Elliott perhaps we could name it something like “Wait until users are logged off” and invert it, or have some (?) hover next ot it?

  • @Jbob Hey JBob, after the reboot it did not start on it’s own. We had to manually load it using the same command.

    As an aside, HostNameChanger said that users are still logged in, and enforce is disabled. Is that a setting on the OSX side that we need to change?

  • Senior Developer

    @Louis-CSUSA So after the newest reboot the client automatically started itself? Also, note to self: ignore the wtmp user in user tracker in the next release.

  • @Jbob The FOG log is starting to look normal now (like on the PC side). I was able to remove the “invalid security token” by hitting the Reset Encryption Settings as you suggested. Before that though, we did stop the service via launchtrl unload and rebooted again (for safe measure). I’ve attached our latest FOG log.

    When we installed the service the first time, we did perform a reboot right after.


  • Senior Developer

    @Louis-CSUSA Be sure to stop the service via the launchctl unload command I provided. The “Invalid security token” message can be fixed by a simple “Reset Encryption Settings” on the host via the fog web portal. What’s more concerning is that the service did not auto start itself on boot. Are you absolutely positive you restarted the machine after installing? Linux is the only OS capable (as of right now) of doing a complete service start without a reboot.

  • @Jbob Yup. (sorry for delays in response, keep hitting the 2 min forum delay.)

  • Senior Developer

    @Louis-CSUSA was this after you ran the launchctl command?

  • @Jbob Also, the FOG client DID show signs of life afterwards. It shows now the following:

    5/12/2016 3:59 PM Main Overriding exception handling
     5/12/2016 3:59 PM Main Bootstrapping Zazzles
     5/12/2016 3:59 PM Controller Initialize
     5/12/2016 3:59 PM Entry Creating obj
     5/12/2016 3:59 PM Controller Start
     5/12/2016 3:59 PM Service Starting service
     5/12/2016 3:59 PM Bus Became bus server
     5/12/2016 3:59 PM Bus {
      "self": true,
      "channel": "Status",
      "data": "{\n  \"action\": \"load\"\n}"
     5/12/2016 3:59 PM Bus Emmiting message on channel: Status
     5/12/2016 3:59 PM Client-Info Version: 0.10.6
     5/12/2016 3:59 PM Client-Info OS:      Mac
     5/12/2016 3:59 PM Middleware::Authentication Waiting for authentication timeout to pass
     5/12/2016 3:59 PM Middleware::Communication Download:
     5/12/2016 3:59 PM Data::RSA FOG Server CA cert found
     5/12/2016 3:59 PM Middleware::Authentication Cert OK
     5/12/2016 3:59 PM Middleware::Authentication ERROR: Could not get security token
     5/12/2016 3:59 PM Middleware::Authentication ERROR: Could not find file "/opt/fog-service/token.dat".
     5/12/2016 3:59 PM Middleware::Communication POST URL:
     5/12/2016 3:59 PM Middleware::Response Invalid security token
     5/12/2016 3:59 PM Client-Info Version: 0.10.6
     5/12/2016 3:59 PM Client-Info OS:      Mac
     5/12/2016 3:59 PM Middleware::Authentication Waiting for authentication timeout to pass
  • Senior Developer

    Ok, that indicates the daemon is setup properly and the user agents are working (somehow), can you try the other commands I posted (I edited my prior post).

  • @Jbob This is what I have so far after the first two commands.

    Last login: Thu May 12 15:46:46 on ttys000
    iMac:~ csusa$ sudo cat /Library/LaunchDaemons/org.freeghost.daemon.plist
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    iMac:~ csusa$ sudo ps ax | grep mono
      291   ??  S      0:00.57 /usr/local/bin/mono /opt/fog-service/FOGUserService.exe
      417 s000  S+     0:00.00 grep mono
    iMac:~ csusa$
  • Senior Developer

    From what I can tell launchd isn’t handling the plists properly for you. Can you provide the output of :
    sudo cat /Library/LaunchDaemons/org.freeghost.daemon.plist

    Then run and provide the output of sudo ps ax | grep mono

    Finally, try running sudo launchctl load -w /Library/LaunchDaemons/org.freeghost.daemon.plist and see what happens? Your /opt/fog-service/fog.log should begin filling up if it worked. You should then stop the service via sudo launchctl unload -w /Library/LaunchDaemons/org.freeghost.daemon.plist as the service wasn’t started “properly” and the user agents aren’t running.

    If that did not work for you (no content in fog.log), try using these commands to start/stop the client instead:

    sudo /opt/fog-service/control.sh start
    sudo /opt/fog-service/control.sh stop

    If no output is still in the fog.log file, perform an ls /opt/fog-service/ and cat /opt/fog-service/settings.json and paste both outputs here.

    I know it’s a lot of things to try, but i need to narrow down what is going wrong.

  • @Jbob Yup, sure did. I’ve attached the SmartInstaller.log file. FOG client file still shows as blank.


  • Senior Developer

    Did the SmartInstaller pass all the steps? You can safely re-run the installer ontop of an existing installation and it’ll perform a “repair” of sorts. After doing so can you post the SmartInstaller.log file which the installer will point you to when completed?

  • @Jbob The file in that path is currently empty. We’re running it on Yosemite at this time.