• Testers

    FOG 7188
    Client 0.9.12
    Ubuntu 14.04
    Windows 10

    First starting off with saying that I am in the process of testing windows 10 and learning about building an image with win 10, not as easy as it used to be.

    I am having an issue with a snapin, it is our wireless profile import, a simple cmd script that runs the netsh wlan add profile command to bring in our wireless profiles. It will work on Win 7 as a snap in. It will run on Win 10 if I run it manually, but when I run it as a snapin I get the following from the FOG client.

    SnapinClient ERROR: Could Not start snapin
    SnapinClient ERROR: The Specified executable is not a valid application for this OS platform.

    Any insight as to why it is not allowing it to run would be much appreciated.

  • Testers

    Setting the “runwith” to cmd.exe did work to run it. Thanks for the help.

    That makes sense, but why did it run the first time and not the second time then? Both times it was a batch file, with no “runwith” specified. Obviously it did not run correctly the first time, but it didn’t give an error. I know I run bat scripts quite often with FOG and don’t set the “runwith” argument. I guess I am going to definitely start adding it in as it can cause issues at times.

  • Senior Developer

    “The Specified executable is not a valid application for this OS platform.” A batch file is not a windows executable. You’ll need to set “RunWith” to cmd.exe and possibly “RunWithArgs” to /c

  • Testers


    I have attached a condensed log with the snapin client area, 2 different spots I found when I started looking again. So I just noticed it was when I changed the file name. It looks like the underscore is throwing an issue. I was able to repeat the error by changing the name back and forth.

    The script still is not working correctly on Win 10 for importing wireless profiles, but it is no longer giving the error. Now it just won’t import if run as a snapin, but will if manually run. Not sure if that is something you can assist with or if that is just a Win 10 stupidity issue.

  • Senior Developer

    Can you post the entire snapinclient section of the log?