Acer Aspire ES1-511-C0QQ Realtek 8169 driver.

  • Hi, Im a student and trying to set up a FOG server to work whit the programers computers. The laptops are Acer aspire ES1-511-C0QQ and have the realtek 8169 driver. The computers are dual booted ubuntu and windows 8.1. I have read that alot of pepole have problems with this driver and nic.

    The FOG server version is 1.2.0 and fog kernel 4.1.2. The server OS is CentOS 7.2.1511 and kernel 3.10.0-327.10.1.el7.x86_64. I have tried to change the tftp boot file and tested all of them. I can pxe other pcs but not these laptops and the fog server are for these Aces laptops.

    Edit: The tftp boot files i have tried i got from:

    Can any one help? any sugestions on what i can try next?

  • @george1421 okej ill check that out. Thanks!

  • Moderator

    @scheffman Thats great you have a working realtek card with the latest version.

    Just for clarity undionly.kpxe is a bios iPXE kernel, if you want to boot that Acer in uefi mode then you should “try” ipxe.efi. That is the recommended uefi iPXE kernel.

  • @Sebastian-Roth Hello again, so i have a working FOG trunk installation now, and the realtek card works with the undionly.kpxe, but only when booting to legacy mode. Greate work guys!

  • Sorry i am trying to upgrade to trunk, but got some errors on the installer so i cant test pxe boot now. I have made another post on that problem, so this isn’t relevant until i get trunk installed. Ill be back on this one if trunk cant pxe boot the r8169 driver.

  • Moderator

    @scheffman You gave a lot of valuable information in your first post but as George already said we need to know exactly what is going wrong and when - best if you can post a picture of the error on screen! 🙂

    Depending on where the error is (PXE ROM, iPXE, linux kernel) there is a different place to look into and make things work. You are talking about changing the tftp files (aka iPXE binaries) but also about “realtek 8169 driver” which makes me think about the linux kernel. Those are two different stories… I am sure we’ll figure it out as soon as you post a picture!

    PS: “writing a troubleshoot the bootup process guide” is on my todo list and I shall get into this later on today!

  • Moderator

    With these realtek drivers, they are a bit of a pain. With that said the first thing I would like you to do is to upgrade that 1.2.0 install to the trunk version (i.e. pre 1.3.0) The trunk version supports newer hardware as well as uefi firmware, gpt disks, and windows 10. The first two are marginally supported in 1.2.0 stable. <edit> If you have the other hardware booting with 1.2.0 there my not be an urgent need to upgrade to the trunk version. Maybe I would make this 3rd on the list of things to do </edit>

    Once you upgrade to the trunk version and you still have issues (I’ll guess yes), then it would be helpful if you posted a picture of the exact error. My guess it will be in the iPXE kernel where it can’t pick up an IP address. If this is the case insert a mini/unmanaged switch between the booting device and the building switch. See if you can boot then.

    Some things you need to check on the laptop. Find out if its booting in uefi mode or bios mode. That will dictate which iPXE boot kernel you will need.

    If pxe booting you can start with the undionly.kxpe boot image (for bios mode). Others have had success with the realtek nics and the ipxe.pxe boot image.