PXE booting on fresh Ubuntu 14.04 install

  • I have set up FOG on a Ubuntu 14.04 VM on virtualbox with a bridged connection. This is only a small testing environment, hence the less then production ready hypervisor. Installed Fog based on the information in several of the guides on the internet. The Fog server is up, but i cannot get a computer to PXE boot.

    I have added entries on our firewall that handles DHCP.

    Option 67 = /undionly.kxpe (i have also used undionly.0, unidonly.kxpe)
    Option 150 = fog or IP (i have tried both, neither work)

    When i try and PXE boot on the same subnet i get an IP. Then:
    TFTP. PXE-M0F: Exiting Intel Boot Agent
    On my computer i have manually used tftp to connect to the server (name and IP) and successfully downloaded the file.

    Any help i can get would be amazing.

  • @ghill Can you post screenshots of the area you’re working in to set Option 066 ? The immediate issues are probably there.

    But yeah I’d say set up an old computer for testing. And as far as testing iterations go, well… you only need one iteration if you’re following one of our more recent tutorials.

    Which brings me back to another point. You said you installed fog based on information in several guides on the internet… Are you aware that the fogproject has it’s own wiki? Things you find on other sites are highly likely to be very obsolete and will probably break more stuff and cause more complications when you try them on FOG Trunk with recent Linux versions.

  • @Wayne-Workman
    I too thought that was weird.
    The firewall that i am using (Fortinet Fortigate 60D, has a number of preset options. one is 150 (tftp server). I did some digging and apperantly 150 is a cisco only option meant for phones.
    I have manually entered option 66. but in a odd quirk of the firewall, manual options can only be in hex. I have set option 66 to the hex for the server name and IP. Neither works.

    I do have physical server i can test on. I was hoping to avoid it because snapshots allow for much faster iteration in testing. But it looks like i might need to bite the bullet.

  • Why are you using option 150? Do you plan to have multiple TFTP servers on the same network? Normally option 066 is set for this.

    Do you have an old computer to put FOG on instead of testing in a virtual box? I only ask because I haven’t used virtual box and a physical system on your network would greatly simplify your testing.