SOLVED Cannot mount <ip>/images, wrong IP is used

  • I was recently tasked with testing FOG for potential use in our environment. I created an Ubuntu Server, installed FOG (accepting the defaults by mistake), and then have been faced with several issues (most notably, the default IP is wrong).
    I’ve changed the IP in the FOG management console, and in several config files, but when the machine I’m trying to grab the image from PXE boots and attempts to mount the images folder, it’s trying to use the old default IP instead of the correct one. Where do I change this setting?

    (please be as specific as possible, I’m a Windows person trying for the first time to do Linux stuff, so I’m happy to have made it this far…)

  • @tgeyer What separate config would that be?

  • @Sebastian-Roth @Wayne-Workman I finally found the separate config location for this, and it is now capturing an image for me. Thanks for all the help!

  • @tgeyer This setting is inside the web interface, under storage management. It’s the IP address set for your storage node.

  • @Wayne-Workman I reran the installer as you suggested. I notice things are running a lot smoother, but when I tried to create the new image on the web interface, it hung up for a bit and showed an attempt to connect to “FOG ftp” which is the old default, not the correct server IP. I’ve Googled this and can’t seem to find where this setting is hidden…I’ve checked /etc/hosts, /etc/network/interfaces, /etc/vsftpd.conf…

  • @tgeyer Can you just re-run the installer and provide the right IP this time?

    Additionally, there are a whole lot of settings inside FOG Configuration -> FOG Settings you might want to go through each single one in there looking for the bad IP address. But I do concur with @Sebastian-Roth 's thoughts - that this is most likely a storage node setting.

    I’ll also add - FOG Trunk is really, really close to release. And I’d urge you to just go with FOG Trunk instead of 1.2.0 - you will very most likely find your 1.2.0 setup obsolete in only a few months from now - plus 1.2.0 has serious problems with properly detecting partitions, problems that FOG Trunk doesn’t have.

  • @Sebastian-Roth I went through all the web interface settings and made sure the had the correct IP. It seems to be in a config file somewhere. I’m running Fog 1.2.0 on Ubuntu 14.04.3 server.

  • There’s also a bit of work I’ve put together to allow fog to use any IP at any location and just work.

  • Moderator

    @tgeyer Should be in the ‘Storage Management’ on the web interface I’d say. By the way, which version of FOG are you using (see in the blue cloud in the web interface)?