SOLVED PXE Boot HP X2 210 (Hybrid tablet Windows 10 Pro)


  • Hi,

    We’ve just bought 32 HP tablet X2 210 (not really a tablet because it runs under Win 10 Pro…), which has USB 3.0 but no network port.
    Like other people, I tried to boot on PXE with USB to RJ45 adapter I found on a store near my office (ASIX AX88772C)
    It’s an UEFI bios so I had first to disable secure boot and it didn’t work with undionly.kpxe.
    If I specified an efi boot file (ipxe.efi or snp.efi), I’m able to boot on network, retrieve IP address and display Fog menu.
    BUT… That’s all…Any option I choose, screen stay black after loading file bzimage and initzx (for quick image I can enter credentials and choose image, but same problem after that)

    What can I change to complete task as quick registration or else ?

    Thanks for help, and my apologize because there are several topics on that subject, but each computer/adapter seems specific…

    Matthieu


  • @sebastian-roth
    thought it is not too old. My fault…
    We will update the server and see what happens.
    Thanks meanwhile.
    Have a nice week
    Greets
    JT

  • Moderator

    @bszadmin said in PXE Boot HP X2 210 (Hybrid tablet Windows 10 Pro):

    We are running fog 1.5.6

    Pretty old version of FOG, hmm!? You might want to grab newer version iPXE binaries from github and see if those work with your HP x2 210 G2.


  • @sebastian-roth
    Good morning, sorry for bringing up ths old topic.
    The clients are HP x2 210 G2 as @Matthieu-Jacquart guessed.
    The fog process stops here:
    de9e3322-e46b-4ef4-9a7a-7e69f74d6f98-image.png
    We are running fog 1.5.6 with kernel 5.10.50.
    Thanks for the support and the great work.
    Greets
    JT


  • @bszadmin Hi, old subject, this file was necessary few years ago to deploy image on X2 210 G1, but for at least 2 years everything works fine with official HP bios and Fog 1.5.
    What concern do you meet ? is it for X2 210 G1 or G2 (G2 always worked fine).
    Matthieu

  • Moderator

    @BSZAdmin Wow, this is bringing up a really old topic! Though I compiled this one off kernel I don’t have it anymore.

    Last time I wrote:

    I really hope I remembered correctly the change I made more than a year ago. Just compiled a new kernel which does not call the hanging function setup_efi_pci(). This is very ugly but seems to be a way to workaround this dang HP firmware bug!

    I might be able to do this again with a newer kernel version. So which version of FOG and which kernel version do you currently use?


  • @matthieu-jacquart
    Hey Matthieu, i also try to deploy HP X" 210 Tablets.
    I tried to download the mentioned bzImage_disabled… but the link is broken.
    Can you provide this image to me?
    Greets Jürgen


  • @sebastian-roth @Wayne-Workman No news for the moment but I’ll keep you in touch 😉

  • Moderator

    @Wayne-Workman No, they didn’t get back to me. But Matthieu just had another try and sent a new message two days ago. Let’s see what happens this time.

    We have an old firmware binary that might be useful to flash those devices with a fix. Though this has never been officially released and is missing other fixes that have been released since then. Let me know if you need help on this.


  • @sebastian-roth said in PXE Boot HP X2 210 (Hybrid tablet Windows 10 Pro):

    I’ll finish it and send it off then.

    Did you ever get a response?


  • @sebastian-roth Ok thanks, I’ll email you as soon as possible.

  • Moderator

    @Matthieu-Jacquart I am sorry but disabling these setup_efi_pci routine is a really dirty hack to make it work on those HP devices. We’re not going to include this into FOG not even with a “Host Kernel Parameter” thing.

    Sure I can send a message to those same guys but I kind of doubt that the fix will ever make it into the official firmware - whatever reason they have?!?! Would you mind preparing a piece of text so I don’t have to do this alone? Just read through the mail I sent you and put together a couple of lines. I’ll finish it and send it off then.


  • @sebastian-roth You’re just a master chief Seb ! It works perfectly !
    Do you think there’s any way to contact HP people to modify bios, or maybe (but I’m dreaming) just add an argument in fog Web UI “Host Kernel Arguments” ?
    Thanks a lot, once again 😉
    Matthieu

  • Moderator

    @Matthieu-Jacquart I really hope I remembered correctly the change I made more than a year ago. Just compiled a new kernel which does not call the hanging function setup_efi_pci(). This is very ugly but seems to be a way to workaround this dang HP firmware bug! Find bzImage_disabled_setup_efi_pci here.

    Turns out HP released at least two new firmware versions but didn’t include the (probably very tiny) fix we worked out together with them. As they even provided fixed firmware blobs to try out I have no idea why this didn’t make it into their official code base?!?

  • Moderator

    @Matthieu-Jacquart Oh yeah, I definitely remember this one. It’s been a long endeavor till we got this fixed. As far as I remember HP provided a fixed UEFI firmware. Just checked the mails in my archive and sent you the message via E-Mail:

    On Tue, 03 May 2016 16:11:34 +0200 JACQUART Matthieu <email deleted> wrote:
    Ok ! With Shell_Full.efi I was able to boot on EFI shell and to downgrade/upgrade bios, and everyhting works fine with Yu Max bios ! I was able to register hots (using ipxe.efi in DHCP options) without error, good !

    So I am a bit confused that you say things don’t work. I had the impression that HP actually fixed this and possibly also officially released a new firmware including that fix. But maybe I am wrong. Please read through the old message I send you via mail and let me know what’s up.

  • Moderator

    @matthieu-jacquart Ah ok, now I understand.

    Just be aware the developers are taking a short holiday for the rest of the month. So their response will be a bit slower. Just be aware so you can adjust your schedule.


  • @george1421 It’s a long story, but it’s an incompatibility between this HP model and fog kernel (HP never made modification for this model and last bios don’t change the problem), so the only solution in February 2016 was to modified fog kernel (big thanks to Seb for his work), and after that everyhting worked fine.
    But now I want to deploy these hybrid and with modified kernel (based on 4.3.3) I’ve got fog (1.5.0 RC8) message : kernel too old.

  • Moderator

    @matthieu-jacquart Has there been any movement on HP’s part to update the uefi firmware on this hardware?

    Is there a compatibility issue with the kernel your have vs the current release of FOG? Or is it just old and you want it updated? I’m just trying to understand the context.


  • @sebastian-roth Hi Seb and @tom-elliott, I re-open this topic because I need to deploy once again our hybrid HP X2 210, but modified bzimage that Seb provided to me (bzImage_rb) is now too old for fog (base on kernel 4.3.3).
    Without this I can’t deploy our 32 hybrid, is there any way to update the bzImage_rb ?
    Thanks
    Matthieu

  • Moderator

    Marking this thread solved for now as the OP is able to capture and deploy his tablets with the modified kernel. Although this is not a proper solution (more a hackish kind of workaround) we cannot do anything else than waiting for the people from HP we got in contact with to possibly fix the UEFI firmware!

    As of now the HP devs confirmed our findings (screwed memory addresses) but we haven’t heard back from them for two weeks now. No solution yet…

346
Online

9.0k
Users

15.6k
Topics

145.1k
Posts