• Testers

    I am trying to update tot he latest GIT version as of 1/11/16 3:15pm EST and I get a failure on “Creating SSL Cert”. everything else gives an ok, but the the webpage is no longer available. I am on Ubuntu 14.04 and I am up to date on it. I tried reinstalling and have had no luck getting the server to come back up. Can someone please help?

  • Testers

    @Wayne-Workman, Well I could just copy the key from a backup and be ok then. But the issue then comes into why did my snapins directory get cleared out and recreated. I hadn’t had that happen before. It should have been left there and the key should have been present. Might be an issue for @Tom-Elliott to look at. Unless he feels that this could have been a fluke. I might be able to copy my server in a couple days and try the update again and see if I get the same results with the snapin folder being cleared. But if it shouldn’t be cleared I will just copy the file from a back up for now.

    Although the new clients are working as is, even with the key missing.

    I appreciate the help and all the effort everyone puts into FOG. I wish I had more time to contribute to the product. But unfortunately I am not able to much at the time. So I understand the dedication it takes to keep this awesome product moving forward.

  • @ITSolutions There are some installation options for recreating the CA keys and SSL keys.

    I asked @Tom-Elliott, he says recreating the CA will cause all of your new FOG Service clients out there to stop working, and require reinstallation. But rebuilding the SSL keys should not.

    ./installfog.sh --help


    ./installfog.sh -K

    That should recreate the keys and the new fog client should still work.

  • Testers

    I just discovered a few other oddities that I hadn’t paid attention to as they were not want I was looking at. But my Snapin folder was empty so all of my snapin had been removed. I do have backups that I take daily of my server and was able to recover the files. But it is slightly odd and could point to an issue in the script. maybe.

  • Testers

    @Wayne-Workman, Yes, I did check and it is not there. I just checked again to make sure and no files are in that folder. but the folder does exist. Not sure where it is created. I did find there is a hidden file for the srvprivate key in the folder, that I didn’t see before. The permissions of the folder look like I would expect. But here is the output in case that is the issue.

    ls -la /opt/fog/snapins/ssl
    total 12
    drwxr-xr-x 2 fog www-data 4096 Jan 11 13:00 .
    drwxrwxr-x 4 fog www-data 4096 Jan 11 16:53 ..
    -rw-r--r-- 1 fog www-data 3243 Jul 22 10:46 .srvprivate.key

    BTW I do have a simple script I normally run that does a pull and update FOG. I hadn’t updated FOG in quite a while as I hadn’t been having issues and couldn’t affford the down time. But I had the time and wanted to get up to date so that is what started this. IDuring troubleshooting though I obviously did all commands manually. I can’t remember the version I went from but the commit number was 8927628 according to my git reflog if that helps.

  • @ITSolutions Have you went to see if it’s actually there or not? Have you checked for funky permissions? Try to run this:

    ls -lahRt /opt/fog

    That should recursively return every file and directory in /opt/fog and include permissions and access times.

  • Testers

    I found what the issue is, looks like I am missing a file somehow.

    /opt/fog/snapins/ssl/fog.csr: No such file or directory

    I even tried re-downloading the latest and still have the error. I then downloaded the previous commit and got the same error. I was able to install with the commenting out the goto error in the install script and everything including the client seems to be working. But not sure why that file is missing and not getting replaced when I re-install.

    So as it sits I am on 5927 with the system up and running. But still would like to figure out how to create the file and I guess report the bug of this file not being created to be used.

  • @ITSolutions Look inside of /var/log, you’ll find a bunch of fog_error_<version>.log files. The one with the highest version is generally the one you tried installing last. This file has all the errors that the installer returned.

    If you can post that, we can go from there.