• Hi,
    I try to imaging Windows 10 with FOG 1.2.0.
    I was able to install windows 10 launch sysprep and upload to FOG.
    But when i download my image on client i have error message :

    Windows boot manager
    Status : 0xc0000428
    Windows cannot verify the digital signature for this file

    I try this (https://wiki.fogproject.org/wiki/index.php/Vista_Image_says_0xc000000e_\windows\system32\winload.exe_can_not_be_loaded)
    And try to Disable Driver Signature completely before uploading.

    But nothing works.

    Have you succeded to upload/download Windows 10 with FOG 1.2.0 with sysprep ?


  • Senior Developer

    @Anil-Patil said:

    … but get error and not completing the process.

    Please tell us about what error (the exact message, best if you can take a picture or video!) you see and we might be able to help. Without knowing exactly what went wrong we cannot give you any advice.

  • Senior Developer

    @Anil-Patil what do you mean when you press enter the system starts?

  • Hi All,

    I have the issue with uploading Windows 10 image using fog 1.2.0.

    I have tried various combinations of Image creation, like selecting Operating System and Image Type, but get error and not completing the process. When I press Enter key the client system starts as usual.

    Please give me suggestions that whether I make mistake at any place

    Thanks in advance

  • @Wayne-Workman It’s work with Multiple Partition Image - Single Disk (Not Resizable) and my partition is resize by the sysprep options “ExtendOSPartition”

    Thanks !!

  • @Florent Try Multiple Partition Image - Single Disk (Not Resizable)

  • @Tom-Elliott Sorry i don’t understand i speak poor english ?

  • @Tom-Elliott Yes in image type i choose "Single Disk - Resizable"

  • Testers

    I’m guessing that you did a uefi image since it wants to use windows boot manager, which I believe is window’s uefi method.
    Was secure boot enabled on the computer that you uploaded from, could that cause a problem? I haven’t actually done any successful uefi imaging and haven’t really tried that hard because I’m personally yet to see why it’s worth it when mbr/bios/legacy works so well and I don’t have any 3+TB drives in my windows workstations at work.

    I have had success imaging windows 10 with legacy mode, just for a reference, I’m on the latest trunk, but I would bet 1.2 works with it.
    Granted I don’t use sysprep, I find that it likes to kill off my default profile. So I just manually uninstall devices in the device manager before imaging. It’s trickier, and involves more work, but it’s done sooner than it takes sysprep to run. But I’m getting off topic.

    Have you tried repairing the install with a win 10 disk. Auto repair. What ever the gpt/uefi equivalent of

    bootrec /rebuildbcd
    bootrec /fixboot
    bootrec /fixmbr

    is. (Fun fact shift+F10 gets you straight to a command line on a windows install disk instead of waiting to click through the menus)
    Or try the windows automatic repair that works like 10% of the time.
    You can also use diskpart to make sure the volume/disk/partition that got imaged is active.

    disk part
    select disk 0
    list partition
    select partition 1
    detail partition

    something like that, and then you can set it to active. That was a problem I used to have when I used the altiris imaging system, I’ve never had the problem with FOG.
    Granted you shouldn’t have to repair the install after imaging, especially if you run sysprep all proper, but if you can make it work then that might narrow down some possibilities.

    Can you disable secure boot in the bios settings on the computer not booting?
    Can you make sure secure boot was disabled on the computer you uploaded from, or if it was disabled try imaging with it enabled?
    I’m just guessing on the secure boot thing, might not even be a thing, but it seems like it could be relevant.

    I hate to suggest starting over on an image, but I would recommend making sure that you’re using bios/legacy/mbr boot mode. Unfortunately there is no way (that I have ever found anyway) to switch a computer between the two without reinstalling the OS because they use different partitioning types MBR and GPT. Also, when installing the OS in mbr mode, the easiest way I’ve found to ensure it’s a single disk (This hasn’t worked for uefi/gpt mode when I’ve tried) is to hit shift+f10 at the partition screen then do the following in the command line to clear the partitions and make only 1 full size partition

    list disk
    # select your disk, usually disk 0 unless you have more
    select disk 0
    create partition primary

    Hit refresh on the partition selection screen and viola. I got that from a forum post on here or related to fog somewhere many moons ago and have been using it forever.

    I seem to be rambling again.
    To sum up

    • Figure out if you’re in uefi or legacy mode
    • If you are in uefi mode, play with secure boot and try a repair disk
    • If you can, remake the image in bios/legacy/mbr mode
    • Hopefully something I said is helpful
  • Senior Developer

    @Florent is this setup as resize?

  • Disk is formatted as MBR.
    Device Model is an Dell Optiplex 7010 with wester digital disk.

    For OS type image in the choose list i try Windows 7 , Windows 8 and Windows 8.1 and problem is identical for all.

  • Senior Developer

    I’m jumping on a limb that you have uploaded the Windows 10 image as Resizable?

  • Is the disk formatted as MBR or GPT? What is the model of the device?

    As far as I know, 1.2.0 will work with any MBR formatted disk, and for Win7 and newer you’d just choose “Windows 7” as the OS type.