Unable to upload Windows 10 Image from hyper-V Windows 2012r2 to fog 0.32

  • Hello,
    i´m trying to upload a Windows 10 Image from a hyper-V VM ( Server 2012,r2 Generation 1 IDE Hard Drive) to the fog Server 0.32. Unfortunately I get Errors, when I try to register the Client to the Fog Server Fog error registration 2.JPG Fog error registration 1.JPG
    So I registrated the client manually on the server and started the upload-job getting the next error.
    Fog error 1.JPG
    I tried several different kernels (3.19.3 x86_64, 3.19.3 x86, 4.12 x86_64, 4.12 x86).
    Can you help me, please?

  • Senior Developer

    @sudburr he’s running 0.32 so x86 is the only usable kernel for him.

    He must use the x86 otherwise everything will break.

    That said I’d actually recommend using the 3.0.1 32 bit kernel. I say this as Windows 8/Windows 10 configs off of vm seem to break kernel loading. 3.0.1 apparently just works.

  • Windows 10 has nothing to do with it. It’s just data on a drive at this point.

    Three things come to mind. If you can successfully upload from another location, ignore #1.

    1. Run the following on your fog server
    sudo touch /images/.mntcheck
    sudo touch /images/dev/.mntcheck
    sudo chmod -R 777 /images
    cat /etc/exports
    - and observe whether /images and /images/dev are mounted correctly.
    1. Configure your VM’s network adapters
    • try uploading with just the legacy adapter connected
    • try uploading with both legacy and Ethernet adapter connected
    1. Try using kernel 3.18.5 x86_64 . Downloading only the x86 kernel to your fog server will have no effect because your client is booting with bzImage which is the x64 kernel.
  • Senior Developer

    @Warrender6 Thanks for the info. Makes more sense now to me. And I was pretty wrong with my guess about you being new to FOG.

    Still I think this NFS error is not mainly an issue with FOG 0.32 (hope I am right with this as I’ve never used it). Obviously PXE from within the VM is working or you wouldn’t even see what you have in the screenshots.

    I wonder how you could test if NFS is accessible from the VM. If you have Windows 10 Enterprise check out this: http://superuser.com/questions/525473/how-do-i-mount-an-nfs-share-in-windows-8 (Scroll down a little and see how to install NFS client and mount a share).

    Otherwise I’d recommend booting the client into debug mode (is this possible in 0.32) or using a linux live ISO. Wait till you get to a shell and try this:

    mkdir -p /mnt
    mount -t nfs -o nolock /mnt
    ls -al /mnt

    By the way. Which DHCP server is handing out the IPs and which IP is handed to the VM?

    I’d recommend not to upgrade yet - let’s make sure it’s not a hyper-V thing or some kind of setting issue.

  • First I want to thank you!
    I´m using Fog for 2 years. I image a lot of different hardware with Windows 7. Everything works fine and I said to myself: Never change a running system. Sometimes I had to update the kernel. So I`m a fan of the server 😉
    It is the first time that I want to get an Image from a Hyper-VM and it is the first time that I use Windows 10.
    The VM and the fog Server are in the same Subnet.
    What is the difference between fog 1.2.0 and fog trunk version?
    Do I need to upgrade Ubuntu? Now it is Ubuntu 12.4

  • Senior Developer

    @Warrender6 The error about NFS is not related to Windows 10 AFAIK. Can you share a little more information about what you are trying to achieve? Has this FOG server been used for some time or why did you install 0.32??

    If you have used the server for a while - do other clients work?

    To me this sounds like you are pretty new to FOG and just tried 0.32 for whatever reason. Wayne is right, give 1.2.0 a shot. But I still think that the issue is NFS related and might be still an issue after upgrading to 1.2.0…

  • @Warrender6 People here image via UEFI with PXE all the time… 1.2.0 has boot files with .efi extensions. The trunk version of FOG has even more.

    1.2.0 is svn version 2094. So using SVN, you can get it like this:

    sudo su
    cd /the/folder/you/want/to/put/the/installer/in
    yum install subversion    ###or apt-get install subversion
    svn co -r 2094 https://svn.code.sf.net/p/freeghost/code/trunk
    #that just initially checks out the 1.2.0 files. You still need to install it like below
    cd bin

    Read here for more details on using subversion: https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk although keep in mind that those instructions are written to get the LATEST trunk version of fog, and not 1.2.0. The instructions above that I’ve written for you will pull down 1.2.0’s files.

  • Thank you for your quick response!
    Do you have a howto for the upgrade from 0.32 to 1.2. I’m unable to find one.

    Is it true, that there is no way to image a Computer over Pxe with UEFI?

  • Senior Developer

    Well, “Network is unreachable” means exactly that - the client cannot talk to the NFS/FOG server because it is on a different subnet and it does not know how to talk to it. Please make sure your DHCP is handing out the correct IP and gateway/router information to the client.

  • @Warrender6 My first suggestion is to update to the latest stable version of FOG, version 1.2.0.

    Try that. If this doesn’t work, I know there has been progress made by the @Developers to make image capture from Hyper-V work better, and those changes are available in FOG Trunk.