• @drc0nc oh damn it.

    Let me guess, it isn’t working at all and you’re running kernel 4.3.0?

  • WP_20151110_002.jpg

  • @Sebastian-Roth Holy cow! that let me boot past init.xz!!! Now I’m getting the error Cannot find HDD on system when running host reg

  • @Sebastian-Roth awesome, will try today and will let you know!

  • Senior Developer

    @drc0nc We were just able to get some UEFI enabled devices up and running. See here: https://forums.fogproject.org/topic/6092/cannot-boot-into-fog-menu-in-uefi-mode

    You might try updating to the latest trunk and see if this works for you as well. Enable UEFI and use ipxe.efi…

  • @Sebastian-Roth Sorry, I haven’t tried booting iPXE via USB yet. But I have tried all the other pxe binaries through the network. It all comes to the same result. It just likes to turn the nic off and hang right after init.xz

  • Senior Developer

    @drc0nc Any new on this? I’d really love to see this working!

  • Senior Developer

    @drc0nc No, errors won’t be in any log file AFAIK. Only on screen.

    Have you tried other iPXE binaries? There are different ones coming with FOG. Change your DHCP settings to point to undionly.kkpxe (double ‘k’) or ipxe.pxe/kpxe/kkpxe and see if it makes any difference.

    Or should we try booting iPXE via CD/USB and load the kernel from there? I remember that some time ago it was impossible to boot iPXE over network on Mac OS X clients. Everyone just booted those via CD/USB. Has been fixed now for a while but maybe your HP books are also causing some kind of weird issue when booting iPXE over network. It’s pretty late here and I can’t go into the details of compiling iPXE just now. But you can try generating a USB/ISO file yourself online: https://rom-o-matic.eu/

    Select Advanced, USB or ISO, NIC type: undionly, PXE_STACK, IMAGE_BZIMAGE, CONSOLE_FRAMEBUFFER and the following three lines as embedded script:


    When you get to the iPXE shell you can issue different commands. For example loading kernel/initrd to boot (untested - so might have minor typos in it):

    kernel bzImage loglevel=7 debug initrd=init.xz root=/dev/ram0 rw ramdisk_size=127000
    imgfetch init.xz

  • @Sebastian-Roth I can usb boot into any OS, I just tried ubuntu. These streams are running windows 8.1 but i dont think that matters at this point.
    I dont know where to look if any errors do show up. would it be in a log file?

  • @Uncle-Frank I have a usb DVD drive and some bootable live linux sticks… I’ll pick my flavor and see what happens…
    Those dots only show up if I start an upload task from the web interface and it attempts to start. In those lines certain percentages scroll by then what you see there, that’s where it hangs.

  • Senior Developer

    Have you ever tried booting any sort of live linux on this? I guess it does not have a CD/DVD drive? Debian ISO files can be copied straight to USB stick (killing all the data on it so make sure to use an empty one): https://www.debian.org/releases/stable/i386/ch04s03.html.en

    I am very sorry but without error messages (unfortunately there are non as we see on the picture) I am pretty helpless…

    Edit: I wonder about those lines of dots… Not sure what that means. I don’t see them when adding debug here.

  • @Uncle-Frank So I enabled debug and cranked it to 7. Is there anywhere I should be looking for a log or something? I’m not seeing anything different.
    Edit: if I try debug mode it’ll add a line before /bzImage... ok it’ll show {IPaddress}/fog/service/ipxe/boot.php... ok
    If I manually add it as a host using mac the machine see it as registered. If I try to do a capture task the HP will see the task and try to start. It won’t go any farther than before. here is a pic of what happens WP_20151102_005.jpg

  • Senior Developer

    @drc0nc The file sizes look pretty good to me! “mess of crazy characters” sounds correct too (binary data). I totally forgot that Tom added kernel debug and loglevel into the web interface already. So you can go to FOG Configuration -> FOG Settings -> FOG Boot Settings to enable FOG_KERNEL_DEBUG and crank up the FOG_KERNEL_LOGLEVEL to 7! Hope we will see any messages then!! Keeping my fingers crossed.

    I thought about maybe the kernel and initrd binaries not getting downloaded properly while the client boots up. But in the picture you posted some time ago it shows that both seam to load fine (AFAIK ok means loaded fine and verified on the client):

    /bzImage... ok
    /init.xz... ok

    Edit: The first message I see when enabling the DEBUG/LOGLEVEL settings is early console in setup code.

  • @Tom-Elliott the output of that was

    -rw-r--r-- 1 fog www-data  6799776 Oct 30 13:39 /var/www/html/fog/service/ipxe/bzImage
    -rw-r--r-- 1 fog www-data  6711552 Oct 30 13:39 /var/www/html/fog/service/ipxe/bzImage32
    -rw-r--r-- 1 fog www-data 15416784 Oct 30 13:39 /var/www/html/fog/service/ipxe/init_32.xz
    -rw-r--r-- 1 fog www-data 16361748 Oct 30 13:39 /var/www/html/fog/service/ipxe/init.xz

    @Uncle-Frank If I nano (preferred) into either one its just a mess of crazy characters

    If i just put debug into any argument it just hangs the same. Is there somewhere I can read an output of (if any) error?

  • Senior Developer

    Hmmm, good point! If the files are there you can either open them using a console editor (vi, pico, nano) or tools like less, more and cat. But you can also check out those using the file command:

    file /var/www/fog/service/ipxe/bzImage
    /var/www/fog/service/ipxe/bzImage: Linux kernel x86 boot executable bzImage, version 4.2.3 (root@debian64) #1 SMP Mon Oct 12 11:56:21 EDT 2015, RO-rootFS, swap_dev 0x6, Normal VGA

  • To me, this sounds more like the tasking did not download the inits or kernels at all. The file’s exist, but there’s nothing viable in them to operate with. My guess, to further help out, is these two files are either completely empty, OR they’re holding html data. Can you get us an output of:

    #If redhat:
    ls -lR /var/www/html/fog/service/ipxe/{bzImage,init}*
    #If debian:
    ls -lR /var/www/{,html/}fog/service/ipxe/{bzImage,init}*

    Then again, what do I know? 😏

  • Senior Developer

    Depending on where you wanna see more output, really! I’d prefer adding it to the kernel arguments for that client. Just play with it and see what you get. I have to admit that I haven’t tried myself. Anyway, we won’t be able to further assist if we don’t have any more information about this. I am just as “blind” as you are with no error messages…

  • @Uncle-Frank is that added after has_usb_nic=1 on the fog.reginput?
    or is this a separate kernel option after i would manually add the host. on host kernel arguments?.. this is an issue if i try to image or just do a registration.

  • Senior Developer

    Is this with added ‘debug’ to the kernel options??