SOLVED Snap in's all reporting cancelled on Server even when successful

  • Testers

    I am using the latest trunk, 4900 and the new client 0.9.5. My server is an Ubuntu 14.04 build and windows 7 64 bit pro clients. I cannot say when this exactly started happening or if it has always been there, but I do know it was happening on 4684, I think that was the version I was on when I started paying attention the history. This has been a somewhat intermittent issue as I can deploy it and it says complete sometimes, but not others.

    When I deploy a snapin, it will deploy correctly to the machine and everything is fine, except on the snapin history page it shows that it was cancelled instead of completed. I have checked the FOG.log and it shows a return code of 0, here is a snipit from one of the machines. fog.log . As you can see most of the snapins are batch files, they call software from elsewhere, but I also have am running a vbscript with cscript and still get the same result code. Which the result code is a clean error code, so it is a good exit code. Not sure if anyone else has encountered this or not, but can someone point me in the right direction as to why this might be?

    As you can see the run times are across the board for the same snapin, but don’t seem to affect weather the complete status is complete or cancelled. Let me know where else to look at for a reasoning for this

  • I’m solving this thread as the issue should be fixed. I imagine there may be issues in the future but only from a reporting standpoint. I have moved all of the states to use the task state class elements. Older data used to close tasks with a state is of 2. Task state is 2 is in-line so some of the reports may say this.