SOLVED Apache2 preconfigtest failed

  • I’ve been having trouble getting Fog to capture a Win8.1 image correctly. I read this about updating SVN which I tried.

    After running this, I am unable to get into my Fog management. I’ve determined Apache2 isn’t running. When I try to start the service I get the following error:

    Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You need to recompile PHP.

    Can anyone guide me on how to fix this? Thank you!

  • @Wayne-Workman Holy crap I got it working again. After upgrading to 14.04 I re-ran the SVN from the link previously mentioned and now I can access my fog server again.

  • @Wayne-Workman This was on Ubutnu 12.04 LTS.

    I have since updated to 14.04 but am having the same problem.

  • @tecnomuzik We need a little more information. What OS is fog running on? Distribution and version.

  • Not sure if this will help but I uninstall Apache2 and reinstalled. During the install I get the following error:

    The apache2 configtest failed. Output of config test was: apache2: Syntax error on line 140 of /etc/apache2/apache.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/ into server: /usr/lib/apache2/modules/ Cannot open shared object file: No such file or directory
    Action ‘configtest’ failed.

    Line 1 of apache2.conf reads as: IncludeOptional mods-enabled/*.load

    Line 1 of php5.load reads as: <IfModule mod_php5.c>

    Does this make sense to anyone?

    Thanks in advance!!