SOLVED FOG FTP login failed (?)

    • I installed several times FOG version 1.2 under Ubuntu 14.04 (desktop) just to be sure. I followed various tutorials (same steps more or less) : appropriate permissions, fog user, move images etc.

    • Fog worked perfectly right 😆 : importing of hosts, doing inventory, cloning of either Linux Ubuntu 12.04 or Windows 7 using the single disk multiple partitions mode, renaming of hosts etc.

    • The only problem I answered with a script was to restart each new graphical session the mysql service (or I got a message to update the database again and again on the login webpage each session) and the tftpd-hta one (apparently too fast to start).

    A few days ago and I setup things again today, I got the following error and still have it now : try cloning a w7 single disk resizable, 99,7% done (fog web interface / I destroy all the images so I have enough place on the harddisk)…

    [When I check what’s happening with the help of a terminal, I can see a temporary cloning in /home/images/dev done by root:root]

    … Then on the cloned PC, a fog FTP login error appears (with the password…) again and again.

    I check : but…

    Thanks in advance,

  • Senior Developer

    @cnaud86 What @ch3i is saying, is it’s still an FTP issue. You manually moving things around, or not, means it is most likely an FTP problem even still. That said, if all of the stuff is “working” automatically, there is still the chance that FTP just can’t read the file size as you would like.

  • I insist. The image is done, 1st into /dev then moved and available into images with the appropriate name and size. But through the webinterface, size = 0 depsite the storagenode shows me there is less space available.

  • Moderator

    @cnaud86 said:

    However the image size through the webinterface is 0

    have you tried to download the image ? If you have a size 0 it’s a FTP login problem.

  • Hi to all,
    Thanks for your help. I finally gave up with the 14.04 Ubuntu version, too unstable for the moment with fog.
    I set up fog 1.2 with Ubuntu 12.04 and it is working perfectly (no need to restart services etc.) except one problem I cannot possibly manage with.
    I’m cloning my 1st image (Windows 7 resizable). The cloning is OK (not stuck into the dev folder, can connect to the ftp with the fog user…). I can find the image done with the appropriate name into the images folder. (I move the images folder into the /home/fog/ folder).

    However the image size through the webinterface is 0 + root:root permissions on it despite the fact it is here in the images folder and cloned properly…

    Any help again welcome… Thanks

  • @cnaud86 said:

    1. I did have a look at the forums about FTP. For the moment, it is not solving the “Error: ftp_login”.

    I was referring to this 😉
    Look at the credentials section.

    What @Trevelyan posted looks like great stuff though. I’ve made note of his post.

  • Do a cat /etc/passwd and see if the output looks like this:


    If it does, there is no shell associated with the user. As root, try the following:

    chsh -s /bin/bash fog

    Let me know if that fixes it for you!

    1. Thanks for the fix about MYSQL. I’ve just followed the advice and it looks OK (no more asking for upgrading the DTB).

    2. I did have a look at the forums about FTP. For the moment, it is not solving the “Error: ftp_login”.

  • I think you might be suffering from a problem that affects a few newer-ubuntu platforms with 1.2.0.

    There’s a fix for it in here.

    And, for the record, there’s an article on troubleshooting FTP too. 😉 Use the WiKi’s search feature, type in the word “Troubleshoot” and see what pops up.