SOLVED Fog 1.2 "is a directory", "not a partclone image" download issue

  • I have images that are part-image from an old .32 server that I am updating . The current version that I am using is 1.2. Every time I update a part-image, it uploads the image fine. I can see it in my storage node and it all looks great. The problem is when I try and download the image. It gives me an error saying that it “is a directory” and it is “not a part-clone image.”. I realize when it uploads that it uploads as a part-clone type. When I check the image type, it lists it as a partclone image. So I am totally confused as to why it thinks the image is not a partclone image, yet it lists it as a partclone image. Any help would be appreciated, Thanks!

  • Senior Developer

    @dustindizzle11 This is a well known issue with 1.2. I fixed it almost two revs after releasing 1.2.0, but had many other bits that made it unfeasible to come out with another fix (and it was mid imaging season.)

  • I have just solved this issue. The problem is that the image was uploaded with the “vista” OS type. I think this must be broken in 1.2. I was able to recover my image by changing the name of the image file inside the folder to “sys.img.000” and changing the OS type of the image to “Windows 7”. To do this, simply browse on your master node, or where your images are stored and rename the largest file inside the image folder to the “sys.img.000”. I was able to fix two images I uploaded with the vista OS type.