SOLVED (Fog 1.2.0 & Ubuntu 14.04) - Initial image upload successful. Can't find image file on deployment.

  • Hello All,
    I’ve tried to find solutions, but I’m still stuck.

    I’ve just rolled out Fog 1.2.0 on Ub 14.04. Install was basically flawless and as default as it gets. No errors, all standard.

    The first image upload is from an HP 6530b (Win7) (Single-Resizable).
    When the machine uploads it pushes without any sign of an error.

    Before I attempt to download the image, the server acknowledges the size at see below.
    7-17-2015 12-46-53 PM.png

    My problem is when I attempt to deploy the image. The error on any of my HP6530 shows “Image File Not Found”. (not exact, not in front of system)

  • Just following up…

    The CentOS7 install (from link on previous) seemed pretty straight-forward.
    Only change was that I couldn’t rename eth0 from it’s preset ens32, but it’s working anyway.

    It’s up and I’m pushing my Win7 image now.

  • @Wayne-Workman thanks for the advise on stable versions of Linux to pair with 1.2! I’m not all about the latest and greatest but I do like to stay current if it’s not buggy. My goal is to get uefi devices going with fog. Everything else is a bonus when upgrading. 🙂

  • Don’t mean to keep kicking this issue… but I’ve been burning my weekend hours trying to get this server up and running. (I’m not new to FOG, but Linux is my weakness)

    I’ve just finished my 4th install of a minimal Ubuntu
    I’m getting stuck at the same point.

    “* Checking package: apache2 … Failed!”

    7-19-2015 1-27-49 PM.png

    Attempted all solution offered through Google (page4)… none clear up the issue.

    If CentOS is a better option… I’m all ears.
    Frustration is mounting.

    This piece of code did move the installation along…
    apt-get clean
    rm -rf /var/lib/apt/lists/*
    rm -rf /var/lib/apt/lists/partial/*
    apt-get clean
    apt-get update
    apt-get upgrade

    but now the deployment is only offering a “Download” (which appears to be a html/php doc) when I access http://(ip)/fog/management.

    please close this thread… I’ll be attempting CentOS via:

  • @Wayne-Workman Currently installing 12.04.5LTS. Thanks for the insight.

  • @Pontiac-CCSD-429 Ubuntu 12.04 is the best option for 1.2.0.

  • Thanks everyone for the quick comments.

    Thanks for the idea to move to Trunk… but as it stands I’m looking for more of my old .32 standby of (set it and forget it) type of deployment.

    I had attempted that same FTP password set as described in

    But maybe I have bigger issues, because that didn’t clear up the issue.

    I think the move to CentOS is probably a good option, but for whatever reason Ubuntu has been my choice (loyalty?) since getting my feet wet with Linux.

    Can I get a suggestion of which combo of (Ubuntu & FOG 1.2.0) would work out of the box? I think 12.04 seemed stable… but did it have the TFTP issue of needed restarted after reboot?

    I need to jump into the UEFI option as I’m seeing more Win8.x and inevitably Win10 around the corner.

    Looks like a How-To was created with 10.04LTS… maybe that’s a good place to start.

  • @Ahagel I’ve seen @Wolfbane8653 comment about how he uses 12.04 with 1.2.0 and even the latest FOG trunk.

    However, CentOS 6.x with 1.2.0 should be stable (if you wanted to switch to red-hat based).

    I think that it’s been explained to me one time before that FOG 1.2.0 was developed with Ubuntu in mind… I don’t really remember… but it’s also been explained to me that any last-year’s versions of red-hat based Linux worked fine with 1.2.0.

    Also, when say things like that, remember that - truely - nobody in the Linux community would make fun of you for using an older version of Linux. People in the Microsoft community will do that, but not folks from the Linux community. It’s totally OK to do that. We might make suggestions this way or that but absolutely nobody will make it anything negative or down or lesser. 🙂

  • Hey guys,

    I am having the exact same issue. I am running Ubuntu 14.04 and Fog 1.2.0 with default settings. It is set to store images on the default storage node in /images. When uploading a new image I created everything is smooth and I even show the data usage on the image file afterwards. Though when trying to push down an image I get the same error “image file not found” and when navigating to /images on my server there are no image files in place. So it was mentioned by @Wayne-Workman that this is fixed by upgrading to trunk as it fixes the DB loopback. I would prefer not to do this if possible. Are there any other known solutions to this issue? If not what is the most current and stable build when combing FOG and Ubuntu? Either way I upgraded from 0.32 for the uefi boot capabilities so I would like to atleast have that. Thank you in advance for any suggestions offered.

  • @Pontiac-CCSD-429 Please follow these steps to correct your FTP credentials, and then you should be good:

    However be warned that there is instability with FOG 1.2.0 on Ubuntu 14.04 and 15.04 due to the DB being told to use the local loopback address… this is fixed in FOG Trunk if you’re willing to try it out, you can follow one of these methods:

  • Steps tried so far.

    • (temp) image file is not seen in /images or /images/dev
    • chown 0777 on /images
    • verified my SQL password of being blank and the user “root”.
    • successfully tested ftp access from subnet via win7 box.
    • successfully tested tftp access from subnet via win7 box.

    edit grammer

    Random Screenshots
    7-17-2015 12-59-30 PM.png

    7-17-2015 1-01-30 PM.png

    7-17-2015 1-04-28 PM.png

    7-17-2015 1-08-31 PM.png

    7-17-2015 1-11-30 PM.png

    I’m stuck as a newbie to linux. Anything stand out to anyone?