SOLVED Multicasting fail: StorageNode Not found on this system.

  • Hi!

    I have an 1.2 version fog installation which cannot multicast, but steadily can unicast. In the multicast log, without having any task in queue I see a permanent error about no storage node, like in topic title. Where and what does it searches for as storage node if I have one working? I mean for unicast it uses the same (1 and only master node) node as it uses for multicast, right? Then why is that repeating log entry? As with 1.2 version this would have been the first multicast try (with 0.32 it worked fine) I checked log before I started a task and I saw error. Ofc I did try to do multicast, hopeing it is something buggy error in log (as I have storage node for unicast working, was not unnatural to hope), but I failed (after partclone starts it stucks there.

    background info:
    fog 1.2
    ubuntu 14.04.0 LTS
    interface name: p4p1 (when it asked interface name I entered this as this version of ubuntu already uses this method to name ethernet interfaces, not the old eth0 etc way.

    I tried the following:

    • testing nfs: mountable from other systems
    • ftp: login with user fog uses possible
    • mysql login test: login with fogstorage user possible (test from localhost via ssh)
    • wireshark to see what and where it sends: strange error reply: nfs3err_noent, which says for me that “No such file or directory. The file or directory name specified does not exist.” extra strange.
    • with fear in heart I did a reinstall of fog 1.2, no change
    • shut down v1.2, boot up oldie 0.32 to see its logs: no error in multicast log. well, as I used that version for years, even from older versions of fog I was sure I would see no error, but worth a try.

    Ofc I read through the forum entries regarding to multicast errors, found many entries about “storage node not found”, but I see it even without ever tried to multicast in error logs of multicast, so testing network with debugs maybe not relevant as first I should “solve the not found” situation before ever try to hope multicasting.

    Any suggestion where to see what makes those entries into log?

  • the restart did it for me:

    [09-14-17 8:44:09 pm] * Starting FOG Multicast Manager Service
    [09-14-17 8:44:14 pm] * Checking for new tasks every 10 seconds.
    [09-14-17 8:44:14 pm] * Starting service loop.
    [09-14-17 8:44:14 pm] * No tasks found!
    [09-14-17 8:44:24 pm] * No tasks found!
    [09-14-17 8:44:34 pm] * No tasks found!

  • Finally, done. Solution: few switch was not ok, network config was changed in a way we was not aware (other device needed different setup and was not properly separated. Now is ok! And, as for full solution multicast tables needed manual clearing. (when we had solved testing, clients seemed stuck, now they dont.)

    all ok now, mass tests will come soon for performance (as now multicast speed a bit low…

  • @Foglalt What we really need is a way to test if multicast works or not… It’s something I’ve been wanting to do but have put off researching.
    I’ll try to do that this weekend.

  • Ok, back again to testing a bit more. I read through the linked topic, but I think it is not that topic you wanted to show me. I am not sure, but I think I read one topic in which info was deleted from fog database tables, but not deleting and reinstalling what linked troubleshoot wiki page suggests.

    If I do the deletion and reinstallation, will I lose the host/settings information I made? I have a working unicast fog setup, I dont want to redo all during debug 🙂 Wayne, dont you remember the topic I mention? I was not too long ago, but I dont know good keywords for searching for it. Maybe you remember better.

  • @Foglalt I believe that this is the same problem as seen here:

    That person was using FOG 1.2.0 and Ubuntu 14.04, and the steps here to clear out certain tables in the DB and then restarting the multicast manager service worked:

  • i will be on vacation for a while and after it i will go back to test and debug it as we NEED multicast pretty soon 🙂

  • Can you check the multicast.log file? It seems, to me, that maybe the command simply isn’t starting? Or, maybe all client’s haven’t checked in?

  • Well, with a full resetup storage node problem solved. BUT, as always there is a but, multicast still not working. We did all on debug list as was suggested, but debug worked and normal multicast is not working (i mean it is stuck at the point of starting imaging with partclone).

    What if debug’s “log sendig” with udp sender/receiver pair works, but normal multicast is not working? What debug work to be done to find the bottleneck? Any more suggestion?

  • @pabloinza for me it is still no. but i am on a trail which may lead to goal. i have to do tests for it.

  • @Wayne-Workman said:

    service FOGMulticastManager restart

    Hi there. I colud solve this just restarting the pc and then it lets me restart the service whith: service FOGMulticastManager restart

  • @pabloinza

    No, not yet. We have some other issues what makes us delay it a bit, network staff has issues cos of powerfailures, things are not that happy 🙂 I will make them continue tests.

  • Hi pal. Could you solve this issue? I´m experiencing the same. Unicast works fine, but can´t achieve Multicast. Thanks in advance.

  • Sorry about forgetting to write I did restarted every single bits, services, hardware, etc.

  • @Foglalt Rebooting is not in your list of tried things… try rebooting.

    You can also try to restart the FOGMulticastManager as well.

    In Ubuntu, it should be something like…

    service FOGMulticastManager restart

  • No, this installation is from scratch, only 2-3 images (as file only) were from the old version. It is a lonely fog install, no other nodes at all. Where it stands as a lone image deploment tool no need for any other one. It is really strange that it cannot see the only node it actually uses for unicast deployment.

  • Is this 1.2.0 FOG server an upgrade from .32 ?

    Have you had other storage nodes connected to this FOG server in the past?

    Did you ever import a DB from another build?