UNSOLVED Upgrade 1.2.0 Install/Update Error

  • Hi,
    I work at a school district and I’m getting ready for the upcoming summer. We were running FOG 0.32 on an old version of Ubuntu and decided to upgrade both Ubuntu and FOG. We upgraded Ubuntu to version 12.XX and FOG to 1.2.0. After the installation we experienced a problem install the database, we are currently getting 113 errors. So far I have tried restarting, stopping and starting mysql. I have also tried reinstalling FOG but nothing seems to work. Any help is appreciated.

  • @Wayne-Workman Screen Shot 2015-07-02 at 9.20.13 AM.png This is a picture of the first 2 of 113 errors I get. I can post them all but it will take a long time. lol. Also I try backing up my FOG Configs but when I get to the FOG Configuration section in FOG there is not a Configuration Save section. I see this: Screen Shot 2015-07-02 at 9.29.08 AM.png

  • @the_duke Do you remember what command line you used to uninstall the SQL?

  • @Clifford-Raymond I did pretty much what these guys are telling you as well. After I initially upgraded and got the errors, wayne told me to uninstall mysql and reinstall it so I did. Then he told me to update my OS, but I went a step further and went ahead and upgraded from 12.04 to 14.04. After all that finished I was still getting the problems so I re-ran the installer and it took me a couple of times to but it finally worked itself out. I can’t really point to any one thing in particular that fixed it. Even after I first got it to working it was a little buggy (couldn’t search hosts or use host menu), and if I restarted the machine I would get the errors again. So I pretty much did everything except uninstalling and reinstalling mysql a couple of times and so far it is all good. Not sure, but I hope that helps some.

  • Also,

    Could you post a picture of the errors you’re seeing? It’d be greatly helpful.

  • You can always try to uninstall MySQL and MySQL-Server and then reinstall them…

    I’d recommend exporting your DB first (if you can) like this: FOG Configuration -> Configuration Save -> Export

  • It depends. sudo command relies on the local user, but it will only provide permissions if the user is in the proper sudo file and/or sudo group.

  • Thanks for your help. I tried it but that didn’t work either. I have a question about log ons though. If the server has multiple logons does it matter which logon the update/upgrade is done on? The reason I ask this question is because when we were originally trying to upgrade FOG from the designated user which had been used in the past we did not have the ability to do so. When we started, terminal did not have any root and whenever we tried to use the sudo command for the user account we were on nothing would happen. We ended up doing the whole upgrade from an admin account but we are not sure if that effects anything.

  • Ubuntu/Debian (aptitude) is normally updated by:

    sudo apt-get update
    sudo apt-get upgrade

  • I think someone else had this issue…

    Try to update your OS, not upgrade, update.

    Should be something like this but don’t quote me:
    [CODE]sudo apt-get update[/CODE]

    Then when that’s done, re-run your installer again.

  • I tried the installer again but I still get the errors.

  • Try to re-run the installer.

  • Not that I know of and so far we have never been asked for it.

  • Is there a MySQL password?