SOLVED Issues Downloading images

  • I am having an issue downloading images. I recently reran the installer to get the latest FOG Client and now when I try and download an image to a system I am getting “mount: mounting on /images failed: Permission Denied”

    I have two storage nodes the default one that gets set up when you install FOG and a second one that is an external drive that mounts to \images2. Nothing has changed other than re running the installer to get the new FOG Client.

  • no, it’s not.

    However, each storage node has it’s own NFS setup.

    So if you edit the image location in your /opt/fog/.fogsettings to be relevant for the node you’re on, the exports will be created following the proper nfs share point.

  • @Tom-Elliott

    Think it’s possible for the installer to read the storage node entries from the DB, and determine which ones are local, then build the /etc/exports file accordingly ?

    Just a thought.

  • Okay, note for the future. Reinstall overwrites the exports file

  • Check /etc/exports

    It probably got wrote over when you reinstalled for some reason… or changed…

    Make sure NFS is running, also. usually, if you give NFS a restart, any syntax errors that is inside /etc/exports become glaringly obvious.

  • Checked all that and issue still persists

  • check your storage node credentials, your FOG COnfig -> FOG Settings -> TFTP Server credentials, and reset (yes, reset) your local Linux fog user’s credentials.

    Then, when you’ve got all that done and working, make sure it doesn’t happen again by editing /opt/fog/.fogsettings