SOLVED Fog Imaging Log Report Not Working 1.2.0

  • This might be a quick one, but I cannot seem to get the FOG imaging log report to show anything in the web GUI. What happens is I will click the “Imaging Log” button in the GUI, then it will proceed to “(server)/fog/management/index.php?node=report&sub=imaging-log” I have version 1.2.0, which was upgraded from .31. I tried to search for any documentation about this, but came up empty. Has anyone experienced this problem with the FOG reports? If anyone has any ideas let me know, Thanks!

    Dustin Olson

  • @Tom-Elliott
    Makes perfect sense. Thanks again Tom!😃

  • some of that is to be expected.

    1.0.0 (and higher) use actual names in the type field, where before (0.32 and below) the type field was a letter and/or number.

    The checks only really care about the upload and download. The check is specific, if not download, must be upload. Hopefully that makes sense.

  • @Tom-Elliott
    I increased it to 256M, and it is working perfectly fine now, Thanks so much! I did notice after running a report though, that it said all the past “downloads” are “uploads”. Unless I am misunderstanding it, I would think they should be downloads. (picture attached) . I may be looking at it wrong, and it’s not a big deal, I just thought I would throw it out there incase this is incorrect. The image is showing times when I sent an image to a computer, “downloaded” to it. In the picture it shows as “Upload”.


  • Yes, it’s safe to update, but you will also have to restart apache once updated.

    I usually start small increments of double the last (e.g. 256M,512M, etc…)

    To restart apache service apache2 restart (ubuntu) service httpd restart (redhat)

  • Hi Tom,
    Just checked it and you are right, it is 128M. I am assuming I can safely increase this because this is the default limit. Is that correct? Thanks for the quick reply!

  • Check your /etc/php.ini (redhat) /etc/php/apache2/php.ini (ubuntu) for the memory limit. Likely it’s very small (128M) and the amount of logs you’re trying to see is much larger than that.