SOLVED SNAPIN : Some exe packages don't deploy

  • Hello everyone,

    I have some problem with some Snapin. I created a .exe file (SFX Maker by David Cornish V2.5 SR -2d) with a .bat inside (with the msiexec argument) for installing some apps (lotus Notes for example); if i launch directly the exe file on the computer the application install is successful but when i put in on my fog server as a snapin… nothing
    Others snapins like java, acrobat reader, 7zip, chrome, firefox (msi and exe with arguments) install without problems
    Is there something I miss in the snapin creation (sfx) or configuration (snapin menu in fog) ?

    here is the complete process for notes :

    Copy the sources of notes on my computer
    create a .bat file to launch msiexec (msiexec /i “path to lotus.msi” /qb
    compress the folder with 7zip (
    use sfx maker to create my exe with my .bat as a comand line :
    Create my snapin on fog :
    Create a single snapin task on my host to test my snapin and…
    fog.log on my destination computer :
    02/06/2015 10:06 FOG: : SnapinClient Attempting to connect to fog server
    02/06/2015 10:06 FOG: : SnapinClient Module is active…
    02/06/2015 10:11 FOG: : SnapinClient Attempting to connect to fog server
    02/06/2015 10:11 FOG: : SnapinClient Module is active…
    02/06/2015 10:16 FOG: : SnapinClient Attempting to connect to fog server
    02/06/2015 10:16 FOG: : SnapinClient Module is active…

    On FOG server :

    thank you for helping me 🙂

  • I found where the problem was, in the /etc/php file I changed the values for a Fedora distrib :
    POST_MAX_SIZE to 1900MB
    but i didn’t change the value of Limit Memory (Ubuntu and VmWare) who was still at 128MB, change it to 1900MB and it works

  • ok so the problem must be on my snapin, the last one (Ooffice) return an error 500 while downloading the package (internal server error)
    Others package works fine msi or exe

  • FOG 1.2.0 on Redhat Enterprise 6
    And yes, i always clear the snapin task when i see it doesn’t work (I’m testing all my snapin one by one because i just instal my Fog server)
    I just reboot my fog Server and client and actually, open office is downloading on my client (it’s very very very slow). It’s an exe created with the same apps (SFX Maker) with a batch file to launch setup.exe with silent argument.
    1\ can snapin process/service fail and need to be restart some times and how ?
    2\ can i speed up the download from my client (or speed up the upload from Fog) ?

  • Okay, some basic questions then.

    What Version of FOG are you using? This should be displayed in the Cloud logo at the top of the GUI.

    Have you tried clearing the snapinTasks table to see if you can get further?

  • the msi is in an exe file, created by sfx maker (like in the screenshot)
    I use the exe to extract the source folder in the C:\temp folder on my client and run my .bat. The problem is that the client doesn’t download the package, on fog server it’s always in “Queued” for hours…

  • I think msi’s typically have issues installing as the system user. I don’t know which in particular have this issue.

    Rather than rely on an MSI to do a batch file install, would it be easier to use a non-msi method?