SOLVED I know what's wrong, I just don't know how to fix it!


  • @Julianh You’re missing one .mntcheck file.

    You need one in both images and dev folders

    [CODE]touch /images2/.mntcheck
    touch /images2/dev/.mntcheck[/CODE]

    After that, restart the NFS service and portmap/RPC (or reboot the machine).

    Let us know what it does then.


  • Thanks for your help, much appreciated.

    I issued the commands, and realised the /images2 and /images2/dev directories were not being exported. I then edited the /etc/exports file to do so. The new 4tb disk is mounted on /images2

    I’ve taken a photo, now the Nfs error has gone. One down one to go.

    Here’s the url of the photo;
    https://www.dropbox.com/s/34lgv7b3f7fkzpc/fogerror2 (1).jpeg?dl=0

    This is the result of the commands, after editing the file;

    image@fog1:~$ cat /etc/exports
    /images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2)
    /images2 *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=3)
    /images2/dev *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=4)
    image@fog1:~$ ls -laR /images2 | grep .mntcheck
    -rwxrwxrwx 1 root root 0 Jun 1 16:30 .mntcheck
    image@fog1:~$

    So it’s getting there, I’m still not sure about the password, so I’m using the “password” from the /opt/fog/.fogsettings. Is that correct? What username should I use?

    Thanks


  • @Julianh

    On your FOG server, what is the output of these two commands?

    [CODE]cat /etc/exports
    ls -laR /images2 | grep .mntcheck[/CODE]


  • Don’t know what happened with the font there, sorry, here’s the photo

    https://www.dropbox.com/s/75rigpzcy2b52mf/fogerror.jpeg?dl=0


  • I’ve attached a photo of the servers screen, it shows the error better. By doing this I also noticed a fail to mount error. I’m not sure I didn’t mess up the mounts from the new disk, so I’ve pasted the fstab

    I’ve also issued the “sudo chmod -R 777 /images2” command, the new disk is mounted as images2.

    Mod edited to use code box
    [CODE]image@fog1:/etc$ cat fstab

    /etc/fstab: static file system information.

    Use ‘blkid’ to print the universally unique identifier for a

    device; this may be used with UUID= as a more robust way to name devices

    that works even if disks are added and removed. See fstab(5).

    <file system> <mount point> <type> <options> <dump> <pass>

    /dev/mapper/fog1–vg-root / ext4 errors=remount-ro 0 1

    /boot was on /dev/sda2 during installation

    UUID=7fb5c067-98c2-45bf-88c7-66e39f3f149e /boot ext2 defaults 0 2
    /dev/mapper/fog1–vg-swap_1 none swap sw 0 0
    /dev/sdb1 /images2 ext3 defaults 0 0

    image@fog1:/etc$[/CODE]

    Thanks for your help, its late here, UK 23:52, and I have to go. If you have any suggestions I’ll look at tomorrow morning, I’d be grateful and thanks in advance.

    I still think I have the username / password wrong, where would you recommend I get the
    correct ones from?

    Julian


  • Double check you made the .mntcheck files inside the new /images and /images/dev directories ??

    Also, assign 777 recursively to your new storage node location?

    [CODE]chmod -R 777 /path/to/your/new/storage/node[/CODE]


  • I added an extra disk locally to the fog server, I’m not using an NFS server. It 4Tb disks in it was the only disk, that had the OS and images on it. It’s now full, hence the need for a new disk.

    Tom kindly pointed out the disk was full, as the sql server didn’t initialise.

    Thanks for your help

    Julian

  • Moderator

    @Julianh said:

    I tried to put as much information in as possible, and forgot the actual error! Sorry it’s

    Failed to mount NFS volume

    Thanks for replying.

    It’s seem to be an error in your export file ? How do you add that new storage in FOG ? Could you post your export and where is mounted your new hdd.


  • I tried to put as much information in as possible, and forgot the actual error! Sorry it’s

    Failed to mount NFS volume

    Thanks for replying.

  • Moderator

    @Julianh said:

    But my images are failing with the following error.

    Hi,

    Which error ?

    Regards,
    Ch3i.

320
Online

8.5k
Users

15.3k
Topics

143.4k
Posts