V3396 Fog Client Green Fog shutting down active sessions

  • I installed the Fog Client that is part of the 3396 build on Windows 7 Pro both 32 bit and 64 bit. The Green fog portion of the client is shutting computers down while users are logged in and working. It also shuts down locked computers.

    Any hints? I’ve disabled it for now.

  • I fully understand that documentation is a huge time sink! I hope I can help.

    I renabled fog on the client and deleted everything from the master. It did not remove the tasks even after a service restart.

    I’m creating a batch file with this command:
    schtasks /delete /tn fog\20@0@s /F
    This deletes the task scheduler items. The 20@0@s is how the name of the tasks that are created show up.

  • Senior Developer

    Well, the code is documented! But other than that, the only documentation available so far is this:

    Right now I am the only developer working on the client, so updating the wiki is quite time consuming. We are (hopefully) getting a couple more c# developers to help out soon though.

    Ideally though the new client’s modules will act exactly the same as the old one (minus a few bug fixes).

  • Yes, new as in beta. Glad to know that this is a known issue. Also glad to know that these things are set in task scheduler. Is there documentation for the new version that I should be reading somewhere? Or documentation that I can contribute to?

    Green fog wasn’t working with the legacy client and the 3396, so I deployed (without testing first) the new client and got myself in trouble… Lesson learned when I want to be on the bleeding edge! The log in the legacy said something like “validating green fog tasks. 0 tasks validated”

  • Senior Developer

    By “new” I mean the beta client. (As opposed to our legacy one that has been around for years).

    Assuming this is the beta client, GreenFOG will force reboot even when a user is logged in. This will change, but not immediately. The easiest way of removing the GreenFOG tasks is to re-enable it and remove the greenFOG tasks. The other way is to open TaskSchedular and remove all tasks in the FOG folder.

  • New as of the 3396 build. Is there a newer one out?

    Am I reporting this in the proper forum?

    I disabled greenfog for most of my clients. and set the shutdown time to later to not affect others. It seems that the settings held after a reboot even the the fog.log shows that greenfog is disabled on the client. I’m verifying that this is the case and not just user error.

  • Senior Developer

    Is this the new client?