FOG no longer PXE Booting....reboots

  • Hello.

    Suddenly my pxe boot/imaging process seems to be failing.

    I create a task in fog, reboot the PC, it starts the pxe boot and gets stuck for a while at init.xz or init_32.xz…eventually it starts pushing out the image but then reboots before the copying screen appears.(the blue screen with the red progress bars)

    This is happening with all images but not with all models of PC, some seem to run ok.

    Thanks very much for any advice, Kev

  • If the image was set to “Resizable”, then it doesn’t matter.

    I’m guessing it’s not re-sizable.

  • I’ve sorted it. I was using a sata drive on various different models of PC around the office to confirm the image works with multiple models. I tried using a different drive and it worked fine, the drive I was using was only 80gb whereas the image came from a 250gb drive.

    The windows installation on the image only takes up about 20gb, is this behaviour correct? Does the target drive need to be the same size or larger then the original?

  • You could try an older kernel… [SIZE=13px][COLOR=#555555]3.19.3[/COLOR][/SIZE] x86_x64 gave me luck recently with a middle-aged laptop.

  • ok, rebuilt fog on a brand new VM, I’m getting the same issue. I can’t think what else it could be…the DHCP options are the same as they’ve always been. Perhaps there’s something odd about these two particular PCs I’ve been testing with, I’ve been using them with fog for a while though. I’m going to dig out another couple of the same model…

  • Cool.

    Create a snapshot after your OS is installed and fully updated (no custom config at this point). Don’t wanna have to do all that over again.

  • ah, too late I removed FOG as per…[url][/url]

    Reinstalled, dragged my images back in…same problem. I’ll build a new vm as you suggest. Thanks very much for your prompt replies

  • [quote=“kevin buckley, post: 46979, member: 29412”]No luck, ran the installer again, still the same issue. Can i remove it fog completey? I have my images backed up…[/quote]

    Before you do that, there are steps you should take…

    In “FOG Configuration”, do the “Configuration Save”. This exports everything in your DB. And double and triple check you have your images backed up.

    I’d also recommend just exporting the HOST list, alone. You should be able to do that from somewhere in the Hosts menu. (this allows you to import host data later, but not settings).

    You can remove FOG, there’s a way to do it, it’s in the WiKi somewhere… but I find starting from scratch much easier and cleaner.

    I’d recommend not dismantling your old FOG server, just turn it off for now; then get other hardware and install FOG 1.2.0 on that (I recommend using Hyper-V because you can snapshot). After installing, you can re-import your DB and images.

  • No luck, ran the installer again, still the same issue. Can i remove it fog completey? I have my images backed up…

  • version 1.20, ubuntu 1404

  • Can you re-run your installer?

    This won’t delete any DB data or image data, it’ll re-use your previous installation choices.

    The installer will update your kernel and inits to the latest, I think.

    What version of FOG are you using, what distribution?

  • This post is deleted!

  • Yep it works ok, it get to the bottom line - saving MBR then starts partclone whereas the others just reboot.

  • Can you take your Dell e6400 and connect it to the network port of either the Optiplex3020 or HP dc7100, then see if the e6400 works on that port?

  • Same thing happens if I try to deploy using the quick image option. I can deploy and capture from my dell e6400 but not to optiplex 3020 or HP dc7100.

    It can’t be anything to do with the actual images as I can’t even capture a fresh image from these PCs.

  • The permissions are :

    owner - root - create and delete
    group - root - create and delete
    others - create and delete