PXE boot not connecting to Fog Server

  • I am having problems uploading an image with Fog. I have Ubuntu 12.04 with Fog version 1.2.0. I did not install any of the DHCP stuff when I installed Fog and I am not using Fog over a network . I have a laptop running Fog plugged directly into the machine I want to pull an image from.

    When the source machine PXE boots, it grinds away like it’s trying to connect but nothing happens. I read some stuff on Google about stopping & restarting the TFTP service but that didn’t solve my problem.

    I went into Image Management, added the machine, then tried to PXE boot and let the boot screen register the host. I have also tried adding the host beforehand but the results are the same.

    Anyone have any ideas? Thanks!

  • Should be.

    You’ll need to re-install and just choose DHCP this time.

    There is an answer file somewhere that the FOG install script uses, it’ll try to pull answers from that.
    You might need to delete that file. You might want to try modifying it first.

    To use DHCP, change that option from 0 to 1

    Here’s an article saying where the answer file is: [url]http://fogproject.org/wiki/index.php/Upgrading_the_FOG_Server[/url]

  • Is it possible to install DHCP after Fog has already been installed?

  • If you’re using a cross-over cable,

    You will have to install DHCP on the FOG server. Otherwise, the client has no way of getting an address.