• I am experiencing a problem with a new fog server that I installed today. I can not get any machine to join to domain. When I check the error log on the client machines there is an error code 1326. I created a new user in AD that is in the domain admins group. I used the FOGCrypt to create the password and copied the encrypted password into the AD account. I installed Remote Server Administration Tools and configured on the client machine. As for the setting in fog I have set the domain, left the OU blank, put in the AD user that I created and copied the encrypted password that was created in FOGCrypt into the password section. I tried changing the username to domain/username but then I get the 2202 error. Trying to find info online for this has lead me to pretty much no where.

    If anyone has battled through this I would appreciate some insight!!!

  • I am building it on a Windows 7 box. I also tried registering a different machine that has not been touched yet and I got the same error.

  • Are you creating the encrypted string on a Windows machine?

    There’s a thread about it somewhere, but people were saying that the string comes out different if you compare ones built on different OSs… I’ll post that thread if I can find it…

  • I just tried using the domain admin account and I still get the padding is invalid and cannot be removed. This is a brand new install of FOG 1.2.0 and I am installing the client directly off of my FOG Server.

  • Although it’s discouraged, I use our Administrator account for FOG domain joining.
    I couldn’t get it to work with other accounts.

  • Moderator

    [quote=“Tom Elliott, post: 44874, member: 7271”]The error code (1326) is specific to Microsoft domain joining specifically that the “username and password are incorrect”[/quote]


    [CODE]Description Actual Error Error Code
    Bad credentials. ERROR_LOGON_FAILURE 1326[/CODE]

    Casey Ailiff, have you try with the default domain administrator account ?


  • Are you using the new client, or the old one??

    If you’ve got the old client in your environment, I’d recommend staying with the old one for now.
    Enabling the new one somehow stops the old clients from working… I’m not a dev, I don’t exactly know why but that’s what I’ve read.

  • Try to re-install the fog client on the host you want an image of.

    Sometimes things get screwy here… I don’t know why, but others have said this has solved their issue.

    Make sure you’re using the client from your FOG server’s web gui. There’s a link at the very bottom of the page after you log in.

    I know this means taking a new image, but if it solves the problem it’ll be worth it. Don’t discard your old image yet though.

  • I decided to redo the FOGCrypt portion of this to make sure something did not get messed up. I am now getting the Padding is invalid and cannot be removed. Since I have done this the machine is no longer changing the name like it would before.

  • The error code (1326) is specific to Microsoft domain joining specifically that the “username and password are incorrect”

  • Wayne,

    Thanks for the response but I have already done all of these. I currently just have the username not domain\username. I can look at the log on the client machine and see that it has the correct IP. It is having no problems naming the machine I just get the HostnameChanger Domain Error! (‘unknown Error’ Code:1326) in the log. I tried the delayed restart but that has no effect either. I can even sit there and keep restarting the service but still get the same error. I have verified that the machine is told to join AD on the management side as well.

    I have installed multiple FOG servers before and am very familiar with how the software works and functionality of it. This is what is driving me crazy is that I have never seen this problem out of the 9-10 times I have implemented these.

  • You don’t have to use DomainName\Username for the username field (you used a forward slash, that isn’t right).

    But, you do need to use a Domain account that has permissions to join systems to AD.

    Also, when you install the FOG client on the host machine prior to uploading an image, you have to ‘tick’ the features that you want. I suggest ticking them all.

    Another thing that could break it is typing in the wrong IP into the FOG client installation.

    Also, if you’ve got really fast systems, you might want to set the FOG client service to delayed start. This will make waiting for domain joins 1 to 2 minutes, rather than like 10 seconds… but it works every time.

    Also, you might wanna re-encrypt your password again and be very, very sure you don’t make a typo. You can make multiple encrypted strings by piping the output to different text files. ( you’d use the arrow character to pipe output ). If you get two encrypted strings that match, in a row, you’re probably not making any typos.

    ALSO, inside of host management, on the left, you need to enable the “Join to AD” feature (that’s not what it’s exactly called, I can’t remember) for it to work at all on a particular host.

    LATER, when you have FOG working right, and are adding massive amounts of hosts into FOG, you can lump them into a temp group and enable the AD join feature on all of them at once, along with other features.