Fatal Error: Failed to Mount File System

  • I’ve been using fog for several months now. It’s worked fine. I have fog 1.2.0 on Ubuntu 14.04, which is a VirtualBox VM running on Windows Server 2008. Nothing has changed on the physical server or in my fog setup (including storage location), but I did allow some updates a few days ago on the fog (Ubuntu) server. Now, when I try to upload or download an image, I get the error in the image. All of my images are Windows 7 Pro or Enterprise. I’ve tried several things from this forum, but nothing has been successful.

    So far, I’ve tried:

    touch .mntcheck
    chmod -R 777
    reinstalled fog over the top

    Any help is appreciated in advance.


  • Moderator

    Alright forget about the firewall things I wrote… Switches can be so mean! :mad:
    Thanks a lot for reporting back. It’s good to know, so maybe I can point to this earlier next time if someone is having a kind of similar issue!!

  • Moderator

    Looks pretty good! You were able to mount and list the NFS share. So why should other clients not be able to? Have you tried to run a FOG task again lately?
    The only thing I could think of are intermediate firewalls. Looking at your IP addresses I am pretty sure there is not much in between. So maybe it’s a firewall on your FOG server?! Run this command and post the output here:
    [CODE]sudo iptables -L -n -v[/CODE]

  • Ok. Thank you for your help, Uncle Frank. I fixed this issue. It wasn’t a FOG issue at all. I had changed out a switch on my network a few days ago and it was the issue. I’m not sure why it’s an issue. I changed an old 24-port Cisco switch with a new 8-port Cisco switch. I never thought the switch would be an issue so I hadn’t thought to change it back until this morning. It’s not a VLAN issue (both switches are flat). Anyway, thank you again for your help.

  • It looks like I put unmount instead of umount in these results. It did unmount fine after I used the right command.

    It seems to be working, I think. Any other ideas?

  • Here is the result of the mount command (after I installed nfs-common on the client):

    administrator@NagiosUbuntu:~$ sudo mkdir -p /mnt/nfstest && sudo mount -v /mnt/nfstest
    mount: no type was given - I’ll assume nfs because of the colon
    mount.nfs: timeout set for Mon Mar 9 12:27:06 2015
    mount.nfs: trying text-based options ‘vers=4,addr=,clientaddr=’
    administrator@NagiosUbuntu:~$ sudo ls -al /mnt/nfstest
    total 44
    drwxrwxrwx 11 1001 root 4096 Feb 12 15:21 .
    drwxr-xr-x 3 root root 4096 Mar 7 20:41 …
    drwxrwxrwx 2 1001 root 4096 Jul 25 2014 Administrators22July2014
    drwxrwxrwx 2 1001 root 4096 Feb 12 15:21 dev
    drwxrwxrwx 2 1001 root 4096 Aug 25 2014 HS88
    drwxrwxrwx 2 1001 root 4096 Jul 24 2014 HSComputerLabs
    drwxrwxrwx 2 root root 4096 Feb 12 14:39 HSLT4
    drwxrwxrwx 2 1001 root 4096 Sep 17 19:23 LongFellow01
    -rwxrwxrwx 1 1001 root 0 Mar 6 15:17 .mntcheck
    drwxrwxrwx 2 1001 root 4096 Jul 21 2014 MSLab14July2014
    drwxrwxrwx 2 root root 4096 Jan 15 16:45 postdownloadscripts
    drwxrwxrwx 2 1001 root 4096 Jul 25 2014 TeacherImage
    administrator@NagiosUbuntu:~$ sudo unmount /mnt/nfstest
    sudo: unmount: command not found

  • Ok. Here is the result of the the netstat command:

    administrator@FOGServer:~$ sudo netstat -antup | grep 111
    tcp 0 0* LISTEN 451/rpcbind
    tcp6 0 0 :::111 :::* LISTEN 451/rpcbind
    tcp6 0 0 FIN_WAIT2 -
    tcp6 0 0 FIN_WAIT2 -
    udp 0 0* 451/rpcbind
    udp6 0 0 :::111 :::* 451/rpcbind

    Looks right, I think?

  • Moderator

    Please make sure you have ‘nfs-common’ (debian/ubuntu see the other posts for package names in centos) installed on [B]the client[/B] from which you want to check the NFS connection!

    Portmap is called ‘rpcbind’ in Ubuntu/Debian. Use netstat to see if it is running on [B]the server[/B]:
    [CODE]sudo netstat -antup | grep 111
    tcp 0 0* LISTEN 1901/rpcbind
    tcp6 0 0 :::111 :::* LISTEN 1901/rpcbind
    udp 0 0* 1901/rpcbind
    udp6 0 0 :::111 :::* 1901/rpcbind[/CODE]

  • In continuing to search the web for more information on this, I keep running into things about a service named portmap. My fog server doesn’t have that service. Should it? I’m sure you can tell, but I’m certainly not a Linux/Ubuntu expert.

  • mkdir command executed fine. However, the mount command had this output:

    [INDENT=1]administrator@NagiosUbuntu:~$ sudo mount -v /mnt/nfstest[/INDENT]
    [INDENT=1]mount: no type was given - I’ll assume nfs because of the colon[/INDENT]
    [INDENT=1]mount: wrong fs type, bad option, bad superblock on,[/INDENT]
    [INDENT=1] missing codepage or helper program, or other error[/INDENT]
    [INDENT=1] (for several filesystems (e.g. nfs, cifs) you might[/INDENT]
    [INDENT=1] need a /sbin/mount.<type> helper program)[/INDENT]
    [INDENT=1] In some cases useful info is found in syslog - try[/INDENT]
    [INDENT=1] dmesg | tail or so[/INDENT]
    I checked the nfs-common package. It’s already installed. I installed the cifs-utils package. It installed fine. I restarted the server and got the same ouptut for this command.
    Thanks, Frank, for your help. Any other ideas?

  • Moderator

    Maybe try mounting the NFS share from a different computer to see if this works… Others had broken their NFS shares lately too, see here for example: [url]http://fogproject.org/forum/threads/problem-with-permission-denied-after-fog-server-restart.12503/#post-43257[/url]

  • Thank you for your reply. I tried your suggestions about the nfs service to no avail. It was running and restarted fine, but no change. I also restarted the physical machine, but no luck there either. I can’t see anything setup wrong.

  • Here is the foginstall.log


  • Here is the exports file.


  • Make sure that the NFS server is running. Please post any errors it gives.

    [CODE]sudo service nfs-kernel-server status[/CODE]

    also try restarting with

    [FONT=Tahoma][CODE]sudo service nfs-kernel-server restart[/CODE][/FONT]

    Check that your [SIZE=13px][COLOR=#333333]/etc/exports is set correctly, maybe post what’s in there.[/COLOR][/SIZE]

    [SIZE=13px][COLOR=#333333]Can you post your FOG install log? It’s right here: [/COLOR][/SIZE][FONT=Tahoma][SIZE=12px]/var/log/foginstall.log[/SIZE][/FONT]