Sudo ./ command not found

  • I am fairly new to linux but I believe I am doing everything correctly but am not understanding why the command will not execute.

    I am following step by step on the wiki ([url][/url]) and I am using Ubuntu 13.10 with fog 1.2.0.

    The directory I am in is /Desktop/fog/bin$
    When I run the command [B]ls [/B]it shows but then when I run command [B]sudo ./ [/B]it comes back with “sudo: ./ command not found”.

    I have even tried [B]sudo ./inst [/B]and then tab to populate the file name but nothing happens.

    Am I missing something?


  • Developer

    If I remember correctly, Ubuntu by default will provided colorized output. If was executable, it would be highlighted a different color. Run:

    [B]ls -l[/B]

    This will show the permissions on the file. You should see [B]-rwxr-xr-x[/B] for permissions. If you don’t have any executable bits, you’ll get the response you got. How do you fix it? For a start, you could run:

    [B]sudo chmod 755[/B]

    This will only make that first script executable. In the same directory, there’s a file that probably won’t have executable rights either.

    [B][U]If you really want to make sure it works[/U][/B]
    It seems you must have extracted the files in a strange way because you should already have the correct permissions. When you get the tar.gz from the website, run tar to extract the files to preserve permissions:

    [B]tar zxvf fog_1.2.0.tar.gz[/B]

    This will extract everything out into your current directory. Then all the permissions should be correct.

  • Senior Developer

    Also, the user you created needs to HAVE sudo privileges.

  • Developer

    also, you should NOT create a user named fog for your fog server. the install script is going to want to create that user.

  • Developer

    you seem to be following, step by step, the instructions on how to install fog 0.32, not fog 1.2.0
    perhaps it’s for the best that you ran into a problem at the start, if you want fog 1.2.0