• We are deploying about 300+ of the same hardware, and I need to load WinXP on the 300+ machines. This Windows XP has some software preloaded that we will use for testing the machines before shipping out.

    I manage to configure my fog server, and I was able to upload an image to the server using a sample of one of the machines. I was unable to download the image back to the machine, I got an error message that said “This is Not a partclone image”. I don’t know what went wrong, I will retest again on Monday. I googled but there is not much information for that error. Anybody here gotten it before?

    My other question (related to the title), all these machines are brand new, and they come with NO operating system loaded. The way we handled it before was: connected the machine to an internal network where we had an imaging server. The server would automatically load the default image for that hardware and halt at the end of the imaging process.

    The person that was in charge of this system left the company, and took the knowledge with him.

    Is it possible to do the same with FOG? I’ve been going around the forums and Google but can’t find an answer.

    I know FOG identifies hardware based on the MAC address. How can FOG tell that they are all the same config and autoload the assigned image for that particular hardware version.

    At at different point in time there will be other hardware configurations, but for now one single one would be enough.

    By the way, I am running FOG on Kubuntu 14.04 VM. It should be the lastest version of FOG

  • Senior Developer

    While I’m sure we could’ve come to these conclusions separately, I’m glad you got this part working for you. That and that you searched and found your answer right here on the forums already!!!


  • Alright, I’m flooding this thread but I think I finally got it working. I went through other posts here on the forums and notice that other people also had 0.00 iB info on their uploaded images, and they also were unable to copy from /images/dev/ to /images automatically. On one of your posts you mentioned that the image upload is first done via NFS, but the via FTP you do the relocation.

    This got me thinking and I assumed that something was wrong with the FTP password. I simply ran sudo passswd fog and changed the password. Then via the Web GUI on 2 places: Storage management and Fog Settings.

    I then hunted down the Config.class.php file and updated the password there too.

    It is working now. I am testing a few wipes and reimages to confirm.

  • Quick question. Should the image reside in the root of /images/ with a name of <imagename>.000, or should it be inside its own folder named <imagename> and have the original filename of <macadress>.000 ?

    I currently have it as the second option.

  • This is the error that I am getting:

    [url="/_imported_xf_attachments/1/1430_error 3a.jpg?:"]error 3a.jpg[/url]

  • I reuploaded the image with the same result. Nothing is created in the /images/<imagepath> automatically. I manually copy the <macaddress>.000 to /images/<imagepathname> and it still shows as size 0.00 iB on the server itself.

  • If it’s of any information, when I list the images via the web manager, the image is shown as 0.00 iB on both Client and Server

  • I had to restart tftpd. I manually moved the image file to the correct folder. I still get “Cannot find XP Image File”

  • This post is deleted!

  • This post is deleted!
  • Senior Developer

    I don’t know what the issue is, but for now, what files do you see in the /images/dev/<macaddress>?

    There should be one:
    in the sequence of :

    To get your image to deploy properly, try moving the .000 file to:

  • Hi Tom,

    I fixed a permission issue I had with the files. However I have found that Fog Server doesn’t relocate the IMAGE file from /images/dev/macaddress to /images/Name-of-Image

    If I go into /images/dev/macaddress I see 5 files in there. But I don’t know why they weren’t moved to /images/name-of-image

    So when I try to download the image to the host I get a “Cannot find XP Image File” error messages.

    Any ideas?

  • This post is deleted!

  • This post is deleted!

  • This post is deleted!

  • Hi Tom. Finally got to the office and I am able to test. For starters, neither the Full Registration or the Quick Registration are working.

    I will try and add the client manually and see if I can image it like that.

  • Thanks, Tom. I will test this and report back on my findings. I really appreciate you taking the time to do all of this.

  • Senior Developer

    [quote=“guscrown, post: 37751, member: 26595”]Got them. Your server was complaining about the certificate. You should check that out.

    Are these files to replace other files in my current installation?[/quote]

    The certificate problem isn’t a “problem” persay but I’m using self signed certificates.

    The init files you downloaded go in your fog server to replace the /var/www/fog/service/ipxe/init.xz and /var/www/fog/service/ipxe/init_32.xz files.

  • Got them. Your server was complaining about the certificate. You should check that out.

    Are these files to replace other files in my current installation?

  • Senior Developer

    I’ve made the hacks I think will work for your situation.


    These files may work for all, but I haven’t tested so please just report any issues you see.