Snapins not deploying after upgrade

  • I had a working version of fog version 0.38 on ubuntu server 10.04. I updated Ubuntu to 12.04 and fog to 1.20 and now snapins will not deploy The log file on a workstation shows the snapin client attempting to connect to the server and reports that the client module is active, but that is all. Any insight would be appreciated.


  • Developer

    No problem, glad to hear it’s working!

  • Looks good so far, have 3 that are having problems in lab. But I can’t ping them or get to them remotely at all. Not a fog issue.

    Thanks for all of your help.

  • I now am trying to send an app to a lab full of computers to see if that works. We had them queued before, but i had to redo them after truncating the tables. Will let you know how it goes.

  • Developer

    Glad to hear 🙂

  • sorry, running behind you in thread. used phpmyadmin to truncate the tables. Now it allows me to add job for all snapins for that client. ooks like its deploying also.

  • When I run the commands, first I had to specify the fog database in mysql, then separate the truncate commands as they would not run on the same line. It then changed the prompt to -> and the only way I could figure to get out of that was to do ctrl-c. It did not change anything in the tables as far as I can see and I still get the error on the machine.

  • Developer

    Just run [FONT=Consolas][CODE]truncate table snapinJobs; truncate table snapinTasks;[/CODE] when under the FOG database in phpmyadmin.[/FONT]

  • I do have phpmyadmin installed on the sever. Can you tell me how to do that? I had 2 tables related to snapins that had a lot of entries in them after the upgrade, snapinJobs and snapintasks. Snapinjobs shows over 7000 entries. I flushed everything out of snapintasks, it had 16,000+ entries.

  • Developer

    Run these commands with mysql

    To do it from a terminal:
    Without mysql password set
    [CODE]mysql -u root[/CODE]
    If you set a mysql password:
    [CODE]mysql -u root -p[/CODE]
    Then type your password.
    [CODE]truncate table snapinJobs; truncate table snapinTasks;[/CODE]

  • Developer

    I bet there was a snapin that carried over with the upgrade. Do you have phpmyadmin installed on your fog server?

    You are going to need to delete the old snapin task out of the database or mark it as completed.

  • [B]All Snapins task failed to create for [U]tech-kj[/U] with image [U]gx380-win7[/U][/B]
    [B]Snapins Are already deployed to this host. [/B]
    This appears to be a single host problem. There is no active tasks or active snapin tasks for this machine.

  • Developer

    what is the error?

  • The webpage will show an error. They never show up in tasks. If you do a single snapin, they show up in active tasks and in active snapin tasks. That is different then the earlier version that I used. They also must be deleted in both places if you wnat to remove the task. Is that normal behavior for this version?

  • Developer

    exactly how does it “fail” ?
    does the webpage show an error? does the task get scheduled but never run?

  • I attached the foginstall.log file from my install. Apache logs show clients requesting the snapin module in the access.log. The error log is almost all file does not exist, mostly .png files. Have only had 9 of these this AM.


  • Could have been .32, can’t go back and check now. It also only allows me to send single snapins, if I try to do deploy all snapins to a client, it fails. I don’t really understand all the tables in mysql, but the snapinjob and snapintask tables both have a lot on entries in them.

  • 0.32?