Fatal Error: Failed to mount nfs volume timed out



  • Sorry if this has been asked before, however I did not see anything like it in the forums so far. One similar post with no solution. Im at a loss as I don’t know what to do to resolve this issue.

    V 1.2.0 Installed on Ubuntu 12.10

    • Send Method . . . NFS
    • Checking in . . . Done
    • Mounting File System . . . mount: mounting 192.168.10.250:/ images/dev/ on /images failed: Connection timed out

    Fatal Error: Failed to mount NFS volume.



  • I know this is a bit old but I just wanted to send off a “Fixed my problem” message. I had moved my /images from a directory on the root partition to a new larger partition mounted to /images. When I made the cp -a it did not, for some odd reason, copy either of the .mntcheck files in /images or /images/dev. After creating and setting permissions on those two files everything started to work again. Thanks much!!


  • Developer

    You don’t have to log in as root to install. You should at least include the sudo in front of the installation command.

    Generally it is bad practice to use the root user for ANYTHING especially logging in to complete tasks, however it is acceptable to sudo su and run your commands or use sudo in front of each command you wish to elevate.

    The reason you edit the lightdm.conf is so you can log in as the root user, but my recommendation is to leave lightdm.conf alone and use a regular user and call sudo when you need it.



  • Hey its me back again. I am setting up a Ubuntu 14.04 install when I try the “echo “greeter-show-manual-login=true” >> /etc/lightdm/lightdm.conf” when the system reboots it goes black. Then I have to go in without the GUI and delete the line added to the lightdm.conf. Now this is just my Linux noobishness showing again but, what am I doing wron this does not enable me to login as root. Also why do I have to login as root when I could just do the “sudo su -” This is just my curiosity. If I run the fog install without loging in as root will that be different from running as with the moded lightdm.conf?



  • That didnt solve the problem but i have now set it to be a non resizeable and it seems to be working now.

    ill know more in the morning.



  • testing this now tom , thanks for the help.
    i am reuploading the image and will let you know if it downloads correctly.


  • Senior Developer

    This is a known issue.

    Try the init files in place of yours that I’m currently hosting:

    wget -O /var/www/fog/service/ipxe/init.xz http://mastacontrola.com/init.xz
    wget -O /var/www/fog/service/ipxe/init_32.xz http://mastacontrola.com/init_32.xz
    


  • almost there, i got the image up but i am getting a error when trying to deploy an image with part clone error exit and then /dev/sda1 no such file or directory.

    its a Windows XP image marked as resizeable in the gui on an ide drive.


  • Senior Developer

    How do you have /images being mounted?

    Is /images a separate disk after you performed the install of FOG?

    The way to fix:

    sudo mkdir /images/dev
    sudo touch /images/.mntcheck
    sudo touch /images/dev/.mntcheck
    sudo chmod -R 777 /images
    


  • this is kinda my issue as well.

    i have a raid mirror md0 mounted as images vis fstab and the storage manager can see the 500gig drive but i dont have a /dev folder in it.

    i have changed the permissions on the folder. how to i get the /dev folder to be created.


  • Senior Developer

    Try restarting the tftpd-hpa service:

    sudo service tftpd-hpa restart
    


  • Last update for the day.

    I have not changed anything from the other day. I am now getting stuck at :

    PXE-E32: TFTP open timeout
    TFTP…

    Again I did not change anything from the other day infact I shut it all down and only got around to booting it all up this evening.

    I don’t understand what happened, that part was at least working. >.<



  • I don’t really know what else to do except maybe wipe and reinstall maybe with v14 of Ubuntu. Kind of a last resort though.

    At this point a little feed back would be helpful,

    Is it the fog machine?
    It is listed as compatible hardware Dell Optiplex 760

    Is there the possibility of it being a client issue?

    The client is hardware registered.
    The management console is [B]unable[/B] to resolve host name.
    It obviously PXE boots and starts fog.

    I am really unsure of what else to try. I have an extra HDD I may try a v14 load and see what happens.
    I also have a second client machine different make and model, I guess before I try a reload I will set up the other machine. . .



  • Here is what I have attempted so far this afternoon. No such luck getting any better results.

    (Except that it seems like it is taking longer on “Checking In and Mounting File System”)

    Currently attempting.jpg



  • Well in that sense I’m not completely illiterate when it comes to tech. I have been in IT for years just never really had anything to do with Linux until now.


  • Senior Developer

    I mean no harm when i say these things.

    I just want to understand what point of view I need to work with.

    Hopefully you understand.



  • I will give that a shot this afternoon.

    Also yeah kind of a noob, the last time I had to use Linux was for the cert back in early 2000. I didn’t really pass either.



  • To see hidden files, change your command ‘ls -l’ to ‘ls -la’.

    Edit: If you want to see hidden files/folders over the file manager, press ctrl + h.


  • Senior Developer

    I’m only going on a limb and guessing you’re fairly new to the linux world?

    Files that begin with a . are “hidden” from the filesystem. This would be why you’re seeing “contents: nothing”.

    When you’re running the chmod commands I’d recommend using with the -R argument.

    The reason is because chmod 777 <file/foldername> only affects the individual item.

    chmod -R 777 <folder> means to set the persmissions recursively which is what you need.



  • I Tried this:

    root@Apl-Fog:~# ls -l /images/.mntcheck
    -rwxrwxrwx 1 root root 0 Oct 9 19:11 /images/.mntcheck
    root@Apl-Fog:~# ls -l /images/dev/.mntcheck
    -rwxrwxrwx 1 root root 0 Oct 8 14:03 /images/dev/.mntcheck
    root@Apl-Fog:~# touch /images/.mntcheck
    root@Apl-Fog:~# chmod 777 /images/.mntcheck
    root@Apl-Fog:~# touch /images/dev/.mntcheck
    root@Apl-Fog:~# chmod 777 /images/dev/.mntcheck

    However the directory is still empty

    Screenshot from 2014-10-09 19:22:01.png


Log in to reply
 

368
Online

38721
Users

10548
Topics

99849
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.