Downgraded Ubuntu 14.04 to 13.10(new install) and failed restore fog backup

  • I decided to downgrade from 14.04 since there were some issues with that still. I decided to go with 13.10 since I know ubuntu a little more than others.

    Anyways, I tried restoring the backup I made in the browser by clicking “import” in fog under “configuration save”. It seems to go through, but nothing shows up. I have restarted too.

    My next test was to manually import the sql file. This is the error I get… Any ideas?

    root@fog:/opt# mysql -D fog -u root -p < fog.sql
    Enter password:
    ERROR 1064 (42000) at line 17: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘801’ at line 1

    Thanks for the help!

  • Found my problem… loaded up my original 14.04 ubuntu… and found that some of my tables in the fog database were corrupt. I ran the repair on them and that fixed it 🙂

    mysql -u root -p fog
    mysql> REPAIR TABLE userTracking; -----> this is an example of one table messed up