Problems with Sony Vaio imaging after upgrade to 1.2.0

  • Hi,

    we are using fog since last year and did the update to 1.2.0 a few weeks ago. We used the 0.32 version with some Sony Vaio laptops successfully, but after the upgrade we cannot run an image any more.
    Other computers / laptops are running fine.

    The host registration of the Sony laptops are successfull, so we get a registered device in the web interface.
    The registered MAC address is also correct, it’s the same shown when booting and listed in the dhcp server, e.g. f0:bf:97:e7:77:77. I tried deleting and reregistering the device, that hosts all register fine, but when running a upload or download job, the laptop allways boots to the default fog menu, not the one automatically running the job.

    So I started checking the logs. From the pxe log I can see the laptops seem to request a slightly different boot image file: I would expect only the mac address, but the Sony laptops seem to add a leading 01: to the mac address, e.g. resulting in a invalid mac 01:f0:bf:97:e7:77:77 . This way the laptops never get the correct boot file.

    Sep 7 07:20:05 fog-srv-1 in.tftpd[28749]: RRQ from filename pxelinux.0.old
    Sep 7 07:20:05 fog-srv-1 in.tftpd[28750]: RRQ from filename pxelinux.cfg/00286f2e-1df6-de11-8ad0-f0bf97e757e5
    Sep 7 07:20:05 fog-srv-1 in.tftpd[28751]: RRQ from filename pxelinux.cfg/[B][COLOR=#ff0000]01-f0-bf-97-e7-77-77[/COLOR][/B]
    Sep 7 07:20:05 fog-srv-1 in.tftpd[28752]: RRQ from filename pxelinux.cfg/C0A8354D

    Sep 7 07:20:05 fog-srv-1 in.tftpd[28753]: RRQ from filename pxelinux.cfg/C0A8354
    So I tried a browser access to the link provided in the default-pxe config file with the correct mac address
    [url][/url] and get the expected boot instruction set, but the
    [url][/url] get’s only the default boot menu.

    Is there a way to change the boot.php (i guess that’s the file checking the mac address and “linking” to the correct boot image)?
    I don’t know why we didn’t run into these problems with the fog 0.32 version, and I don’t know why Sony seems to use these invalid mac addresses with their pxe firmware. I checked for a newer bios image for the laptops, but Sony never released a newer version than the original one…

    Thanks for any help!

  • Hello Tom,

    I get to the ipxe menu, and the hosts keeps saying it’s not registered. I can run the registration process, the hosts gets added to the web interface, too, but after reboot the ipxe menu still reports “Host is NOT registered”.

    It’s just the sony vaios that have this problem, other systems (Dell Latitudes, Workstations, …) are running fine, so I guess it’s a problem of the sony pxe boot options…

    Here are the other details you requested:
    [SIZE=12px]FOG Version: 1.2.0[/SIZE]
    [SIZE=12px]OS Version: [/SIZE][SIZE=12px]CentOS release 6.4 (Final)[/SIZE]
    [SIZE=12px]The foginstall.log is attached. I couldn’t find an error in the apache logs, is there anything I explicitly need to look for?[/SIZE]



  • I’m going on a limb and saying you kept your option 67 with pxelinux.0?

    True PXE booting had a process to look in pxelinux.cfg/01-XX-XX-XX-XX-XX-XX where XX represents the client mac address. The 01 just was a prepender for PXE to know what files to look for in a sequence. You would have the same effect if it create 00286f2e-1df6-de11-8ad0-f0bf97e757e5 or C0A8354D files in /tftpboot/pxelinux.cfg/.

    My guess is something isn’t correct with your current setup which is part of why you’re seeing the issues you are. You’re stating it get’s to the fog menu, but which fog menu? The ipxe menu where it tells you the host is registered or not, or the old (fog 0.32 and below) fog menu where it just has: Boot to local disk, Memtest, Quick registration, Full registration, quick image, and debug?