Ubuntu Server upgrade breaks FOG (or I did)

  • Hi all,
    1st post 🙂
    [B]Thanks[/B] for FOG. It’s a big asset at the public school where I’m employed.

    [B]Current isue:[/B]
    I can’t deploy or upload - Error: “Unable to start task. Unable to upload file.”
    Using FOG v0.28 Been working great for 1.5 years on Ubuntu Server 8.04 LTS

    Today I upgraded to 10.04 LTS.
    []I’ve checked FOG’s logs - no help there
    ]Perms are correct on the server, all services are running AFAICT
    []Root owns /images and the dir is 777 (all my images are still there) Whew!
    ]/opt/fog/service/etc/config.php contains no database details, but the error remains even if I add details
    [*]/var/www/fog/commons/config.php does have db details. I never worked on these files prior to the upgrade.
    Any pointers please?

    EDIT 2 Mar, 11am SAST : The log now shows “Failed to connect to database server” but as mentioned above, even if I add the db details to /opt/fog/service/etc/config.php I still have the same errror.


  • Cool! I’m glad to hear that you got it working.

    Hi Mark,
    I had no success trying these various options, so I made good backups again and re-installed the Ubuntu server to the latest current LTS. Then I installed the same FOG version as before - create DB, import the sql, check and edit passwords, etc, etc as per forum threads.
    When all was working to my stisfaction I upgraded FOG to the latest version. All is running sweetly now 🙂


  • You may have to change (reset) the password in the host OS for the user fog. I had to do that after an upgrade, and that did fix the issue. You’ll need to make sure that it matches what you have set in Storage Management::All Storage Nodes::DefaultMember

    Management Username
    Management Password

    Good luck

  • I checked - the tftpboot is owned by fog, group = root, perms = 0755. I made the perms 0777 as a test, but that made no diff.

    /images is on a separate partition, is mounted with owner and group = root, perms = 0777.
    There is a .mntcheck file in the root of /images (can’t remember what it does though).


    PS: Sorry to be such a pain…

  • From what i’ve read, the PXE-T02 error means that the TFTP server doesn’t have rights to write to the requested file. Have you tried to chmod the tftpboot folder?

  • I re-installed and now I can create a Task, but a machine on boot up still gives:
    “PXE-T02 Forbidden Directory; PXE-E3C Acces Violation”

    This sounds like a permission error, but I’ve looked at perms and they seem ok?


  • @kevin

    This may be it! I read that page and am ging to try it. My scenario fits almost like a glove… Will get back (I know, so many never do, but I’ll try - promise).


  • According to, [url]http://community.spiceworks.com/how_to/show/373[/url], you need to re-install FOG. Though i’m not sure if that’s 100% true.

    “UPGRADE NOTE: If Upgrading Ubuntu from 9 to 10, you will need to re-install fog. Ubuntu 10 changed around some stuff in the init folders. I am not a linux geek so I cant explain it. But for further information see paul2019’s comments below.”

    I’m assuming 8 to 10 would be the same scenario.

  • @stark235

    I tried that in in /var/www/fog/commons/config.php, but no change - thanks anyway.

    When I PXE boot a client I notice it cannot connect to the tftp server with this error:
    “PXE-T02 Forbidden Directory; PXE-E3C Acces Violation”
    Maybe that helps? I can’t see why any directory would be denied. I’m see what Google gives on these.


  • In the fog web Ui under Other information > Fog setting, you should see, FOG_STORAGENODE_MYSQLUSER
    FOG_STORAGENODE_MYSQLPASS. try contecting to your mysql data base using these settings.