SOLVED GuiWatcher On Windows 7

  • I have noticed that the GuiWatcher does not work on Windows 7. It puts the information in the log like it worked, but nothing ever pops up on screen, is there something that needs to be changed in the service to make this work?


  • This is still a problem, though I haven’t had much time to look at C# or learn it rather. I will attempt over the next few months at my take of recoding/working the FOG Client Scripts.

  • Yes I have been reading up on the fog client and issues with Win 7 and Vista needing a try application to produce GUI pop up messages. But C# is beyond my skill levels at the moment. I’m trying to learn as I really want to redesign the snapin to pull from local storage.

  • Developer

    Correct, Windows Vista and up introduced service “interactive mode” - basically it stops services interacting with your desktop… i.e. viruses & malware

  • Developer

    it looks like you cannot get a service to show a messagebox or GUI but you CAN get an application and service to communicate… maybe we could utilise the FOG Tray and move the responsibility of the actual GUI (Messagebox) into the FOG Tray application, that way you could get message boxes again… but it would also mean FOG Tray would need to be compulsary, i know some people don’t like having the tray icon, maybe add “Hide Tray Icon” to the application?.. just my suggestions 🙂

  • Developer

    If someone is capable & willing to rewrite the FOG Service Code for me (Visual C#), please send me a PM.

  • I noticed that the GUIwatcher placed an icon on the taskbar when trying to pop up a message on windows 7. Also noticed that in the fog.log that the word “Installation” is spelt incorectly when trying to install applications via snapin [Just thought I would mention it :-)]

  • That would be great. We disable UAC with GPO, I would be more than willing to help test any changes that are made.

  • It has to do with UAC I believe. It’s a known issue with the current release.

    I’m going to see if we can’t get this thread moved to the Dev forum and have them be reminded of this issue now that the old forums are gone. 🙂

  • Does anyone have this working or any updates on it’s ability to work?