Thinkcentre M57p wont register



  • Good day.

    I have 60 Lenovo Thinkcentre m57p (6073-A14) machines that were recently procured. I’m trying to register the machines but the get to the point where it says it preparing to register but it fails and the error goes of the screen too fast.

    Has anyone tried adding this brand machines and have the same issue?



  • @Mentaloid, post: 36203, member: 4362 said:

    You upgraded to 1.2.0? If so, you might want to verify that the default domain settings are correct in FOG config, noting that the domain portion should NOT be included in the username anymore.

    If you have clients that are not using the default (as in you specified the OU, and therefore the rest of the domain settings as well), then you may need to double check the individual clients/groups as well for misconfigured domain/user’s
    hmmm thats interesting. i will have to try that when i return to work. the domain user section that is. When i searched the 2202 error is an AD authentication error and not a fog error, stating that the provided name is incorrect or in wrong format



  • @Jaymes Driver, post: 36168, member: 3582 said:

    Is this by chance an old image? I have had problems like this happen (with one unit in particular that we use for nComputing) where the Administrator user becomes corrupt and had to be removed. I also add a SECOND administrator when I use the unattend file, i name him Admin, that way I have two instances in which to enter as the admin user.

    The only resolve I had for my issue was to set my image up again, it was daunting and well worth it!

    I am glad you got your FOG issue fixed, and thanks for telling us HOW you fixed it, that will help users in the future, I hope you get your image issue fixed :(
    Thanks i always try to share solutions to problems i encounter as someone sure will be in my position somewhere down the line. No its not an old image. The win7 images are new and its my first time doing sysprep and first time deploying win7 on fog



  • @Juan Antonio, post: 36077, member: 23837 said:

    dof You set up the domain in FOG?
    Yes i did set it up. i had it setup prior to the upgrade



  • You upgraded to 1.2.0? If so, you might want to verify that the default domain settings are correct in FOG config, noting that the domain portion should NOT be included in the username anymore.

    If you have clients that are not using the default (as in you specified the OU, and therefore the rest of the domain settings as well), then you may need to double check the individual clients/groups as well for misconfigured domain/user’s


  • Developer

    @dwayneS, post: 36032, member: 25830 said:

    Yes all of that was done and was working OK from day 1. After making the changes I mentioned above all was well. I only have 2 issues now.

    1. a section of my unattended file seems to not work. There is a command to enable the administrator account but that not working. I need to revisit.
    2. The computer is not being joined to the domain via fog client service. When I check the log file I get an unknown error 2202.

    Is this by chance an old image? I have had problems like this happen (with one unit in particular that we use for nComputing) where the Administrator user becomes corrupt and had to be removed. I also add a SECOND administrator when I use the unattend file, i name him Admin, that way I have two instances in which to enter as the admin user.

    The only resolve I had for my issue was to set my image up again, it was daunting and well worth it!

    I am glad you got your FOG issue fixed, and thanks for telling us HOW you fixed it, that will help users in the future, I hope you get your image issue fixed :(



  • dof You set up the domain in FOG?

    sshot-1.png



  • It seems to be correct, do not know what can be the problem.



  • Here is my unattend.xml. After imaging the machine the Administrator account was still disabled and fog service still could not add machine to domain.

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="generalize">
            <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>1</SkipRearm>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <Path>c:\windows\system32\net user administrator /activate:yes</Path>
                    </RunSynchronousCommand>
                </RunSynchronous>
            </component>
            <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="wow64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Home_Page>http://www.jamaicacollege.org</Home_Page>
                <BlockPopups>yes</BlockPopups>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName></ComputerName>
            <UserAccounts>
            <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>password</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Description>Local Administrator</Description>
                            <DisplayName>Administrator</DisplayName>
                            <Name>Administrator</Name>
                            <Group>Administrators</Group>
                        </LocalAccount>
                    </LocalAccounts>
                    <AdministratorPassword>
                        <Value>password</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
            </UserAccounts>   
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Reseal>
                    <Mode>OOBE</Mode>
                </Reseal>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                </OOBE>
            </component>
        </settings>
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>en-US</UILanguage>
                </SetupUILanguage>
                <InputLocale>en-US</InputLocale>
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-US</UserLocale>
            </component>
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <WillShowUI>OnError</WillShowUI>
                  <Disk>
                      <DiskID>0</DiskID>
                      <WillWipeDisk>true</WillWipeDisk>
                      <CreatePartitions>
                        <CreatePartition>
                <!-- Create the system partition-->
                            <Order>1</Order>
                            <Type>Primary</Type>
                            <Size>100</Size>
                        </CreatePartition>
                <!-- Create the Windows partition and fill the rest of the hard disk -->
                        <CreatePartition>
                            <Order>2</Order>
                            <Type>Primary</Type>
                            <Extend>true</Extend>
                        </CreatePartition>
                      </CreatePartitions>
                      <ModifyPartitions>
                <!-- Modify the system partition-->
                        <ModifyPartition>
                            <Order>1</Order>
                            <PartitionID>1</PartitionID>
                            <Format>NTFS</Format>
                            <Label>System</Label>
                        </ModifyPartition>
                <!-- Modify the Windows partition -->
                        <ModifyPartition>
                            <Order>2</Order>
                            <PartitionID>2</PartitionID>
                            <Format>NTFS</Format>
                            <Label>Windows</Label>
                        </ModifyPartition>
                      </ModifyPartitions>
                  </Disk>
        </component>
                <UserData>
                    <ProductKey>
                        <WillShowUI>OnError</WillShowUI>
                        <Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                    <FullName>Jamaica College</FullName>
                    <Organization>Jamaica College</Organization>
                </UserData>
        </settings>
        <cpi:offlineImage cpi:source="catalog:d:/sources/install_Windows 7 PROFESSIONAL.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    


  • You can show unattended xml sysprep?



  • Yes i had seen something like that. I need to check how server 2008 accepts the domain user credentials for user name.

    I have a command in the unattend file that should enable the Administrator account. By default sysprep disables the Administrator account. So i need to revisit that section of my file



  • See this link



  • Error 2202: from what I’ve read refers to the user name or group name parameter is invalid, you should check server settings.

    What do you mean? about “a section of my unattended file seems to not work”



  • Yes all of that was done and was working OK from day 1. After making the changes I mentioned above all was well. I only have 2 issues now.

    1. a section of my unattended file seems to not work. There is a command to enable the administrator account but that not working. I need to revisit.
    2. The computer is not being joined to the domain via fog client service. When I check the log file I get an unknown error 2202.


  • Has FOG server static IP?
    Did you set up in the DHCP server to redirect PXE requests to the IP of FOG? (Server 08 DC)



  • Oh ok. Yes its integrated into network. Clients get IP from my Server 08 DC



  • Your FOG works as DHCP server or is integrated into another network ??



  • I had to change the IP in these 3 places via fog web interface

    • General Setting: [B]FOG_WOL_HOST[/B]
    • TFTP Server: [B]FOG_TFTP_HOST, FOG_PXE_IMAGE_DNSADDRESS[/B]
    • WEB Server: [B]FOG_WEB_HOST[/B]

    After that i had to change the IP in the [B][I]/tftpboot/default.ipxe [/I][/B]file
    I don’t quite get you last question.



  • What type of facility used for initial configuration of FOG?



  • You can chage de FOG IP from fog configuration, fog setting, general setting,

    sshot-3.pngsshot-2.pngsshot-1.png


Log in to reply
 

417
Online

38920
Users

10688
Topics

101407
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.