• I have hit a bit of a snag in my project to get fog up and going. I installed fog in Ubuntu 11.10 running in virtual box. Everything was going smoothly and I got to the point of wanting to upload an image. I loaded fog onto the client pc, but could not get it to register. My next “bright” idea was to start changing passwords in the config.php files as I had read on different websites to correct part of my problem. I am not running any sort of external ftp to host or upload images to but i changed the tftp password in both the webui and /var/www/fog/commons/config.php files. I also updated my mysql passwords as described in the tutorials. Once changing my tftp_ftp_password in webui to my fog password I get “unable to connect to host”. Is there anything I can do to reverse what I did or somehow get default tftp passwords that would allow me to access webui. Thank you all in advance.


  • Sk00t3r,

    I appreciate you taking your time to help me after making sure all my passwords were correct I started looking through my notes. I found one file that i had documented that I had messed with. This file was /etc/mysql/my.cnf. For some reason when i switched my bind address i must have not hit save when i updated my ip address. Once again thank you for you time.

  • In your original post you said “Once changing my tftp_ftp_password in webui to my fog password I get “unable to connect to host”.”

    I am trying everything I can think of but this error does not come from chaging that password. To double check I logged into my fog server changed that password rebooted and logged in again with no issues. Im sure i will not be able to boot a client up to the fog server but the WEBUI should NOT be affected in anyway by this change.

    The ONLY way I have replicated this error is by typing the WRONG password (the one I DID NOT use at the SQL setup portion of the fog server) into:

    “MYSQL_PASSWORD” “xxxxxxxxxxxx”

    does your portion of the config.php look like mine?

    Im sorry I couldnt be of more assistance.


  • I’m a bit confused. I didn’t think you could login to the fog account when it creates it. Also I tried leaving the password blank in both files but still got the same error. The guide i followed had me enter a password and i made sure to right it down so i don’t think it is a lack of not know my password. If I somehow fat fingered it when changing in the webui could that be my problem?

  • Oh sorry read your post again your login needs to be set to “fog” as the username NOT USER.

  • Did you use the password “fog” for your MYSQL database when setting it up? or did you leave it blank? (most guides i have read say just leave it blank so if you followed a guide perhaps you also left it blank and thats what it should be). It really sounds like you have the incorrect password set to login to the SQL database “fog”.

    Make sure you have the password entered at the initial setup for the SQL database entered in /var/www/fog/commons/config.php and also check /opt/fog/service/etc/config.php

  • I have the same password entered there as my other ones. Also i login to my ubuntu account with my name as user and fog as my password. Having that password set to fog conflict with something by chance?

  • Ok looks like its not able to connect to the MYSQL database. Scroll down farther in your config.php file (the 3rd red box in my picture above) and make sure you have the correct password in there (the the one you entered while setting up fog initially) (the database should be fog the user should be root), also is your username and password to logon to your ubuntu pc fog/fog?

  • Sorry about that.

    [url="/_imported_xf_attachments/0/54_Browser screenshot.png?:"]Browser screenshot.png[/url][url="/_imported_xf_attachments/0/55_config screenshot.png?:"]config screenshot.png[/url]

  • your images are not showing up. Set them up as an attachment.

  • Ok, sorry I maybe confused here. Can you take a screen shot of the error and a screen shot of your config.php?

  • I do get the message it works, but still unable to connect to host when logging into webui.

  • You have the correct password in where I marked mine out in red?

    Also if you type in your ip address or host name into your browser do you get the IT WORKS! message?


  • Sk00t3r

    All passwords match just like you said you had yours set up. Is there any other file location that might be preventing me from accessing the webui?


  • /var/www/fog/commons/config.php

    4th line down :
    define( “TFTP_FTP_PASSWORD”, “xxxxxxxxx” )

    place the password you need where the xxxxx are.

    I used the same passwords for everything (MYSQL, Ubuntu User {fog}, & TFTP) it helps keep everything clean.