• Hello everyone
    I have a problem with fog 1.2.0, when I try to boot with PXE nothing happens. This is my first time using fog so I don’t have much experience with it.
    I think that I have problem with tftp but I’m not sure about it. I’ve installed fog like described here [url]http://www.fogproject.org/wiki/index.php/Installation_on_CentOS_6.4[/url]
    First things first - SELinux status: disabled so no problem with that
    iptables are also disabled - no problem with that either
    I’m using windows server as DHCP and I’ve set scope options 66 (Boot server host name) as ‘FOGSERVER’ and 67 (bootfile name) as ‘pxelinux.0’ (also tried with ‘undionly.kpxe’).
    When I try to use tftp on CentOS machine like ‘tftp -c get boot.txt’ it downloads me desired file to desired directory but on my other (windows) machine it says connection timed out but I can access fog management page on that machine.
    Any help would be appreciated 😉

  • I’ve tried upload task and then download task and it works like charm
    Thanks a lot everyone 😉

  • This post is deleted!

  • Upload = Upload will pull an image from a client computer that will be saved on the server.
    Download = Deploy action will send an image saved on the FOG server to the client computer with all included snapins.

    Upload is for creating.
    You cant download/deploy an image because you don’t have one.

    Try an upload task.

  • No, I haven’t because I don’t have any image to upload. I’ve just tried to change image OS setting to eg. ‘windows-other’ and with that change I can create a task but when pxe boots I get error like invalid OS ID on target PC. I still can’t create a task while having ‘Windows 7’ as image OS.

  • Have you uploaded an image ?

  • I’ve checked topic and did ‘gdisk -l /dev/sda’. This is what I’ve got:
    [CODE]GPT fdisk (gdisk) version 0.8.10

    Partition table scan:
    MBR: MBR only
    BSD: not present
    APM: not present
    GPT: not present

    Found invalid GPT and valid MBR; converting MBR to GPT format
    in memory.

    Disk /dev/sda: 976773168 sectors, 465.8 GiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): 2A376EEF-D28F-4A6D-903B-F053F2B9AC3A
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 976773134
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 2029 sectors (1014.5 KiB)

    Number Start (sector) End (sector) Size Code Name
    1 2048 1026047 500.0 MiB 8300 Linux filesystem
    2 1026048 976773119 465.3 GiB 8E00 Linux LVM

    But it doesn’t make any sense that if I choose Windows 7 for OS in image management that I can’t download a image but can when I choose ‘Other’. Here is screenshot of image settings and when I want to download that image from target PC I get this message:
    ‘Download task failed to create for [U]Rec1[/U] with image [U]rec[/U]
    To setup download task, you must first upload an image’.


  • You can also check the ftp password in the GUI under Fog Configuration/Fog Settings/TFTP Server/FOG_TFTP_FTP_Password and make sure it matches what is in Storage Management/{Your Storage Node}/Management Password.

    It sounds like a issue with boot record on the boot computer you used to upload. Check out post 6 and after on [url]http://fogproject.org/forum/threads/stuck-on-dev-sda.11105/[/url]

  • I’ve entered IP of CentOS machine in DHCP and it, let’s say, worked. I’ve moved from dead point but still couldn’t get a image. I have a strange problem now. It ‘worked’ on one PC which I’ve used for test but when I try to download a image from non-test PC I get this error
    ‘Download task failed to create for [U]Rec2[/U] with image [U]Rec1[/U]
    To setup download task, you must first upload an image’.
    But there are no errors for my test PC when I try to download a image :S
    FTP is working with fog and changed password (did ‘passwd fog’, then changed password in configuration on fog configuration -> fog settings menu and in this file ‘/var/www/html/fog/lib/fog/Config.class.php’ (TFTP_FTP_PASSWORD and STORAGE_FTP_PASSWORD). Do I need to change it anywhere else?

    EDIT: I’ve found that if I set Windows 7 as image OS it won’t work (Download task… error) but if I set image OS to Other then it will create a task but I’ll get error on remote PC (wrong OS selected)

  • Its probably a problem with your DHCP config. The boot filename should not be pxelinux.0, it should be undionly.kpxe. I just setup another fog server using CentOS 6.5 today and there are no quirks with that distro.