Windows 7- image deploys fine but 'operating system not found' on first reboot

  • Hi guys,

    I’ve started work on my Windows 7 soe. I’m creating it on a virtual machine, and occasionally uploading the image to Fog at various points to test it on some physical machines.

    I have just attempted to deploy the image to a Dell Optiplex gx745. The image deploys fine, but on first reboot instead of starting the sysprep minisetup like it should, it just says ‘operating system not found’

    Some info about my setup:

    The windows 7 image is created as a ‘NTFS Only, resizeable’ image (I made sure that during initial install of Windows 7 I only used 1 partition, so there is no hidden 100mb partition to worry about). The virtual machine that I am creating the image from has a 40GB virtual disk. I run the fogprep tool before capturing the image.

    The client machine I am deploying fog to is a Dell gx745 with an 80gb hard drive. In Fog, I’ve changed the host os for this client to be Windows 7. I’ve tried both ‘normal’ and ‘legacy’ options for sata operation in the bios.

    Just not sure why it isn’t working. Any suggestions?


  • Found out how to have the partition extended to cover the whole disk via this thread:


  • Update- choosing the ‘non resizable’ image type fixed the issue. I have been able to successfully deploy the image on two different machines.

    Next up is to work out how to have the image use the entire disk via sysprep. Any pointers on this one?

    Thanks guys

  • That’s news to me about the 100mb partition being expected by FOG for a single partition type. I’m sure that when I started looking at Windows 7 deployment via Fog, the general consensus was that if you wanted to have a single, resizable partition you needed to ensure that your Windows 7 image was a single partition. When did this change? Is it documented somewhere?

    For what its worth, there’s nothing wrong with running Windows 7 without the 100mb partition- it isn’t like you are using a hack or something that will make the installation unstable. If when installing Windows 7 a ntfs partition already exists that takes up the whole disk, Windows 7 will happily install on that.

    Thanks for the suggestions. I guess I can try a non resizeable image and then do the resizing via sysprep mini setup.

  • FOG expects the 100MB partition to be there for the Single Partition type, it’s built to handle it. I’m not sure how it reacts to the 100MB partition not being there.

  • we ran into similar issues here at work… we had to run a fix mbr on the machines to get them to boot.

    if you selected non-re sizable it should resolve some of your issues. Give it a shot.