• Good afternoon,
    I am really confused right now, have been working for the past week to configure the server & the network to get it working with FOG. Yesterday after successfully multi-casting two machines I felt a feeling of accomplishment. He he, I guess two soon.

    Yesterday I had troubles with multi-casting although unicasting worked. Then after I upgraded to latest SVN the multi-casting started to work.

    Today I noticed that there’s a new FOG release, 1.2.0 (previously I had 1.1.2 and unfortunately I don’t remember the SVN that I downloaded yesterday). Either way - today is the same story all over again, multi-cast is not working while unicast works perfectly fine.

    [SIZE=3]I get stuck at this “[URL=‘http://fogproject.org/forum/threads/fog-1-1-0-multicast-sits-at-starting-to-restore-image-to-device-dev-sda1.10782/’]Starting to restore image (-) to device (/dev/sda1)[/URL]”[/SIZE]

    [SIZE=3]Is there any possible solution I could try to solve this?[/SIZE]
    [SIZE=3]Any help would be greatly appreciated. [/SIZE]

    [SIZE=3]Thank you in advance,[/SIZE]
    [SIZE=3]Sincerely - Davis [/SIZE]

  • It looks like we have resolved this issue by installing Ubuntu 14.04 on both our FOG server and image server and then installing the GlusterFS as per Tom’s advice. Thank you Tom for all of your help.

  • I have done a fresh install of Ubuntu 14.04 LTS and SVN and restored database.
    Now the multicast process doesn’t stop but it still doesn’t multicast.
    Here is the log:

    [07-24-14 1:55:48 pm] * No tasks found!
    [07-24-14 1:55:58 pm] | Task (1) Multicast Group Quick Deploy is new!
    [07-24-14 1:55:58 pm] | Task (1) /images/PeteTest image file found.
    [07-24-14 1:55:58 pm] | Task (1) 2 client(s) found.
    [07-24-14 1:55:58 pm] | Task (1) Multicast Group Quick Deploy sending on base port: 58570
    [07-24-14 1:55:58 pm] CMD: cat /images/PeteTest/rec.img.|/usr/local/sbin/udp-sender --min-receivers 2 --portbase 58570 --interface eth0 --full-duplex --ttl 32 --nokbd;cat /images/PeteTest/sys.img.|/usr/local/sbin/udp-sender --min-receivers 2 --portbase 58570 --interface eth0 --full-duplex --ttl 32 --nokbd;
    [07-24-14 1:55:58 pm] | Task (1) Multicast Group Quick Deploy has started.
    [07-24-14 1:56:08 pm] | Task (1) Multicast Group Quick Deploy is already running PID 2520
    [07-24-14 1:56:18 pm] | Task (1) Multicast Group Quick Deploy is already running PID 2520

    I have checked all of the options we have previously gone through in this thread and omping does work for multicast. Any ideas since we can get this far?

  • exports file, I mean.

  • Also, why wouldn’t I change the /etc/exports folder on the fog server to match the image box:?

    /images *(rw,sync,no_wdelay,no_root_squash,insecure)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)

  • No,

    Because the /images directory is still mounted read only.

  • Would it make sense to change the owner of PeteTest to www-data for testing purposes?

  • Yes.

    Unicast access the file system on /images as root user.

    This means that it’s the same permissions as if it were on the nfs.

    The Multicast tasks, initially, get started from the www-data user. So if permissions are read only, it can’t execute anything on them.

  • Unfortunately, we did run out of space on this so we can’t test on the one server. Do you think permissions would be an issue since unicast imaging does work?

  • okay, thank you,

  • This says it will take about 18 minutes. I will leave it running but I have to leave the office now. I really appreciate your help with this and will report back in the morning with a status.

    Thank you very much.

  • mkdir /images/dev
    touch /images/dev/.mntcheck

  • touch: cannot touch `/images/dev/.mntcheck’: No such file or directory

  • Then I’m at a loss as to what this issue is.

    One last thing to try if at all possible:
    [code]umount /images
    touch /images/.mntcheck
    touch /images/dev/.mntcheck
    scp -r /images/
    chown -R root:root /images
    chmod -R 777 /images[/code]

    If you have enough room of course. Then try redoing the tasking, does all work?

  • done. restarted nfs kernel servers and FOGMulticastManager and still not working

  • The image box.

  • They both match. Which should I change, fog server or image box?

  • Then restart the NFS services on both the hosting images box and the fog server.

    [code]sudo service nfs-kernel-server restart[/code]

  • Okay,

    I’d say copy the exports from there to your FOG Server, if they don’t match already.

    In that exports only set:

  • That is from the box where the images are stored.