Version 1.2.0 released!

  • The FOG Project team is proud to release the latest of FOG as version 1.2.0.

    With this release comes many new features including the ability and support for Linux and multiboot resizable imaging. Thanks in particular to Curtis Larsen of the FOG Project team.

    Please download and try the latest in FOG. The download can be found at:

    SVN Release for this is SVN Revision 2094.

  • Banned

    This post is deleted!

  • I just updated to 1.2 and it is flawlessly imaging my whole lab over to Ubuntu 14.04 LTS. For the first time I don’t have to munge around with Grub, fix a bunch of swap partitions, and just generally pull my hair out. It Just Worked.

    Thanks for maintaining this amazing tool. I love this release.

  • Developer

    it downloaded to what ever folder you were in when you ran the sudo wget command.

    Normally that would be a home folder unless you changed the directory and then ran the command.

    check your home folder, type ls to see a list of current folders and files.

  • I was able to download the latest update using sudo wget [url][/url]

    It seemed to download fine, but don’t know where to go from there to get it installed. I am running a linux server with no GUI, and I don’t see where the update downloaded to.

  • [quote=“Tom Elliott, post: 35753, member: 7271”]Where are you trying to download FOG From?[/quote]

    Hi Tom,

    I’m now able to download the file. There was a problem with the network of Sourceforge.

    Greetings and thanks for this fantastic program!

  • [quote=“jjacobs, post: 35747, member: 516”]Hi,

    The download of 1.2.0 is not working for the moment.
    Is there an other site to download fog from?


    Where are you trying to download FOG From?

  • Hi,

    The download of 1.2.0 is not working for the moment.
    Is there an other site to download fog from?


  • Hi Mr. Daniel Murga,
    In my case, with a help from Tom Elliot, the firewall was the problem.
    I am running a local firewall on fog machine and unblocking ports to my clients (20,21) solved my problem.
    If you need more details, see: [url][/url]

  • I get the same error as Thiago:
    These error appear in image listing:

    FOGFTP: Failed to connect. Host:xxxxxxxxxxxxx, Error: Undefined variable: whereArray

    How can i fix ?

  • Tom,

    I did the delayed start of mysql as indicated on the rc.local file.

    now the tftpd-hpa wont respond to requests unless I stop it manually and start it again.

    I disabled tftpd-hpa by:
    sudo update-rc.d tftpd-hpa disable

    then tried doing the same for the tftpd-hpa on the /etc/rc.local file and added:

    sleep 30 && start tftpd-hpa

    but I still need to top and start tftpd-hpa manually by doing this:

    sudo stop tftpd-hpa
    sudo start tftpd-hpa

    then it works…

    Any ideas???

  • What do you get if you run:
    [code]mysql -u root [ -p #only if you have a db password ] fog
    select * from images where imageName="<a name of your image here>" \G;[/code]

  • When creating images in fog ui, these error appears on listing:
    FOGFTP: Failed to connect. Host:, Error: Undefined variable: whereArray

    How can i fix ?

  • Choose either Linux or Windows OS type, not other.

  • [quote=“BigDawg986, post: 34017, member: 75”]Thanks, I should have figured as much but whenever I set up multiboots I always put each OS in a separate partition so that’s why I asked.[/quote]
    which option should I choose to get an image (from win/lin disc) resizable?
    my settings:
    Operating System: Other (99)
    Image Type: Single Disk (Resizable) -(1)

    What i have to do, to clone from 250GB to 160GB (hd size) ?

    Thanks and sorry about my inexperience

  • Okay, so the issue, I believe, is because if ibdata.log.

    Try the steps at the top of this issue in my github?

  • Tom,

    I restarted the server several times, and it seemed to load the web interface but then a minute after it was displaying the “Database Schema Installer / Updater” accompanied by the client PCs not able to load anything from TFTP… This is the same for the other two FOG Servers I installed from scratch on Ubuntu 14.04.

    Here are the steps I followed, in case they are of help:
    []Installed Ubuntu 14.04 from flash drive with options:
    ]Download Updates during Install
    []Erased Hard drive (it was brand new but nothing else installed)
    []Installed all Ubuntu updates (nothing else added or installed)
    []Installed FOG 1.2.0 from TAR:
    ]Downloaded FOG 1.2.0
    []tar xvzf fog_1.2.0.tar.gz
    ]sudo ./
    []Followed prompts for Debian (Ubuntu install)
    ]Normal Install
    []No DHCP
    ]Selected appropriate Router Address
    []Entered DNS IP
    ]Left MySQL password blank
    []Logged in to web interface to install Schema
    ]Hit Enter to proceed
    After that I did:
    []Quick registered host with Master Image
    ]Capture image from first host (Image ID # 1)
    []Full hosts registration for 29 computers
    ]Selected Image ID 1 for all hosts
    []Created group for the 29 computers (computer lab)
    ]Multicasted image to 29 clients
    []Shut down server (yesterday)
    ]Turned on server today
    [*]Tried to multicast image again on the next day (we were testing imaging) and started to get the page for the schema update

    • Created user to allow login via PXE Menu
    • Edited the PXE Menu to Timeout 5 seconds and Hide menu - Press F9 to login

  • Can you try:
    sudo service mysql restart, or simply a system reboot? Maybe firewall is blocking access to mysql from your systems?

  • Tom,

    Yes, confirmed, the settings are as follows on /var/www/fog/lib/fog/Config.class.php

    DATABASE_HOST ‘localhost’

  • [quote=“Jose Antonio Sanchez, post: 34455, member: 25349”]Tom,

    It went right in… no password set, and it took me to the “mysql>” prompt (it also displays MySQL version info before that - 5.5.38-0ubuntu.14.04.1 (Ubuntu))[/quote]

    Then can you check the /var/www/fog/lib/fog/Config.class.php file specifically under the db_settings() method and make sure the DATABASE_HOST is localhost, DATABASE_NAME is fog, DATABASE_USERNAME is root, and DATABASE_PASSWORD is ‘’