My FOG 1.1.0 broken - Please help



  • Hello,

    I’ve recently upgraded my FOG installation 2 days ago from 0.32 to 1.1.0 and all went well; apart from an issue with the Kernel which Tim Elliot sorted out for me. So since then it’s been working fine. However this afternoon, when I tried re-imaging a computer, FOG kept prompting invalid login at the Quick Image option, so I decided to login via the web UI to look at the problem; but I couldn’t login with my usual credential. The web UI kept prompting invalid login as well.

    So I restarted the FOG server itself and this hasn’t fixed the issue. The last thing that was done before I tried running Quick Image was an Image Upload; which seem to have been successful upon logging to the FOG server I can’t even locate the said image within the \images directory.

    Just in case, at the moment there is about 55 GB storage space left on the FOG server storage.

    I would appreciate if someone can help with this.

    Thanks.


  • Senior Developer

    Please see the following issue with possible fix for this issue.

    This is being posted so all can try and see if this helps.

    [url]https://github.com/mastacontrola/fogproject/issues/1[/url]



  • Hi Tom,

    Attached is MySQL error log file. The forum won’t let me post it.

    [url="/_imported_xf_attachments/1/1004_MySqlerrorLog.txt?:"]MySqlerrorLog.txt[/url]


  • Senior Developer

    No,

    By chance can you print a few lines of your /var/log/mysql/mysql.err log or one of the log files in the /var/log/mysql directory?



  • Hi Tom,

    Do you think I should downgrade to 0.32? This was the version we had before the upgrade.
    Luckily I created the database backup before upgrading to 1.1.0; and we’ve got images that were created with the 0.32. Will these images work after the downgrade?

    Also how do I go about the downgrade?

    Thanks.



  • An update:

    I’ve just had a look at my /var/log/apache2/error.log after trying to login to the web UI unsuccessfully; the error log says:

    [COLOR=#ff0000][Mon Jun 16 08:34:19 2014] [error] [client 200.168.212.226] PHP Fatal error: Call to a member function mainMenu() on a non-object in /var/www/fog/management/index.php on line 70, referer:[URL=‘http://<ip_address>/fog/management/?node=login’][COLOR=#ff0000]http://200.168.212.226/fog/management/?node=login[/COLOR][/URL][/COLOR]

    And below is a copy of my install.log from /var/log/foginstall.log:

    Script started on Mon 16 Jun 2014 07:53:39 BST

       ..#######:.    ..,#,..     .::##::.   
    

    .:###### .:;####:…;#;…
    …##… …##;,;##::::.##…
    ,# …##…##:::## …::
    ## .::###,##. . ##.::#.:######::.
    …##:::###::…#. … .#…#. #…#:::.
    …:####:… …##…##::## … #
    # . …##:,;##;:::#: … ##…
    .# . .:;####;::::.##:::;#:…
    # …:;###…
    ###########################################

    FOG

    Free Computer Imaging Solution

    [url]http://www.fogproject.org/[/url]

    Developers:

    Chuck Syperski

    Jian Zhang

    Peter Gilchrist

    Tom Elliott

    GNU GPL Version 3

    ###########################################
    Version: 1.1.0 Installer/Updater

    • Found FOG Settings from previous install at: /opt/fog/.fogsettings
    • Performing upgrade using these settings…
      Starting Debian / Ubuntu / Kubuntu / Edubuntu Installtion.

    #####################################################################
    FOG now has everything it needs to setup your server, but please
    understand that this script will overwrite any setting you may
    have setup for services like DHCP, apache, pxe, tftp, and NFS.

    It is not recommended that you install this on a production system
    as this script modifies many of your system settings.
    This script should be run by the root user on Redhat or with sudo on Ubuntu.
    ** Notice ** Redhat users will need to disable SELinux and iptables in
    order to use FOG
    Please see our wiki for more information at [url]http://www.fogproject.org/wiki[/url]

    Here are the settings FOG will use:
    Base Linux: Debian
    Detected Linux Distribution: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 200.168.212.226
    DHCP router Address: 200.168.212.220
    DHCP DNS Address:
    Interface: eth0
    Using FOG DHCP: 1
    Internationalization: 0
    Donate: 0

    Are you sure you wish to continue (Y/N) y
    Installation Started…
    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Preparing apt-get
    • Installing package: apache2
    • Installing package: php5
    • Installing package: php5-json
    • Installing package: php5-gd
    • Installing package: php5-cli
    • Installing package: php5-mysql
    • Installing package: php5-curl
    • Installing package: mysql-server
      We are about to install MySQL Server on
      this server, if MySQL isn’t installed already
      you will be prompted for a root password.
      Press enter to acknowledge this message.
      Reading package lists…
      Building dependency tree…
      Reading state information…
      mysql-server is already the newest version.
      The following packages were automatically installed and are no longer required:
      libtommath0
      Use ‘apt-get autoremove’ to remove them.
      0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    • Installing package: mysql-client
    • Installing package: isc-dhcp-server
    • Installing package: tftpd-hpa
    • Installing package: tftp-hpa
    • Installing package: nfs-kernel-server
    • Installing package: vsftpd
    • Installing package: net-tools
    • Installing package: wget
    • Installing package: xinetd
    • Installing package: sysv-rc-conf
    • Installing package: tar
    • Installing package: gzip
    • Installing package: build-essential
    • Installing package: cpp
    • Installing package: gcc
    • Installing package: g++
    • Installing package: m4
    • Installing package: htmldoc
    • Installing package: lftp
    • Installing package: openssh-server
    • Installing package: php-gettext
    • Installing package: clamav-freshclam
      Confirming package installation.
    • Checking package: apache2…OK
    • Checking package: php5…OK
    • Checking package: php5-json…OK
    • Checking package: php5-gd…OK
    • Checking package: php5-cli…OK
    • Checking package: php5-mysql…OK
    • Checking package: php5-curl…OK
    • Checking package: mysql-server…OK
    • Checking package: mysql-client…OK
    • Checking package: isc-dhcp-server…Failed!
    • Checking for legacy package: dhcp3-serverOK
    • Checking package: tftpd-hpa…OK
    • Checking package: tftp-hpa…OK
    • Checking package: nfs-kernel-server…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: sysv-rc-conf…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: build-essential…OK
    • Checking package: cpp…OK
    • Checking package: gcc…OK
    • Checking package: g++…OK
    • Checking package: m4…OK
    • Checking package: htmldoc…OK
    • Checking package: lftp…OK
    • Checking package: openssh-server…OK
    • Checking package: php-gettext…OK
    • Checking package: clamav-freshclam…OK
      Configuring services.
    • Setting up fog user…Exists
    • Setting up and starting MySql…OK
    • Backing up user reports…OK
    • Did you leave the mysql password blank during install? (Y/n) Y
    • Setting up and starting Apache Web Server…OK
      You still need to install/update your database schema.
      This can be done by opening a web browser and going to:
      [url]http://200.168.212.226/fog/management[/url]
      Press [Enter] key when database is updated/installed.
    • Configuring Fresh Clam…OK
    • Setting up storage…OK
    • Setting up and starting NFS Server…OK
    • Setting up and starting DHCP Server…OK
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…OK
    • Installing init scripts…OK
    • Setting up FOG Services…OK
    • Starting FOG Multicast Management Server…OK
    • Starting FOG Image Replicator Server…OK
    • Starting FOG Task Scheduler Server…OK
    • Setting up FOG Utils…OK

    Would you like to notify the FOG group about this installation?
    * This information is only used to help the FOG group determine
    if FOG is being used. This information helps to let us know
    if we should keep improving this product.
    Send notification? (Y/N)N
    NOT sending notification.

    Setup complete!
    You can now login to the FOG Management Portal using
    the information listed below. The login information
    is only if this is the first install.
    This can be done by opening a web browser and going to:
    [url]http://200.168.212.226/fog/management[/url]
    Default User:
    Username: fog
    Password: password

    Script done on Mon 16 Jun 2014 08:06:43 BST

    Just in case, I’m running Ubuntu 10.04 OS.

    Any ideas?



  • Hello,

    I’ve now ran the installer again this time leaving the MySQL password blank. However, I can’t still login to the FOG web UI with the default login “fog” and “password” that I’ve always used.

    This is happening when I try to login to the web UI on the FOG server itself and from a client PC.

    Any ideas?

    Thanks.



  • OK, I can re-run the installer again; then this time leaving MySQL password blank.

    Thanks


  • Senior Developer

    What that means is you don’t have a root password set for mysql.
    If you had a password set to the mysql server and typed in the mysql -u root fog, the terminal would’ve spit out:
    [code]ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)[/code]

    Mysql doesn’t run because of the /var/www/fog/commons/config.php file. It runs on it’s own.

    You can set a password for mysql but I would recommend against it. When the installer is asking you if you left the mysql password blank either hit enter your type Y and press enter.



  • And this is the issue as reported in web UI…

    [url="/_imported_xf_attachments/0/997_FOGISSUE.jpg?:"]FOGISSUE.jpg[/url]



  • This is the prompt I got with or without MySQL password in Config.php when I typed “MySQL -u root fog” command at the Terminal…

    [url="/_imported_xf_attachments/0/996_FOG2.jpg?:"]FOG2.jpg[/url]



  • No I’m afraid, still not working.
    Seems a strange problem.


  • Senior Developer

    Are things working now?



  • Password removed.

    Thanks.



  • Yes.


  • Senior Developer

    So remove the password from the db_settings field.



  • Typed that in and it took me straight to MySQL> prompt. There was no prompt for credentials.

    Thanks.


  • Senior Developer

    [code]mysql -u root fog[/code]

    Does it let you into the database?



  • I’ve changed the ‘localhost’ to the server’s IP address and restarted MySQL but still didn’t resolve the issue.

    Is there a way I can test MySQL login via Terminal to see if it prompts me for the credentials?

    Thanks.


  • Senior Developer

    I’m going to guess, then that everything is correct and you could actually login to the mysql instance. What happens if you change localhost to the actual FOG Server’s IP address?


Log in to reply
 

367
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.