Latest Development FOG

  • FOG works fine for until SVN 3109. Then I can’t load the web page anymore. All the previous revisions do not have this issue.

  • I tried downgrading to 3109 and I had the same issue, but when I downgraded further to 3102 the FOG GUI comes up fine. I’ll try each new iteration and let you know when the issue started on which revision.

  • Senior Developer

    Can you try in a different browser?

  • I updated from 3101.

  • Senior Developer


    What did you update from?

  • I just updated to 3110 and the web gui will not load for me anymore. It just spins in a constant loading cycle. I can’t even log into it anymore since the page never comes up.

  • Senior Developer


    3101 released.

    This comes with a huge change. First the kernels are now 3.19.1. This done for you for those of you on SVN, but upgrading to 3.19.1 may prove problematic across the board for those on other versions of FOG where the kernel and init’s are NOT downloaded for you, though I’m not 100% sure. The init’s are now updated per our discussion on the Bug Reports about nic registering and what not. The methods that are used are updated to reflect properly as well. Hopefully you all will enjoy as it took a lot of hard work between collaborating (Thank you Uncle Frank and cspence for the help there).

    It also has a lot of changes in how things operate. While I don’t know if things are truly Async, it’s as close as I think we can get until I figure out how to pass things in multiples and getting the returns back in the proper order. From what I can tell though, it feels very fast and may help those on isolated networks. It also, properly, attempts the mysqlnd installation and implementation so we can do async mysql queries using the mysqlnd drivers as many suggest. While again I doubt the queries are truly asyncronous due to there only ever being a single thread for the event to occur and our own mysql/php implementations are in their very nature a locking type of system, but it does seem to be a bit of an improvement.

    Hopefully you all enjoy.

  • Senior Developer

    Probably good to open a new thread for this and post your apache error logs (see Tom Elliot’s signature). I guess you’ve tried clearing browser caches??

  • Hi Tom,

    Using the latest SVN I can’t get into the fog configuration page. All i get in chrome is Version: 3091 and in IE it just errors out and doesn’t display.

    Happy to troubleshoot in any way I can but will need guidance.



    Downloaded Latest SVN (Version 3100) and all is good again.

  • Senior Developer

    I’d say 3078 should be good.

    Not only does it have a “stable” working base now, but it’s also got all the work we put in. It also adds improvements for performance and a couple of new features you may like.

  • So,

    There’s a chance that I might be setting up FOG for my school district using the location plugin.

    What’s the current recommended FOG revision ?

    I want a solid version with as few known problems as possible.

    I was considering using 2920 or 2922 because I’ve had zero serious issues with it so far, and it’s all I’ve used as of yet.

    Also, I have to at least use 2920 because of the custom multicast address changes and Fedora support that it implemented.

  • Developer

    [quote=“YuYo, post: 43152, member: 3300”]
    What’s in 3073 that is not in 3072?

    all changes are documented in the SVN [url][/url]

  • Right! It’s all working now!

  • Senior Developer

    3074 should fix that.

  • Went to try, but I have errors updating the schema … GRRRR!

    I rolled down to Rev. 3072 and I can deploy images correctly.

    What’s in 3073 that is not in 3072?

    Thanks for your time and your patience Tom. We are glad to help you make Fog a better tool 😉

  • That fixed it. Thanks for the hard work Tom.

  • Senior Developer

    Update again and you should see it

  • It’s almost fixed. It does display the correct information but there are not options to enable them or not.[ATTACH=full]1736[/ATTACH]

    [url="/_imported_xf_attachments/1/1736_ScreenHunter_67 Mar. 03 13.21.jpg?:"]ScreenHunter_67 Mar. 03 13.21.jpg[/url]

  • Senior Developer

    service page should now, officially, be fixed, hopefully.

  • The inventory issue is fixed and I can also image correctly again. The only other issue is the one on the services page. That issue is still occurring for me.