FTP Issue When Uploading Images to SAN - Fog 0.33b

  • Not sure if this is the best sub-forum to use but I suspect its not really a Fog bug and more due to the fact my images are stored external to the server.
    My current test setup is Fog 0.33b and Ubuntu Server 14.04.
    /dev/sdb1 is mounted as /images (/dev/sdb1 is an iSCSI target on a SAN)

    I’m having a similar issue with FTP as noted here:

    The image uploads as it should then I get a never ending FTP authentication error (not the same as the one listed in the Wiki):
    [CODE]FOGFTP: Login failed, Host: fogipaddress, Username: fog, Password: hashedpassword, Error: ftp_login(): Login incorrect,[/CODE]

    Doing as the Wiki says an moving/renaming the uploaded directory works but it the fix listed appears to be for Fog 0.32 as Post_Stage2.php is completely different in 0.33b comparing it to our live 0.32 server.

  • I was running 1491, just checked out 1493. Testing now.


  • Developer


    If so the issue is likely password related.

    Try setting your ftp info under the fog settings tab.

    If that doesn’t work reset the password to what you have in the fog UI settings on the Ubuntu system itself.

  • Checked out the latest revision using SVN.

  • Developer

    [QUOTE]I’m still getting the same error with the latest revision. [/QUOTE]
    Where did you get the latest version from?

  • I’m still getting the same error with the latest revision.

  • Its purely a test setup at the minute, we have a live Fog setup running on Ubuntu 10.04 LTS which has been running for years.
    Its likely we’ll go with 14.04 as a production server in the future but [SIZE=2]the old server will still be available as a backup.[/SIZE]

    I’ll try a newer revision now, thank you.

  • Developer

    “Ubuntu Server 14.04” This distro is barely a week old. I wouldn’t recommend using it for a server…

    Also Revision [SIZE=13px][FONT=arial][COLOR=#262626]r1483 fixes your issue.[/COLOR][/FONT][/SIZE]

    Here is the fix as you’ve already installed:

    [LEFT] [/LEFT]
    [LEFT][COLOR=#141414][SIZE=13px][FONT=Tahoma][COLOR=#141414][SIZE=13px][FONT=Tahoma][SIZE=13px][FONT=Tahoma][COLOR=#141414]The fix is to edit the /etc/passwd file[/COLOR][/FONT][/SIZE][/FONT][/SIZE][/COLOR][/FONT][/SIZE][/COLOR][/LEFT]
    [CODE]sudo gedit /etc/passwd[/CODE]

    [LEFT][COLOR=#141414][SIZE=13px][FONT=Tahoma][COLOR=#141414][SIZE=13px][FONT=Tahoma][SIZE=13px][FONT=Tahoma][COLOR=#141414]Edit the bottom line to look like the following[/COLOR][/FONT][/SIZE][/FONT][/SIZE][/COLOR][/FONT][/SIZE][/COLOR][/LEFT]


    [LEFT][COLOR=#141414][SIZE=13px][FONT=Tahoma][COLOR=#141414][SIZE=13px][FONT=Tahoma][SIZE=13px][FONT=Tahoma][COLOR=#141414]Save and reboot, all should be well.[/COLOR][/FONT][/SIZE][/FONT][/SIZE][/COLOR][/FONT][/SIZE][/COLOR][/LEFT][/QUOTE][LEFT][/LEFT]
    [LEFT] [/LEFT]