FOG 33b - installation - HP Elite 8300 SFF


  • I’m getting SystemRescueCD
    It has GPTdisk 0.8.8 (the latest is 0.8.10)


  • Tried imaging the USDT - Exactly the same problem. Now I must use this sgdisk syntax.
    I’ll assume that I need to download an ISO of sgdisk and burn it to CD then boot off that. (I know: sgdisk not gsdisk)
    Unless I’m told something else. Man I’m running out of time. The teachers come back Tuesday 22nd.


  • I see. I’ll try taking an image anyway just to check if GParted did the job.

    Exactly how and where do I use that syntax? Do I need to download a gsdisk ISO and burn a gsdisk boot CD?

  • Developer

    Gparted may have wiped the partitions but not the boot sector. I haven’t used Gparted in a while and i’m not sure how GPT aware it is. Tom, does it sound possible that fog is seeing leftover bits of the GPT information in the boot sector, and looking for GPT, when the partitions are actually MBR?


  • Yes and no.

    GPT likes to leave stale elements. I, do however, believe even if it’s an intentional MBR/GPT structure, it’s still going to report as MBR on Windows Disk Management.

    Running sgdisk -Z /dev/sda removes the entire partitioning table completely. It’s essentially turning the drive into an uninitialized drive.

    I think this is why you’re seeing the issues you are. Just because Windows DiskManagement references it as MBR DOES NOT MEAN it is a pure MBR filestructure.

    This is why the fixparts was suggested, it will find all GPT structures (whether real or just left over) and remove them. sgdisk -Z /dev/sda does this in one nice and neat little command rather than having fixparts try to guess what’s what.


  • I need to state something clearly here: Both of these models, the USDT and the SFF, have MBR partitions.

    How do I know that:
    Windows Computer Management
    Disk Management
    Right click on Disk 0
    Properties
    Volumes
    Partition style = MBR

    The USDT had GPT before. Confirmed via Disk Management.
    I used GParted Live Boot CD to delete ALL partitions on this USDT model leaving only unallocated space.
    Having deactivated UEFI completely in the BIOS I reinstalled Windows 8.1 and ended up with an MBR partition/drive which can now pxe boot without any problem. I did not have time today to try capturing an imaging from this PC.

    The other model is SFF. Yes it did appear to have an active “UEFI Boot Order” menu in the BIOS. But no it never had a GPT partition. It has ALWAYS been MBR - comfirmed via “Disk Management” as described above. This is the model I tried to capture an image from earlier today which failed. These are all facts.

    But is there something I don’t understand here? Are you saying it is possible to have the primary partition as MBR and the disk still be GPT? Remember Windows “Disk Management” is telling me that Disk 0 is MBR. And Disk 0 is the entire drive which contains at least 2 partitions.

    I thought GParted deleted everything. Is that assumption wrong?
    Does sgdisk -Z /dev/sda remove more?

    Tomorrow first thing I will try to take an image from the USDT model.


  • Yes.

    GPT doesn’t just disappear which is why I was recommending you to do the sgdisk -Z /dev/sda command. That will wipe out all partition information on the drive and allow you to truly install MBR.


  • But the disk is already MBR, not GPT. That’s why I didn’t have problems with PXE boot on this SFF model.
    Do I still need to wipe and re-format to MBR for some reason?

  • Developer

    Not trying to sound harsh but this error is fairly self explanitory…

    [QUOTE]Saving partitiion tables … invalid partition data [/QUOTE]

    Now that you’ve disabled UEFI, wipe the disk of all formatting, set it as MBR, THEN start the windows install.


  • This time I did not stop the task on the console.
    Instead I hit CTRL C on the client.
    It raced forward, created an empty image folder on the fogserver and rebooted back through pxe to Windows.


  • I don’t know if this is relevant.

    Although I never had a problem with this Classroom-1 SFF model with regard to PXE, the BIOS always had an active “UEFI Boot Order” selection menu which was above the “Legacy Boot Order” menu. So I have now deactivated the UEFI menu and tried to take the image again. Same result.


  • I stopped the task on the console.
    Then used CTRL C on the client which then led to the following lines:
    Using hardisk sda
    Saving partitiion tables … invalid partition data


  • I’m trying to take an image of the Classroom-1 SFF
    The pxe process started ok going through a check list:
    Checking OS = win 8
    CPU cores = 4
    etc…
    until
    Looking for harddisks…Done
    flashing cursor


  • It works!!

    Used GParted to delete all partitions. (Didn’t want to bother you Tom to ask what you meant by “Boot the system as a debug task”. Chinese to me. So I took a chance on GParted.)

    Disconnected network cable. (to avoid auto downloading of app store programs and other stuff after installation)
    Deactivated UEFI in BIOS.
    Put CD at top under “Legacy Boot Order”
    Reboot
    With no intervention did not boot from Win 8.1 DVD !!
    Reboot
    Need to press ESC to enter what I call the UEFI option page. Many UEFI options there including boot order. Weird since I have already deactivated “UEFI Boot Order” in BIOS.
    Select Boot to CD - “Sata”
    Win 8.1 DVD fires up
    I do not do any partitioning. The disk space is unallocated. NEXT
    After installation, the first page comes up asking for desktop colour and PC name. I press CTRL-Shift-F3 to enter Audit Mode.
    I confirmed that the drive is now MBR !! Amazing.
    Reboot to pxe fog and register client.
    Reboot and with no intervention end up in Audit Mode.
    Yeeeeeeeeees!!

    Now, FINALLY, I can try imaging from Audit Mode.

    Thanks so much Tom and JunkHacker!!

    I’ll let you know how the imaging goes.


  • I stated that in my last message.

    To completely wipe the drive of any and all GPT and/or MBR data:
    Boot the system as a debug task. At the terminal prompt type:

    [code]sgdisk -Z /dev/sda[/code]

    Delete the tasking and create your “base” image. Then upload the image. You should be good.


  • OK I’m sorry, I think I’m confusing you.
    The 0x80 issue relates to the very old HP clients which I need to wipe or hopefully install Ubuntu 12 on, to give away to students or parents. I understand, I think fully, your advice about how to solve that issue. And I might do what you say there.

    But much more important are the new HP Elite 8300 USDT clients that I need to get out to all the teachers. I have installed win 8.1 on one of these clients called “Teacher-1” This has the bios problem and the GPT drive.

    The other new HP Elite 8300 clients are SFF and are for the classrooms and I have installed win 8.1 on one called “Classroom-1”.
    (By the way I have confirmed that this Classroom-1 SFF model has an MBR drive, which is interesting since it also has a list of active UEFI boot options which have not automatically resulted in the creation of a GPT drive - curious. This should be no problem to image.)

    From my understanding we are not talking about fog or imaging now.

    I can in fact completely deactivate UEFI in the bios of the Teacher-1 USDT.
    I just need to wipe the disk somehow and then reinstall Win 8.1 with only legacy bios options active.
    That should result in the creation of an MBR drive.

    I’ve done some research and now know what a GPT drive is.

    Bottom line - how do I wipe the GPT drive, or how do I proceed to re-install Win 8.1? I have the latest Gparted Live boot CD if that’s a help.


  • Alistair,

    You can do a legacy boot. You stated that earlier. The only difference for your particular scenario is that you’ll have to change the boot order of the devices.

    I don’t agree with Junkhacker’s assessment wholly as I’ve created images using GPT formatting and Legacy PXE Boot. FOG 0.33b automates some of this process for you.

    If you want to create a wholly Legacy system, you need to disable UEFI entirely in the BIOS. You state you cannot do this, so based on this I don’t know what to tell you.

    To create an MBR based image, you would need to make sure the drive is formatted in MBR format. Load the system up with debug mode, perform[code]sgdisk -Z /dev/sda[/code] To wipe the drive of all partition/gpt/mbr information. Boot the system in Legacy Mode (MUST DO THIS) and create your Image from scratch.

    If you cannot boot the system in Legacy mode for whatever the reason, it doesn’t matter how many times you try, your system is going to try to load windows using the GPT format structure, and you’ll be stuck in EXACTLY the same situation as you are now.

    To allow the system to boot:

    Change the relevant lines in BootMenu.class.php
    (LINE 107 in current revision)
    [php]print “prompt --key “.($this->KS && $this->KS->isValid() ? $this->KS->get(‘ascii’) : ‘0x1b’).” --timeout $this->timeout Booting… (Press “.($this->KS && $this-> KS->isValid() ? $this->KS->get(‘name’) : ‘Escape’).” to access the menu) && goto menuAccess || sanboot --no-describe --drive 0x80\n”;[/php]
    TO SAY:
    [php]print “prompt --key “.($this->KS && $this->KS->isValid() ? $this->KS->get(‘ascii’) : ‘0x1b’).” --timeout $this->timeout Booting… (Press “.($this->KS && $this-> KS->isValid() ? $this->KS->get(‘name’) : ‘Escape’).” to access the menu) && goto menuAccess || exit\n”;[/php]
    (LINE 221 in current revision)
    [php] print “sanboot --no-describe --drive 0x80\n”;[/php]
    TO SAY:
    [php]print “exit\n”;[/php]
    (LINE 333 in current revision)
    [php]print “sanboot --no-describe --drive 0x80 || goto MENU\n”;[/php]
    TO SAY:
    [php]print “exit || goto MENU\n”;[/php]


  • “the GPT formatted disk means that you installed windows with UEFI enabled, and it has configured the hard disk as such. if you wipe the drive and re-install windows like you did before, but under Legacy, your hard disk will not be configured as GPT”

    Tom, do you agree with Junkhacker? I need to take action now today.

    Junkhacker, what is the quickest, easiest way to wipe the disk when I cannot do a legacy boot? Not sure about how to proceed.


  • Also, the line:
    [code]sanboot --no-describe --drive 0x80 || exit[/code] will not work because iPXE doesn’t know that the sanboot has failed. Hence why the system freezes. This is most likely due to the bug in the firmware HP has. This is also seen on many Dell systems. Simply make sure the PXE system is set to boot, and change the sanboot --no-describe --drive 0x80 lines are replace with just exit. Exit will drop the system back to BIOS which should allow everything to boot normally, even if your hard drivers are formatted as GPT.


  • That said, you will still need to make sure UEFI Mode is not enabled for the NICs. UEFI PXE Boot does not work quite yet.

343
Online

10.1k
Users

16.3k
Topics

149.6k
Posts