FOG 33b - installation - HP Elite 8300 SFF

  • Developer

    [QUOTE]Server 2012 R2 already had DHCP scope options:
    066 = fogserver[/QUOTE]

    Are you sure you set this ip to the ip of the NEW FOG server you made, not the old one?

    Also that is not a bug, that is how the UI functions.

    To add hosts to a group go under the groups tab and select a group then click membership and add the hosts you want.


  • There is a bug in hosts window.
    When there are many hosts, the option at the bottom of the page to put selected hosts into a group has vanished.

  • Developer

    can you include some screen shots of what you see, the task page for example and the booting clients??

    You are giving us almost nothing to go off of and it makes identifying the problem very difficult…


  • Bug in hosts page.
    With many new hosts, the option to add them to a group at the bottom vanishes.


  • On the management console the Ubuntu-12 image appears to be 9.07 MiB.
    But on fogserver itself they are:
    d1p1 = 1.4 GB
    d1p2 = 1.0 kB
    d1p5 = 635.6 MB


  • I have just tried to deploy Linux to 13 PCs in 1 classroom.
    All booted automatically and loaded the pxe file.
    But they did not pick up the image. They just
    rebooted to pxe fog window
    rebooted to pxe fog window
    rebooted to pxe fog window
    endlessly

    It’s 21:30 now and this is a real downer.


  • The new code worked. The old HPs are now going further after the pxe fog and booting into the OS.


  • Thanks and sorry. I thought that code was something to do with GPT.



  • Tom I need to use the following you suggested:
    sanboot --no-describe --drive 0x80 is the line in BootMenu.class.php that deals with how to pass to the harddrive. That said, not all systems like this method. If your systems are freezing. Try changing those lines to just say: exit.

    Do I change all 3 places this text appears in the file?

    There is additional text on these lines. Precisely which words do I replace with exit.
    Is it only the words: “sanboot --no-describe --drive 0x80” ?

    I need an answer as soon as possible.

  • Developer

  • Developer

    Doesn’t seem like the hpa service is starting fully or is starting too soon.

    You can always check the system logs and see if it’s providing any errors when it’s starting.


  • Restarted DNS on server - No joy

    I stopped tftpd-hpa and then started it. That fixed it. Now it’s working.

    sudo stop tftpd-hpa
    sudo start tftpd-hpa

    What a relief.
    Anyone have any idea why?


  • I used Clonezilla before on the old HP version 32 fogserver without problem.

    Can I check anything else on fogserver?


  • I suspect the problem is the fogserver because after the reboot, the “Brightness Lock” settings were wrong.
    I had set them 2 days ago to never turn off the screen with inactivity, and it worked. But after the Clonezilla imaging and reboot, the screen turned itself off after 10 minutes. Even though the settings are “never”.

    status mysql = running
    status tftpd-hpa = running


  • I used Clonezilla to take an image of fogserver now that everything is working. Task completed.
    Rebooted fogserver
    Tried to take an image of the new HP SFF and discovered that I’m back to PXE TFTP timeout on the client.
    That issue was already resolved by using IP address 10.0.1.40 under DHCP scope option 066.
    tftpd-hpa is already running on fogserver.
    I’ll try rebooting fogserver again. No joy.
    I’ll restart DHCP on server. No joy.
    I don’t believe this!!


  • Yes, sorry I didn’t get to respond sooner. I was driving in to work.

    In the future, just understand that you didn’t need to download a rescue disk.

    Where you go to schedule a task, you can choose advanced options and choose a download or upload task with the phrase Debug after it. It will boot the client system and drop the system into a terminal prompt screen where you can type commands. You didn’t have to download a CD to boot into to run the command.


  • The image is captured and present on fogserver. I’ll try deploying it tonight to another client.

    Well now I’ve learnt something. MBR is not always MBR.
    And deleting all partitions with GParted does not delete the Boot Sector.

    Thanks for sticking with me on this Tom and JunkHacker.


  • It works. It’s taking an image!!


  • I confirmed that the BIOS has “EUFI Boot Order” completely disabled.
    Booted from SystemRescue-CD. Ended up seeing the following:

    root@sysresccd /root %

    I typed:
    sgdisk -Z /dev/sda

    “Invalid partition data!”
    “GPT data structures destroyed! You may now partition the disk using fdisk or other utilities.”

    Somewhat confusing to see the line “Invalid partition data”. But the 2nd line gives the impression that the job is done.
    I assume now that I will not create any partitions myself but allow the Win 8.1 DVD to do it for me.
    Is that correct?

344
Online

10.1k
Users

16.3k
Topics

149.6k
Posts