FOG 33b - installation - HP Elite 8300 SFF


  • Multicast does not work again.


  • TFTP is still not running despite the mod to /etc/rc.local

    Here is a copy of the file. Is there anything wrong?

    #!/bin/sh -e

    rc.local

    This script is executed at the end of each multiuser runlevel.

    Make sure that the script will “exit 0” on success or any other

    value on error.

    In order to enable or disable this script just change the execution

    bits.

    By default this script does nothing.

    /bin/sleep30 && /etc/init.d/tftpd-hpa restart
    exit 0

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

    In order to enable or disable this script just change the execution

    bits. (no idea what this means. Do I need to enable this script?)

  • Developer

    For now I would do as you suggested, run a delayed start up of the command, or just restart the service on each reboot. You are welcome for the the suggestion, don’t feel bad when I get stressed about a fog issue someone else normally comes up with an easy test for me too, just paying it forward 😉


  • Tom I just read your comment from last year:
    [I]Has anyone in this thread found this issue with 0.33b? Maybe I can append/sed the command into the installation so nobody has to worry about this! [/I]

    Sounds like a good idea[I].[/I]


  • Probably need to implement the delayed startup of TFTP that’s been mentioned earlier.
    Obviously that will solve the TFTP … (waiting) on the clients.

    But could there also be a connection between this and the image not being multicasted?

    I hope a delayed startup of tftpd-hpa will also solve the multicast problem and eliminate the need to reboot fogserver.

    When it comes to computers, I just seem to attract bugs and issues.
    Computers are not impressed with my natural charm and charisma


  • I’m so tired and stressed out about this that I didn’t think of the obvious Jaymes that you did think of.
    I did what you said.
    fogserver, win server 2012, my PC and 2 clients (I used the win server because it was quicker - it had DHCP)

    Same result, waiting for image… BUT.

    Rebooted fogserver
    TFTP …
    Restarted tftpd-hpa

    Then multitasking worked to the new PCs!!!
    Have to go home now. Thanks Jaymes.

  • Developer

    I think you are chasing a ghost in the machines. You need to concentrate on a single issue and solve it before moving forward. And I doubt the firewall is the issue. The firewalls position is between your network and the world to act as a bouncer. Your fog server doesn’t send information to the world to come back to the network, it sits on the network and sends information on the local network ONLY, if your fog server is being passed through your firewall, something is wrong. Therefore it is highly unlikely that the firewall would cause the issue. NOW there could be a firewall installed in linux that could cause some issues, but I don’t think that pertains here.

    Try eliminating the switch gear and attempt to image on a small hub or router (You will need something doling ip addresses to pxe boot) and try your set up on a few machines, if the multicast completes as expected you need to look at the settings in your network on your switch gear. If you have to set up a “test” environment on a few old hubs and try the set up, don’t use the main switches.


  • The Cisco switch says: By default, all Multicast frames are flooded to all ports of the VLAN

    Palo Alto - have not found any relevant info. The guy that helps me with the PaloAlto is uncontactable.

    One thing is clear here - everything is in 1 broadcast domain, so it’s unlikely that multicasting has been filtered.

    I’m stuck.


  • [I]We don’t mind helping out but you need to start searching for the basic info you are looking for especially when it’s related to your own hardware. [/I]

    Absolutely.

  • Developer

    That would depend on your device. As for finding the options, again… google searches will save your life…

    We don’t mind helping out but you need to start searching for the basic info you are looking for especially when it’s related to your own hardware.


  • Although we have 6 VLANS, everything we are talking about here is in the same VLAN-1 and physically connected to the same switch.
    I’m not sure how to find out if multicast has been disabled or not. But it was not disallowed before, before we set up the VLANS.
    Isn’t it normal by default to have multicast enabled in each VLAN?

    Our gateways for all our VLANS are on a new PaloAlto PA-200 firewall. Not sure if that is creating a problem for multicast packets.
    I’m looking at the PaloAlto user interface but cannot find any reference to multicast traffic yet.

    But isn’t it normal by default to have multicast enabled in each vlan?


  • Don’t forget, multicast traffic only sends broadcast traffic across it’s own subnet. If you want broadcast traffic to pass through to other VLAN’s you’d likely need to enable ip broadcast forwarding so it can cross subnets into the realm’s you’re specifically requesting.


  • That’s a good point about multicast because I have just set up a new multi VLAN network on pre-existing switches.
    Maybe multicast has been disallowed. hmmm


  • The Starting to restore image (-) to device (/dev/sda1) line means it’s getting its data from Standard Input, this is expected to happen.

    Does your network allow for multicast traffic or is it filtered?

    Just because something doesn’t work, doesn’t automatically make it a FOG issue. You need to check all of your stuff before trying to place the blame on FOG.

    The reason I say this is because, I can multicast using the same revision (I’m guessing) that you are.


  • No the deployment to a single old HP did not work. Exactly the same result as with the multicast to those old HPs yesterday.

    Now I’ll try to write down the error messages on both old and new HPs.


  • The multicast to 3 new USDT PCs stopped, froze waiting at the PartClone white window in a blue frame.

    With one line of text at top:
    Starting to restore image (-) to device (/dev/sda1)

    Notice the image is (-)

    Looks like multicast is not finding the image, the same image I have just sent successfully to one of these 3 PCs.

    This would also explain why the multicast to the old HPs did not work.

    I will now try deploying Linux to a single old HP PC in the same classroom where the Linux multicast did not work yesterday.
    I’m hoping that might work, showing that the problem is in multicast.


  • Tried sending a single image to one of the NEW Elite 8300 USDT.
    It worked!
    This means that most things must be correct on the fogserver and server 2012 domain controller.
    I will now try a multi cast deploy to 3 of the new USDT. If that works, then that points to a problem with the old HP DC7100 PCs or the Linux image or the network in that classroom.

  • Developer

    As long as option 67 is set to undionly.kpxe then when you are back in the office post some screen shots of the tasks page and what the client are seeing during their pxe boot.


  • Server 2012
    066 = 10.0.1.40 which is the new fogserver.


  • I’m too tired to do this now. I need to go home now. It’s 10PM.

307
Online

10.1k
Users

16.3k
Topics

149.5k
Posts