FOG 33b - installation - HP Elite 8300 SFF

  • Developer

    [quote=“Alistair, post: 25693, member: 1830”]tftp client is now installed on win 8.1 client in Audit mode (one of the PCs that has been receiving the images)

    tftp 10.0.1.40 get undionly.kpxe
    flashing cursor…
    “Connect request failed”

    I’ll try turning off firewall[/quote]

    yes please disable the firewall it causes issues.

    I read your posts, I understand you are using that Firewall, that is fine but for now we are trying to eliminate it as a possibility of the errors, so eliminate extra switch gear use only the router. I understand your set up, that is fine but first lets get for WORKING then lets introduce it to the network. Adding Servers is like adding fish to your aquarium, you need to make sure that the “fish” get use to the temperature of you water, and then you can relase them, same thing here, lets let FOG get use to being in the workplace and working then lets release it to the production environment. If the router worked yesterday for multicast, then it will work today, we just have to figure out what is failing and why.

    Why are you rebooting the server after you get it working are you a glutton for punishment?

    on a side note I am going to test multicasting.


  • tftp client is now installed on win 8.1 client in Audit mode (one of the PCs that has been receiving the images)

    tftp 10.0.1.40 get undionly.kpxe
    flashing cursor…
    “Connect request failed”

    I’ll try turning off firewall


  • This simple network router is a domestic wireless router that I have lying around.
    My main system router is a new expensive PaloAlto Firewall which is the gateway for 6 vlans.
    But as I said earlier, all of these new and old HP PCs, server, fogserver etc are on only 1 vlan.
    There is no cross vlan interaction. There are no multiple systems that concern us here. Just one.
    The PaloAlto should have no problem at all in handling multicast.
    The simple domestic router I’m using right now did in fact work with multicast yesterday after I rebooted fogserver.
    My central switch is a Cisco SG-300-52 port gigabit.

    When multicast is working, [U]it appears to keep on working for multiple jobs until I reboot fogserver.[/U]
    When multicast is not working, it never works again without rebooting.

  • Developer

    [quote=“Alistair, post: 25689, member: 1830”]Still on the simple 1 router network.

    A unicast to a group of 2 PCs has worked.

    tftp 10.0.1.40 get undionly.kpxe
    “tftp not recognised as an internal command”[/quote]

    I assume windows 7?

    The tftp command is not available by default in Windows 7 but can be enabled by turning on the TFTP Client Windows feature from Programs and Features in Control Panel.

    That is my fault, I still have Windows xp floating around that I use for my virtualized images, I usually run commands from there, I had forgotten that the latest revisions of windows don’t have tftp enabled by default.

  • Developer

    tftp client is not installed by default in windows, add it in the “turn windows features on or off” section of “programs and features”


  • Still on the simple 1 router network.

    A unicast to a group of 2 PCs has worked.

    tftp 10.0.1.40 get undionly.kpxe
    “tftp not recognised as an internal command”

  • Developer

    [quote=“Alistair, post: 25686, member: 1830”]
    Thanks Tom for the typo correction - To avoid a typo I copied the syntax directly from:
    [url]http://fogproject.org/forum/threads/ubuntu-11-04-distro-that-just-works-heres-how.4378/#post-12571[/url]
    I just cannot win here.[/quote]

    That one was my fault there was no space between sleep and 30, I have fixed the post so the problem shouldn’t be present in the future.

    Alright so now we have determined the problem to be with the multicast directly. So here’s something for you to ponder, it is NOT the tftpd-hpa service, if it were, unicast would fail, and any attempts to use a command to communicate with the tftp server would fail.

    WITHOUT REBOOTING OR DOING ANYTHING ELSE, while your unicast works and multicast doesn’t, use the tftp get command on a windows machine on the 4 port switch.

    use this command
    [code]
    tftp IPADDRESSOFFOG get undionly.kpxe
    [/code]

    If the command succeeds. It is not a problem of the tftpd-hpa service, it may be the hardware you are using. If you are successful, and you can image the machines via unicast, please try a unicast group to see if you are able to achieve imaging multiple machines. If successful, look into a business class switch or hub and try multicasting again.

    Multicast is not supported by all hardware.

    I don’t want to sound pompous, but this may not be an issue of FOG, this may be an issue of the gear you are using.


  • Just because you have multiple systems, does not mean you have to Multicast to get a job to work. You can schedule both systems as Unicast tasks, even if they have the same image and information.

    Beyond that, what kind of router are you using? My home network goes completely dead if I try to multicast to two systems at the same time as the Router I have at home is a typical Consumer router.

    I imagine it’s the same issue being experienced here.


  • [U]I am back on the simple one 4port router network with:[/U]
    Server 2012 (for DHCP)
    fogserver (I am running management console here)
    2 clients
    I pinged router and server - both respond.

    Rebooted fogserver
    stop start tftpd
    Multicast to 2 PCs
    Multicast not work
    Cancel tasks
    Unicast to 1 PC
    Worked.
    Multicast to 2 PCs
    Multicast not work

    Thanks Tom for the typo correction - To avoid a typo I copied the syntax directly from:
    [url]http://fogproject.org/forum/threads/ubuntu-11-04-distro-that-just-works-heres-how.4378/#post-12571[/url]
    I just cannot win here.


  • [quote=“Alistair, post: 25671, member: 1830”]TFTP is still not running despite the mod to /etc/rc.local

    Here is a copy of the file. Is there anything wrong?

    #!/bin/sh -e

    rc.local

    This script is executed at the end of each multiuser runlevel.

    Make sure that the script will “exit 0” on success or any other

    value on error.

    In order to enable or disable this script just change the execution

    bits.

    By default this script does nothing.

    /bin/sleep30 && /etc/init.d/tftpd-hpa restart
    exit 0

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

    In order to enable or disable this script just change the execution

    bits. (no idea what this means. Do I need to enable this script?)[/quote]

    I believe your script has a typo:

    I should read as:
    [code]
    #!/bin/sh -e

    rc.local

    This script is executed at the end of each multiuser runlevel.

    Make sure that the script will “exit 0” on success or any other

    value on error.

    In order to enable or disable this script just change the execution

    bits.

    By default this script does nothing.

    /bin/sleep 30 && /etc/init.d/tftpd-hpa restart
    exit 0[/code]

    Major difference is that there was no space between sleep and 30 originally so it read: sleep30, I made it read sleep 30.

  • Developer

    Why multicast then? Try unicast to multiple hosts, I personally hate using multicast because if a host drops out in the middle of imaging, your whole group is hosed. I set up a group of members and push a unicast to each of those machines at once. only 10 will image at a time but they will wait in que until a spot opens up and then image.

    Try unicast imaging, it uses the tftp-hda service to push to single units too, try it before you multicast.

    So reboot, try single unit image, is it successful?
    If not, and it is because of the service, restart it and push image again, was it successful?

    after successful unicast, try multicast, did it fail? Try unicast again, did it succeed?

    what I’m trying to do here is figure out if it is the tftpd-hpa service, or if it is just the multicasting ability.

    Sorry to give you so much to do, but I want to get some direction going here. Is the multicast only failing for these units? Are you still working on a test switch setup like I suggested? Try these troubleshooting steps I recommended OFF of the network, so we can make sure the FOG server is working.

    We want to get multicast for SURE working before you put it in the production environment because some switch gear causes issues.


  • I repeated the above procedure only one time and multicast failed to my horror.

    This failure of multicast is totally unpredictable.

    Jaymes, the syntax sudo stop tftpd-hpa does in fact work. It is confirmed on the following line that tftpd is not running.
    But I will use the syntax you recommend from now on.

    You wrote: [B]If I were you I would manually type the commands at the restart of the server.[/B]
    A have done that [U]everytime[/U] as I listed above. Multicast works sometimes and not others.
    This is crazy. I had the TFTP problem with the old fogserver and old HP clients. But that was easily fixed with the start stop syntax.
    Never had a problem with multicast, if that is in fact the real problem here.

  • Developer

    [code]
    sudo service tftpd-hpa stop
    sudo service tftpd-hpa start
    [/code]

    Is what you should be using.

    You are lucky "sudo stop tftpd-hpa " even works at all, this is not how you syntax a service restart.

    You have confirmed that there is a bug in the tftpd-hpa up start service, this is a known issue where the service is started before an ip address is even assigned to the machine.

    [B]If I were you I would manually type the commands at the restart of the server.[/B]

    This is not a problem of fog, your fog server is working as expected. If you want help in resolving the issue, please try an Ubuntu forum, the people there are very nice and will help you to better understand the problem you are facing and how to fix it!


  • Reboot
    Log in window appears
    Have not logged in.
    Wait 1 minute.
    Multicast to 3 PCs
    TFTP… waiting
    Cancel fog tasks
    Log in to fogserver
    Wait 1 minute
    Multicast to 3 Pcs
    TFTP…
    Cancel fog tasks
    sudo service tftpd-hpa restart
    Multicast to 3 PCs
    TFTP works
    Multicast failed - same white window with blue frame
    Cancel fog tasks

    Reboot fogserver
    Log in
    wait 1 minute
    sudo service tftpd-hpa restart
    Multicast to 3 PCs
    Multicast failed !!! (strange, I thought this would work now)
    Cancel fog tasks

    Reboot fogserver
    Log in
    wait 1 minute
    sudo service tftpd-hpa restart
    Multicast to 3 PCs
    Multicast failed again !!!
    Cancel fog tasks

    Reboot fogserver
    Log in
    wait 1 minute
    sudo stop tftpd-hpa
    sudo start tftpd-hpa
    Multicast to 3 PCs
    Multicast Worked (note that this time I stopped tftp first and then started it 10 seconds later)

    I am now going to reboot fogserver and repeat the above procedure 2 more times to confirm working with stop and then start.


  • Tom you wrote:

    Shouldn’t the proper commands to restart the service be:
    Code:
    sudo service tftpd-hpa restart
    I just realized that you are probably referring to the script used in rc.local? I thought you were commenting on when I wrote:

    This time I rebooted fogserver, logged in, waited 2 minutes,
    sudo stop tftpd-hpa
    sudo start tftpd-hpa

    I have now used the following line in rc.local, including sudo:

    /bin/sleep30 && sudo /etc/init.d/tftpd-hpa restart


  • Have now multicast the Ubuntu-12 image to the same classroom of old HPs - as expected did not work.
    Then for the 3rd time I multicast Win 8.1 successfully to the 3 same new HPs.

    3 successful multicasts of Win 8.1
    1 failed multicast of Ubuntu to old HPs.


  • Shouldn’t the proper commands to restart the service be:
    [code]sudo service tftpd-hpa restart[/code]


  • I suspect Firefox or LibreOffice may be the culprits.
    I know it is not good practise to use other programs on a dedicated server, but it makes it so much easier to to get this fog stuff done and sorted by using Firefox and LibreOffice on fogserver.

    OK I am going to work through this systematically.
    I am not touching the fogserver desktop. (remember I only logged in and then stopped and started tftpd-hpa.)
    I am now multicasting again for a 2nd time succesfully to the 3 clients. To prove that it wasn’t a one off fluke. It can be repeated.

  • Developer

    I guess you will need to run the script yourself to stop and start the service, it’s not like it is a long command.


  • Now it is working (multicast to the same 3 new PCs)

    Trying to understand the sequence of events that leads to it not working and then working.

    This time I rebooted fogserver, logged in, waited 2 minutes,
    sudo stop tftpd-hpa
    sudo start tftpd-hpa

    From my PC - multicast to 3 PCs which worked

312
Online

10.1k
Users

16.3k
Topics

149.5k
Posts